Jump to content

WD MyBook - Error 1115 (Disk Full) due to FAT32


Recommended Posts

I hope this helps someone some day, it was "an educational experience" that occupied my whole afternoon!


I'm on Win XP Media Center Edition (not my choice, came w/the machine) on a Toshiba Satellite laptop. I'm using Retrospect Express HD 2.0.145 that came with my 500 GB WD MyBook Premium ES USB external drive. FWIW it came out of the box formatted with a FAT32 file system. Turns out that can be problematic.


I had to send the PC to Toshiba for optical drive replacement recently, and they did me the favor (!) of re-imaging the HDD. Effing swell. The MyBook+Retrospect saved me much grief! I restored the whole HDD and most everything worked OK. I only had to re-install three apps, so things could have been much worse since I didn't lose any *data*.


So, the *replaced* optical drive worked for all of 4 days. Effing swell, back to Toshiba for another whack! at it. I tried to do an immediate backup before shipping the computer off but it failed with an Error 1115, not enough disk space to save the backup. That seemed very peculiar because Explorer reported 260 GB (yes, more than half the disk) free space. I tried numerous things but nothing worked so those steps aren't worth chronicling.


I spent a couple hours searching for any info on what might cause a half-full 500 GB disk to report a lack of space. Then I noticed that the RestorePoint.rbc file in the "Retrospect Restore Points" folder was right at 4 GB in size. Therein lies the rub, that's the maximum file size for a FAT32 partition. Retrospect couldn't update the catalog with the new restore information because of the FS limitations. I didn't know that then but I do now.


After that revelation I found a link on the WD site that pointed me to Microsoft's Support pages with the skinny on using "convert.exe" to convert the FS from FAT32 to NTFS (which does not have the 4 GB file size limitation). Not for the faint-hearted for sure! But after trying that, and after renaming the RestorePoint.rbc file and letting Retrospect rebuild it under NTFS (took about 4 hours), I was able to perform an immediate backup again and all is well.


So, if you have just purchased one of the WD MyBook (or anybody's) external drives formatted with FAT32, before you perform any backups either convert it or re-partition it to NTFS. (Back up the pre-loaded software files first!) It might save you an afternoon or more of anxiety and grief if you're going to be storing a large quantity of backup data.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...