Jump to content

Open File Backup Error (1017)

Recommended Posts

I seem to have developed a problem with open file backup. I am using Multi Server version 6.5.382 with open file backup to back up a XP Pro SP2 box (where Retrospect is installed) and several laptops on the network, all of which have the Retrospect client installed. Retrospect is running with admin privileges.


I recently added a Vista Home Premium laptop to the network, installed the client, and promptly started getting errors on the first backup. Error message reads:


Can't use Open File Backup option for xxx on yyy, error -1017 (insufficient permissions)


This error precipitates others due to the fact that Retrospect is unable to use the open file backup option, like:


File "xxx": can't read, error -1020 (sharing violation)


I have checked both the XP box and the Vista laptop to ensure that the Shadow copy service is set to “automatic” and that there were/are no errors starting the service.


Still getting the errors… any ideas? What am I missing?

Link to comment
Share on other sites

  • 3 months later...

We are running into this error on all of our 64-Bit Windows 2003 Servers in VMWARE. I have tried every Microsoft patch and registry change on the planet it seems. Still no help. What bugs me is that I don;t believe VMWARE is the issue, as our 32-bit images backup just fine. Still scratching my head over this. Anyone actually fixed this yet?



Link to comment
Share on other sites



This worked on our "NewSidded" 64-bit ESX boxes. It tunrs out that when you run "NewSID" or any other SID generator on 64-bit images, it hoses VSS. This is how we fixed it, and we are now backing up all of our 64-bit VMWARE servers. Good luck! Be SURE to check the directory paths. That was our problem the whole time. We kept registering the system32 folder dlls.




1. Stop the Microsoft Shadow Copy Provider & Volume Shadow Copy Service




2. Export the contents of the HKLM\Software\Microsoft\EventSystem key to a .reg file (as a backup).


3. Delete the HKLM\Software\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions key. (Just delete the Subscriptions subkey; leave the EventClasses key.)


4. Restart the server.


5. Run the "VSSADMIN LIST WRITERS" command.


This causes the VSS entries in the HKLM\Software\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions key to be rebuilt when the writers initialize.




If that does not resolve it try this:




Check the Registry - HKEY_CLASSES_ROOT\CLSID\{FAF53CC4-BD73-4E36-83F1-2B23F46E513E}\InProcServer32

- check right pane for (Default)

- ensure this is pointing to the correct location à %systemroot%\system32\ES.DLL




Try launching each of these consoles:




- perfmon /wmi

- msinfo32

- wmimgmt.msc




If the above works out without any issues, please run these commands on the server:




Net stop vss


Net stop swprv



regsvr32.exe /i %windir%\system32\eventcls.dll


regsvr32.exe /i %windir%\system32\swprv.dll


regsvr32.exe %windir%\system32\vssui.dll


regsvr32.exe %windir%\SysWOW64\vss_ps.dll


regsvr32.exe %windir%\SysWOW64\msxml.dll


regsvr32.exe %windir%\SysWOW64\msxml2.dll


regsvr32.exe %windir%\SysWOW64\msxml3.dll


regsvr32.exe %windir%\SysWOW64\msxml4.dll


regsvr32.exe %windir%\SysWOW64\ole32.dll


regsvr32.exe %windir%\SysWOW64\oleaut32.dll


regsvr32.exe %windir%\SysWOW64\es.dll


regsvr32.exe %windir%\SysWOW64\comsvcs.dll


vssvc /register


net start swprv


net start vss




Edited by Guest
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...