Jump to content

Restrospect Always requires authentication

Recommended Posts

When I launch Retrospect it asks me for my user name and password, even thought I unchecked "always require authentication." Also when I set the preferences to not require authentication under the security tab it resets back to require when I restart Retrospect.


I am running Retrospect 6.1.138 on OS X server 10.4.11


The problem is that I am not being backed up. The server was restarted and after that Retrospect stopped backing up. I have the launch Retrospect set in the preferences and I have Retrospect set as a login item. This doesn't work if someone is not there to type in the password.


Thanks for any help.

Link to comment
Share on other sites

Since Retrospect runs as a root process just by double-clicking on it, the program contains some methods to make sure it can't just run on a system without having authority to do so.


You don't describe much about your configuration, but perhaps something in your OS X Server setup is preventing Retrospect and its associated sub-processes from setting their permissions correctly.


I'd suggest making a copy of your preferences file, then using the installer to Uninstall retrospect. Then reinstall from the same installer, and replace your preferences into /Library/Preferences/Retrospect/


You might also want to run the Repair Permissions routines from Disk Utility while booted from the OS X Server install DVD.





Link to comment
Share on other sites

As a comment:


(1) because this is OS X Server (10.4.11), ACLs will be enabled on the boot volume. Don't know if this has any effect, but ACLs, if present on a folder/file, will override Unix permissions.


(2) I'm not seeing this, and never have, on our Xserve with the same versions of Retrospect, OS X server, etc.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...