Jump to content

Leopard compatibility

Recommended Posts


Is there anything else you can tell us about this?



Not much. Since updating to Leopard, I have not gotten Retrospect to do a backup. (It was working on the same machine under Tiger.) The previous version (6.1.126, I think) did the same thing. The dialog is still sitting there. Activity Monitor shows that Retrospect is taking about 80% of the CPU. I can't sample the process because it is running in Rosetta.

Link to comment
Share on other sites

How about more details?


What type of Mac?

What type of backup device?

How is the device connected to the computer?

What type of backup set?

What troubleshooting have you tried?


What we do know is that you had the problem before updating Retrospect, so the problem isn't with your version of Retrospect.

Link to comment
Share on other sites

OK, more details. It is a Mac Pro (2 x 2.66GHz dual-core Xeon). The backup device is the built-in "superdrive", an OptiArc DVD-RW drive. I was using CD-R media. (I know from previous experience that Retrospect doesn't support DVD-R media with this drive, but CD-R had been working under Tiger.) I tried an immediate backup of a folder, with a newly created catalog. If I try to stop the backup, I get the confirmation dialog, and after dismissing that, Retrospect goes into full "spinning pizza of death" mode. I tried redoing the custom configuration for the device, and got the message "Retrospect was unable to configure this drive with the inserted CD-R media". It offered to send an error log to EMC, and I gave it the OK, so I guess it did.

Link to comment
Share on other sites

I'll add to this thread as a Leopard issue.


Computer is a MacPro running OS X Server 10.5, which was a fresh install (not an upgrade from 10.4). Running the new Retrospect version for Leopard. Has three internal hard drives we wish to back up (and a fourth which we don't back up). One of the three drives is the boot drive. The backup goes to external firewire hard drives (as a File, not taking over the whole drive). Script runs under Backup Server.


The two data drives back up fine. When the script gets to the boot drive, Retrospect immediately crashes without notice. The "scanning" window appears VERY briefly, then everything goes away. There's nothing special on the boot drive - it's named "Server Boot" and does not contain any Time Machine, FileVault, etc. Only 50GB of info on the drive.


The server creates a CrashReporter log file with the date/time of the crash. The top group of lines are:


Process: Retrospect [37831]

Path: /Applications/Retrospect 6.1/Retrospect/Contents/MacOS/AuthenticateUser.app/Contents/MacOS/../../../Retrospect

Identifier: Retrospect

Version: ??? (???)

Code Type: PPC (Translated)

Parent Process: launchd [1]


Date/Time: 2007-11-13 09:16:22.263 -0500

OS Version: Mac OS X Server 10.5 (9A581)

Report Version: 6



Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000342000

Crashed Thread: 0


Thread 0 Crashed:

0 translate 0xb8160305 CallPPCFunctionAtAddressInt + 25781

1 translate 0xb816cdf4 CallPPCFunctionAtAddressInt + 77732

2 translate 0xb80bd6fb 0xb8000000 + 775931

3 translate 0xb80b6b77 0xb8000000 + 748407

4 translate 0xb80d4530 0xb8000000 + 869680

5 translate 0xb813c9e9 spin_lock_wrapper + 1981


(I can send or post the full crash report upon request.)


If I attempt a manual backup of the boot drive, I encounter the same problem (crash when the Scanning window appears after clicking Preview to select files).


Interesting thing - the fourth drive (not intended to be part of the backup set) is an internal backup drive, used by both Carbon Copy Cloner and Time Machine to keep copies of the Server Boot drive. Obviously the Time Machine data is skipped, but with CCC running the drive should be quite similar to the boot drive. So it's possible the problem could be related to the fact that it's the actual boot drive, not the data on the drive. Just a guess.


So my workaround for the time being will be to back up the Internal Backup drive, which gets me essentially the same backup as Server Boot, just an hour or two older. This is dangerous as it relies on CCC's automated backups which seems reliable but is another risk in the backup chain.


Advice appreciated.





Link to comment
Share on other sites

Thanks for the quick reply. Enabling the "don't backup ACL" preference allows the scan to take place. Backup is running now.


I ran Disk Utility immediately prior to changing the checkbox, and the drive has a clean bill of health.


Obviously I'd prefer having ACL permissions properly backed up, but this is ok for now.


The interesting tidbit is the Carbon Copy Cloner version of the drive does back up. CCC uses Ditto to copy files, which does preserve ACL's.


Thanks again,



Link to comment
Share on other sites

Hi. I've got a Quad G5 which I use to backup onto DVD-R media. Under Mac OS X 10.4, version 6.1.126 worked fine and I was pleasantly surprised to see that it continued to work fine after upgrading to 10.5 Leopard. When I saw that the update to 6.1.138 fixed an issue with selecting files which didn't actually need to be backed up again, I jumped on the updater as I've had problems with this in the past. Now, however, I cannot write any backups as it tells me "the disc is write protected. Please unlock it and try again". How does one unlock a DVD?!


I tried various things to fix it, including uninstalling the latest version and re-installing 6.1.126 but that didn't help, I tried removing the Retrospect cd file system extension but to no avail. I even used FileMerge (one of the developer tools) to compare my /Library and /System/Library directories with those from a Time Machine backup from prior to upgrading Retrospect, and removed/replaced any different files which were related to Retrospect, but I still cannot get this working again.


I have now re-installed 6.1.138 and when I got the same message again about the backup volume being locked, I clicked "Options" and "skip" to try and carry on from a new DVD. Retrospect wrote 1 file (total of 12K) before telling me "Trouble writing media 9-Backup Set D, error 100 (Device rejected command)"


Any thoughts on how I could fix this please?


For what it's worth, when I upgraded from 10.4 to 10.5 I did an Archive Install, keeping Applications, Network and User settings.


[Edit: Edited to include actual error text as shown when I insert the requested backup disc]

Link to comment
Share on other sites


- What are the make/model/driver (as seen by Retrospect's Configure->Devices) of the optical drive?


Device status says:


Product: DVD-RW DVR-110D

Version: AA06

Driver: Pioneer DVD DL(5.12)


- What RDU are you using?


- What RDU where you using when it worked?


Having seen the very subtlely different RDU version number, I'll head back to Time Machine and restore the contents of the /Applications/Retrospect folder and report back.

Link to comment
Share on other sites


Having seen the very subtlely different RDU version number, I'll head back to Time Machine and restore the contents of the /Applications/Retrospect folder and report back.



I'm back in business! Thank you very much for your help. I'm now happy for two reasons: 1) I can sleep easy knowing my Retrospect backup is online again and 2) I've found a use for Time Machine!! Now if only we could fix Spaces and Dock Contextual menus as easily I'd be deliriously happy grin.gifcrazy.gif

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...