Jump to content

Rebuild Catalog file problems/ error 24201, Chunk checksum didn't match

Recommended Posts

Hi all.

I'm in a world of pain and I'm hoping someone can help.

My G4/400 AGP had a Problem which resulted in it's primary hd ( the startup disk) being reformatted.

It has 832Mb RAM, the primary drive has had OSx.4.10 reinstalled and has about 68Gb available space.

Retrospect 6.1.126 has been reinstalled and has RDU installed.


This Mac has been acting as a file server and as my wife's computer. It has 4 hard disks; the system disk (80G), and a 20 G disk which is my wife's file area, are on the motherboard controller.

Attached to a PCI IDE controller card is An 80Gb hard drive which is used for file backup sets for important info like email, etc and catalog files for DVD-R based backup sets, and another 160Gb disk which is a general file storage space. There is an LG "Super Multi" DVD±RW/RAM drive in the Mac's optical drive bay which is used for backing up to DVD-Rs.


My main backup consists of a DVD-R backup set which numbers some 158 DVD-Rs ( I'm beginning to think that I should have started a new set some time ago) I've been using Retrospect for many years without problems, but this is the largest backup set I've ever had.

The problem I have, is that when attempting to restore some files to the primary drive ( not a full volume restore), Retrospect informed me that Restore preparation failed, error 24201, Chunk checksum didn't match.

I attempted to repair the catalog file by updating the existing file, but Retrospect informed me ( and I don't remember the exact message) that it was too badly damaged to repair. So I deleted that catalog file and started to rebuild the catalog file from the media. I progressed, with the occasional error in the log informing me that a DVD was damaged/or the drive heads were dirty. until the recatalog stopped with a message saying "process incomplete" At that point I tried a cd head cleaning disk although I don't think it made much difference, and restarted the recatalog by "updating existing catalog" this proceeded with the occasional stopping with "process incomplete" and me restarting it and repairing existing catalog file, till disk 139 where every disk failed up till disk 145, when the system crashed with a kernel panic.

When I restarted the Mac, ran the apple disk repair utility with not much found wrong, repaired permissions, then restarted retrospect, it crashed, so I replaced the library/retrospect folder as suggested in the help file, and that seems to have fixed that , but lo! the catalog is now corrupted and unfixable again.

So I renamed that catalog file, and started to recatalog again, thinking that this time I'll stop when the first problem arrises, and restore what I can from there before continuing with the recatalog. So i got to disk 24 and it stopped, So I tried to restore some files, but it now says, that restore preparation failed with error 24201 again. I tried restarting the recatalog, then stopping it after disc 25 and tried a restore with the same error. Nothing else is running on the Mac during this except file sharing, with minimal activity.


Sorry about the long story, but I wanted to be complete as I could with the chain of events.

What should I try next?

From reading several posts about similiar issues, (but not with DVD sets), I get the impression there may be an issue with the size of backup set catalogs. The catalog file that was almost there before the kernel panic is 2.34Gb, the new 24 disc catalog file is 170.6Mb. Should I recatalog , say 15 discs, then stop, and restart the recatalog. Is that likely to side step the problem?

This is very frustrating.

Link to comment
Share on other sites


So no Comments or suggestions? No Read page x of the user guide from the EMC support crew?



This is a user-to-user discussion. No comments usually means no-one got a clue.

Are you on a support contract? Contact support.

Not on a support contract? Contact support and pay for a "support incident".

Link to comment
Share on other sites


There is an LG "Super Multi" DVD±RW/RAM drive in the Mac's optical drive bay



What is the exact model of the drive? What dirver is it using (as displayed in Retrospect's Device Status window)?


> Retrospect informed me that Restore preparation failed, error 24201


At what point in the process did you get the error?

Link to comment
Share on other sites

Thanks for the reply

The Optical drive as reported in the system profiler is a HL-DT-ST DVDRAM GSA-4163B

The driver it is using is HL-DT-ST DVD+RW - RDI (TAO), ATA as reported in the device status window.

I used the Custom Automatic configuration to set up the drive.


I couldn't remember exactly when the message came up, so I went through the sequence again.

The sequence is this:

from the main window I select immediate action: Restore

I select "restore files from a backup"

I select the source catalog and the snapshot of the disk I want to restore from

I select the destination which is a new folder on the primary hard disk and "retrieve Files & Folders" is selected in the popup

Click OK

It hesitates for about 5 seconds, then up comes the error message: "restore preparation failed, error 24160 (Catalog is invalid/damaged)"

Now this error message has a different number than before, but the same text - I'm fairly sure as I had typed into this forum from the Mac's screen before just like I did this time ( I'm typing this on another Mac)


While I was waiting for a reply, I started the recatalog again, planning to stop it before it got to disk 24 and then try a restore. I did this, stopped at disk 23 and tried a restore. It gave me the same error so I tried restoring a different HD snapshot from the catalog (there are 5 different hard disk snapshots in the catalog at this stage). That worked!



I don't know if this is significant or not, but the hard disk snapshot that gave me the error is of a hard disk that is physically not present anymore ( it failed a while ago) and it's volume name has not been reused so thre is no volume of that name existing in the system anymore. Mind you, the snapshot that did work is also of a HD that has been replaced, and whose name hasn't been reused. so it's probably not significant



when recataloging the disks, disk 1 through to 23 took around 30 minutes each on average to scan. I had restarted the recataloging on disk 24 which has run for about 2 days. so I just stopped it to get the info you asked for, and I figured it wasn't working. I've just looked at the log file and it has generated a long string of errors saying

"trouble reading "24 all docs 06" (3877), error 206, Drive reported a failure: Dirty heads, bad media, etc"

The number in the braces changes in different lines of the log.

I'm guessing this means the DVD is damaged, as the drive seems to read the other disks ok. And I suppose this means I have at a minimum lost the info on that DVD-R


Does any of this mean anything?

Link to comment
Share on other sites


I used the Custom Automatic configuration to set up the drive.



Did you insert all kinds of media in sequence? I mean, did you insert a DVD-R, a DVD+R, a DVD-RW and so on for all kinds of media you want to use?

If you perform the operation again with just one type of media, the other kinds are "forgotten".


I had another model of HL-DT-ST drive before and it never worked (reliably) with Retrospect.


All kinds of media doesn't suit all drives, so the brand of discs you used may not be "liked" by your drive.


Can you try another drive? Borrow an external, perhaps?

Link to comment
Share on other sites

I inserted a variety of media, including CDR, CDRW, DVD-r, DVD+r. DVD-rw, DVD+rw

I didn't bother with DVD DL or DVD RAM because they're simply not cost effective. I know it forgets, I've had to reinstall Retrospect on this Mac a few times, and each time I waste a set of media.

I understand about various drive 's likes or dislikes of media, I generally use Verbatim disks or Sony. I have tried various brands and found them most reliable. I used to use TDK but found they were too variable in quality. I have used Laser brand successfully in the past.

I did have pioneer drives in this machine previously but had two of them fail in quick succession, and had one supplier offer the LG as a replacement because Pioneer wouldn't honour their warranty ( despite it being within the 12 months warranty period by a week) so I took it. It might be the drive, but it's funny that one snapshot will work while the other won't.

I can't easily try another drive, i don't have a physically compatible one available. I have thought about buying another drive , but i'd rather not unless I'm certain it is the problem. I don't know anyone who uses external DVD drives - they're just way too expensive here.

I have also thought about installing retrospect on the iMac i have and trying that , but it's an intel, and from what i've read on this forum, that's not such a good idea, ( when is EMC going to release a Universal Binary version of Retrospect - it's way overdue) and I don't want to use the iMac as a back up server long term because it doesn't have the internal storage capacity the G4 tower has. That's what the G4 tower's purpose in life is - to be a file & backup server. it should be entirely adequate.


Apart from all that, the problem I have now is catalog files that are becoming corrupt. how can the backup media or drive influence that?


Is it possible that a hard disk that passes Disk utility checks, and Techtool Pro tests and SMART drive monitoring tests could still have some issue that corrupts files? After all it did have that Kernel panic the other day…

Could that be the issue?

Link to comment
Share on other sites


Is it possible that a hard disk that passes Disk utility checks, and Techtool Pro tests and SMART drive monitoring tests could still have some issue that corrupts files? After all it did have that Kernel panic the other day…

Could that be the issue?


No, I don't think that could be the issue.

Kernel panics are often caused by hardware problems, most likely bad RAM.

One co-worker here in the office gets a kernel panic once every three months or so. Hardware tests reveal NOTHING.

Link to comment
Share on other sites

Well I'm proceeding with the recatalog from disk 25. It got up to Disk 33 and had an internal consistency check error and fell over.

The log has 2 "Bad backup set header found" lines

then the "Internal consistency check error",

then a "Assertion check at elem -c918"

I've restarted Retrospect, and restarted the recatalog at the next disk.

I plan to stop it at disk 50 and attempt another restore.


Any more thoughts to a cause or solution?

Link to comment
Share on other sites

  • 2 weeks later...

Well I did stop at 50 and did a partial restore, then feeling optimistic ( oh why) I decided to go to disk100 and try another partial restore.

Now it's failing to prepare for restore because the checksum doesn't match.


Is there any other way to fix the catalog other than starting again with a recatalog?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...