Jump to content

Normal backup NOT incremental at all!


Jaros

Recommended Posts

I have installed the Retrospect Mutli server 7.5.370 and made an immediate backup of some 1.6TB (289.300 files) of data to the NEC tape loader library. It took quite a while, and verified OK.

 

Immediately after that, I tried to run it again, to see if it detects the only one or two files changed (by myself, as our offices are closed over the weekend, no one was in the office at all).

 

It wanted to make a 1.2TB backup..... This is not what the normal (incremental) backup is expected to do. I just seems to not correctly detect that the files have already been backed up, even some with a few years old change date were included in this second backup.

 

In my case this is totaly useless, it takes 3 LTO-3 tapes to store the full backup, and hours to run, and to be forced to do it everytime is unaceptable.

 

Is this a known BUG? Even the cheapest of backup software for 10$ can detect changed files correctly.

 

Is there any setting I didn't see or if not, did this work correctly on the old version 7.5.324?

 

I attached the screenshot of Matching options for the backup, I beleive they are as supposed to be for incremental backup?

backup.jpg

Link to comment
Share on other sites

"Retrospect uses several matching criteria to find new or changed files. If one of the criteria has been changed, Retrospect will back up the file again. On Windows, Retrospect looks at creation date and time, modified date and time, size and name. If match only in same location option is set, Retrospect matches on the path, volume name and drive letter also.

 

"By default, the archive attribute is not used as a matching criteria in Windows, allowing for true and reliable backups to multiple backup sets. "

 

So, are you SURE none of the above criteria has changed?

 

Are you backing up local files only? Or are the files on a file server?

Link to comment
Share on other sites

Yes, I am quite sure, that no criteria has changed, this are files located on SCSI RAID external disk array on the server the backup is running on.

 

I checked the attributes of files, and really nothing I was able to see changed, not in a few minutes after the backup was done, and on 250.000 files which are going to be backed up again...

 

Does it work as it should for you? I see there are some similar problems mentioned on this forum!

Link to comment
Share on other sites

Quote:

We have also the same problem. Even though the backup is defined as Normal no incremental backup is being done!

All backup is done as Full.

 

I hope this can be solved quickly since the backup never managed to get finished because of this

 


I quote rhwalker.

Please provide:

(1) complete version number of Retrospect

(2) complete version number of Retrospect Driver Update

(3) complete version number of the OS

(4) complete description of hardware being used.

(5) complete description of the steps you are doing

(6) complete description of the problem

Link to comment
Share on other sites

There seems to be two types of incremental backup problems. The first one seems to be that Retrospect never did or ever will do a incremental backup on a particular backup set. The other one is that Retrospect will perform incremental backups for a while (even weeks) then one day perform a full backup on ALL backup sets Retrospect manages. I have the second problem, and others here have described the same problem.

 

Jaroslav and Philipb, did your incremental backups ever work, or did they work for a while and perform a full backup randomly?

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...