Jump to content

FTP & Mac OS X 10.4.8 and 10.4.9, possible? How?


Recommended Posts

I would to be doing all of my onsite as well as offsite backups under Retrospect and I've seen posts from people using 10.4.8 and/or 10.4.9 that make it sound like the ftp backup can possibly work, after long being told that it was broken.

 

Is it possible? If so, could someone list instructions?

 

I probably have it 99% working, but since I have yet to find anything but the most basic instructions, I don't know what to do now that it isn't working. I am using 10.4.9 on both machines for this description.

 

 

• Right now I am trying having my backup server set as DMZ, on an ip address that I can see from the server I am trying to push from, firewall is all turned off in the router as well as on the mac.

 

• I go into the Configure section of the Retrospect Server app, then click on Backup Sets.

• In the Backup Sets window, I click on New

• In the Backup Set Creation window, I choose a Backup set type of Internet, put in a password (is this the password from Retrospect on that machine, or the Mac OS X FTP password? I've tried both), then a directory name and click New...

• This gives me a new window to configure my connection. In here I put the remote username and password, the ip address of the machine, then /Users/username/backup_folder/. If I don't put in a password or put in the wrong password, as expected, it doesn't let me in, gives me error 221 username or password incorrect (just testing if it's actually talking to the server or not wherever I can). If I put in the correct info, I then get yet another folder called Choose a Folder.

• In Choose a Folder it's asking where I want to save the catalog for this backup. I select the normal folder on this machine for catalogs, it adds the new backup set to the Backup Sets window with the Apple-style icon, and I close that window, as it would seem that I am done in there.

 

• Next up, creation of a backup to test with. I go next to Automate, Scripts, New, Backup, Ok, Please enter a name for the new script: retrospect_testing, New, which gives me a new window with that backup's attributes.

• Sources - found a small item that backs up fine on the local network, Destinations - selected my just created retrospect_test ftp backup set, selecting - all files, standard options, no schedule.

 

• I then close everything besides the main window and click Immediate, Run, select my script and then hit OK, Execute now - Execute.

 

And, of course, now something is different. Before it would fail, saying that it couldn't write the files, I made a folder with same name as I had typed, tried then with different chmod values on the folder. Same thing every time. Now, it's not even getting that far. It pretty much just closes the execute dialog without doing anything.

 

Edit: Ok, for some reason, these weren't happening but were getting added to the schedule with no time. Once I tell them to run, I get the same problem. It says Device Trouble: "retrospect_test", error 225 (FTP: no write privileges, bad name, or disk full). I've tried variations, and this is the closest to working that I've gotten it.

 

Could someone go through this to see if this indeed can be made to work with 10.4.8 and/or 10.4.9? If there have to be variations, but it will then work, that is quite fine. Just let me know.

 

Thanks in advance, and sorry this was so long, Ian

Link to comment
Share on other sites

> the Backup Set Creation window, I choose a Backup set type of Internet, put in a password

> (is this the password from Retrospect on that machine, or the Mac OS X FTP password? I've tried both)

 

You left out the step where you click the button "Security" button (with the word "Secure" on it) that leads to a dialog box allowing you to select from multiple security types, which, after selecting one of the three, provides you with a dialog for a key.

 

So to answer your question above, it's a passphrase you create to inhibit the ability of someone getting hold of your ftp datafiles and getting your data out of them. It has nothing to do with existing system passwords on either the local or remote machines.

 

- Have you searched the Forum or the Knowledge Base for the connection issue?

 

If the local machine is configured for passive FTP mode, turn it off in the Proxies tab of the active ethernet interface in the Network Preference Pane. Retrospect does not use PASV.

 

The solution to your problem may well be answered by this post by waltr.

Link to comment
Share on other sites

I went through it all again to make sure I didn't skip that. I must have just described that step poorly, but I was doing it. So I have a password, and I did enter it in that window, after which, that button changed to "Remove".

 

What I get after that is the little progress window sitting there for a little bit trying to connect or copy files, and it then changes to saying "Execution incomplete", and tells how many files are left to complete. In the operations log, it says similar things and then also the error 225, ftp no privileges, bad name, or disk full.

 

Anything else?

 

One question that could relate, how do you change the retrospect password on the ftp machine? I want to double-check that the password is what it should be.

 

Thanks again, Ian

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...