Jump to content

Retrospect schedule not working


Recommended Posts

Hello,

I have benn a Retrospect user since 1993. I am currently running Retrospect ver 6.6.126 for Mac & have 4 backup sets scheduled for 4 different days but all at the same time of day (12:15 am). Retrospect sometimes runs the backup(s) at the scheduled time, but most times it does not. My machine is on 24/7 but can go to sleep so I have it scheduled to wakeup 5 minutes before the scheduled backup. I confirm that the maching is awake by running an Automator script to launch iCal & iCal in turn sends me an email alarm. The sent time of the email confirms the machine is up at the time Retrospect should launch. When Retrospect does not run the backup at the appointed time what happens is when I wake the machine from sleep in the morning (many hours after the scheduled backup was to run) Retrospect will launch & run at that time & I then have to wait for it to finish. What is difficult to understand is that it may run any of the 4 backups correctly on any given day, but not run them at the appointed time on other days. In other words the behavior is not consistant.

 

Thanks in advance, any thoughts or help is greatly appreciated.

Lee

Link to comment
Share on other sites

Quote:

I am currently running Retrospect ver 6.6.126 for Mac

 


there is no such version.

 

Quote:

The sent time of the email confirms the machine is up at the time Retrospect should launch.

 


Not really. I can forge SMTP headers easily (and spammers do it all the time), and the "Date:" header, depending on the SMTP MUA mechanism used, could mean many different things. What is the time stamp on the Received: header when your mail server got the email message? Could you post the full headers on that email? Anyway, that's really not relevant to your issue

 

Quote:

When Retrospect does not run the backup at the appointed time what happens is when I wake the machine from sleep in the morning (many hours after the scheduled backup was to run) Retrospect will launch & run at that time & I then have to wait for it to finish.

 


Still does not indicate a Retrospect problem, only that your computer was asleep when Retrospect needed it to be awake to check the backup schedule.

 

What happens if you do not allow your computer to sleep? If the backups happen reliably then, it shows that the issue is not a Retrospect problem, but instead that your computer is asleep when Retrospect checks. Perhaps it wakes up to send the email and then goes back to sleep. Our Xserve G5 never sleeps (no server ever should), and we have never seen this problem.

 

Now, there is a different issue that should not be confused with your issue, and that is that Retrospect's retrorun file can become corrupted and all scheduled backups will fail, and the only fix is to delete the corrupted retrorun file, restart and quit Retrospect, and it will create a new retrorun file without corruption. You can search the forums for that different issue.

 

But that's an entirely different issue from yours.

 

Have you tried setting your computer's sleep time (and disk spin down, too) to, say, 30 minutes and waking the computer up 15 minutes (not 5) before the backup time? Try using the Energy Saver preference pane, Schedule button, to schedule the wakeup. You don't say how you have the wakeup scheduled.

 

Russ

Link to comment
Share on other sites

Quote:

What happens if you do not allow your computer to sleep? If the backups happen reliably then, it shows that the issue is not a Retrospect problem, but instead that your computer is asleep when Retrospect checks. Perhaps it wakes up to send the email and then goes back to sleep. Our Xserve G5 never sleeps (no server ever should), and we have never seen this problem.

 

Now, there is a different issue that should not be confused with your issue, and that is that Retrospect's retrorun file can become corrupted and all scheduled backups will fail, and the only fix is to delete the corrupted retrorun file, restart and quit Retrospect, and it will create a new retrorun file without corruption. You can search the forums for that different issue.

 

But that's an entirely different issue from yours.

 

Have you tried setting your computer's sleep time (and disk spin down, too) to, say, 30 minutes and waking the computer up 15 minutes (not 5) before the backup time? Try using the Energy Saver preference pane, Schedule button, to schedule the wakeup. You don't say how you have the wakeup scheduled.

 

Russ

 


 

When the computer is not allowed to sleep Retrospect will still not do every backup every time. It always does the Monday backup, almost always does the Tuesday backup, but Wednesday & Thursday are a crap shoot (probably about 50% or less).

 

The sleep time is currently set for 30 minutes & the option in Energy Saver preferences are set to wake up every day as decribed in my original post. BTW, Automator will not run if the computer is asleep either, it will wait until the computer is awake to run it's script. So again since iCal launches (using Automator) & iCal sends the email the system is definitly not sleeping. If the backup ran all the time every time I would trash the Automator/iCal/Email routine because it's only purpose was to prove the system was actually awake at the prescribed time.

 

Your point about the RetroRun file corruption is well taken, I will delete that file using the procedure you described & see what results are obtained. I will post back with my findings.

 

Thanks again for your time.

 

Lee

Link to comment
Share on other sites

Quote:

When the computer is not allowed to sleep Retrospect will still not do every backup every time. It always does the Monday backup, almost always does the Tuesday backup, but Wednesday & Thursday are a crap shoot (probably about 50% or less).

 


Then that's odd. I'll have to say I have never seen that behavior on our Xserve G5. Perhaps could it be something involving a screen saver?

 

We have one user who would "helpfully" put his iMac to sleep each day after logging out, which would cause that client's backup to be skipped. I changed his energy saver control panel to wake up his computer 5 minutes before the scheduled Retrospect backup running on the Xserve G5 starts to walk the network, and that client has now never failed to be backed up after this change was made. But that computer is always left at the login screen when the awaken occurs.

 

Is your computer sitting at the login screen when it goes to sleep, or is it sitting in the Finder?

 

Again, this is new behavior to me. I've never seen it.

 

russ

Link to comment
Share on other sites

Quote:

Then that's odd. I'll have to say I have never seen that behavior on our Xserve G5. Perhaps could it be something involving a screen saver?

 

We have one user who would "helpfully" put his iMac to sleep each day after logging out, which would cause that client's backup to be skipped. I changed his energy saver control panel to wake up his computer 5 minutes before the scheduled Retrospect backup running on the Xserve G5 starts to walk the network, and that client has now never failed to be backed up after this change was made. But that computer is always left at the login screen when the awaken occurs.

 

Is your computer sitting at the login screen when it goes to sleep, or is it sitting in the Finder?

 

Again, this is new behavior to me. I've never seen it.

 

russ

 


The computer is left in the finder (since I'm the only user & it's in a secure environment).

 

I have deleted the RetroRun file & had Retrospect recreate it, so I am going to see what happens next week.

 

Regards,

Lee

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...