Jump to content

Autolaunching twice!


Recommended Posts

I have scheduled backups set to start at 17:00, 17:05, etc.

At 17:00 retrospect launches and starts running the first backup, but more often than not it starts up twice. Both doing the same job and of course one of them fails with a file is locked error.

How do I stop it doing this and ensure that it only launches one copy?

Link to comment
Share on other sites

Quote:

How do I stop it doing this and ensure that it only launches one copy?

 


This has been discussed at length in the forums. Not possible to answer your question without any configuration information (Retrospect version, OS version, hardware, RDU, etc.).

 

First step would be to bring yourself up to date on versions, and make sure you don't have more than one Retrospect installed on your computer. This bug was (perhaps mostly) fixed, although some people have reported that there might still be an issue. Unfortunately, we never know whether they give up or achieve success because we never hear from them again. If, after doing all the things suggested here, you still have the issue and we are unable to resolve it, I urge you to contact EMC support because it might help them find the bug, if it still remains.

 

Here are the updates:

Retrospect updates

 

Once you are current with versions, in Terminal do

Code:


locate MacOS/Retrospect

 

See if more than one folder is reported. There should only be the stuff in

/Applications/Retrospect 6.1/Retrospect/Contents/MacOS/Retrospect

 

Russ

Link to comment
Share on other sites

I think I'm using all the latest (!) versions. (Sorry, but v6 being the latest when Windows is on 7.5 is a bit annoying).

system is an iMac intel core 2 duo, 10.4.8 all the latest patches and updates.

I only have one version of retrospect installed.

I'm not impressed with technical support. I raised a question ages ago, they responded once and then dropped it completely. I'm still waiting for them to send me the utility to patch it so it works with ACLs. For now I just disabled ACL support.

[Retrospect version is 6.1.126 RDU is 6.1.9.102.]

Link to comment
Share on other sites

Quote:

I'm still waiting for them to send me the utility to patch it so it works with ACLs.

 


You opened a support case with them on the telephone? That's odd, support has always been very good for us under our support contract. Anyway, there is no such "utility". The version of Retrospect that works on Intel Macs with ACLs enabled has been posted for a while in the Knowledgebase, and there are numerous references to it in these forums. Here is a link to the Knowledgebase article and file download:

Retrospect hack for ACLs on Intel Macs

 

The way I find it is to search the Knowledgebase for intel ACL crash (all words) and it's the second article.

Be sure to read all the way to the end about turning on the option to not copy ACLs.

 

Now to the other issue: Double launching. Searching these forums is a black art. It helps to read the "Advanced search tips" in the link above the keyword field. The search engine is non-intuitive.

 

Quote:

I only have one version of retrospect installed.

 


I assume that this statement is the result of the Terminal command that I gave and not simply your belief that there is only one copy of Retrospect installed, correct? Only way to tell is to do the Terminal command I gave (well, actually, you could also do a find / and pipe the result to an appropriate grep and pipe that result to "more" or "less", etc.).

 

Searching on:

+launch +twice

in subject and body

highlighting all of the Macintosh categories in the left pane

newer than 1 year

 

yields the useful items. Doesn't seem to be any way I can provide you with a link to the result, you will have to repeat the search.

 

Good luck. I have only seen this problem once on our Xserve G5 on Retrospect 6.0.x, and it hasn't repeated on 6.1.x.

 

Russ

Link to comment
Share on other sites

I opened a call over the internet. I had to jump through hoops to prove I had bought it, despite having bought it direct and despite the SAME guy being the one who dealt with the purchase. Talk about OTT.

Then when they looked into the fault he said yes you need the utility/patch whatever if you want me to send you the link let me know. So after a week of them messing about you would think that maybe I might be interested in the link - but no I had to actually specify to them that I wanted it. I've heard nothing since and of course the complimentary 30 days have now long since gone. I get the impression that they couldn't care less. It was MUCH MUCH better when it was Dantz. Seems odd that the ACL is a known issue and it still took them a week to diagnose it! But then Macs have been intel for a year and Retrospect is still running under rosetta (and way behind the PC version).

Anyway back to the original issue. I have two sets of backups, 17:00, 17:05, 17:10... and then 20:00, 20:05... The 17:00 set are local and the 20:00 set are the MBP. It often starts twice at 17:00 and one fails (file locked) but I don't ever remember seeing it do that at 20:00.

I did use the command given and only have /Applications/Retrospect 6.1/Retrospect. I'm pretty good with computers, I've been working with them for 20 years and had Macs since the early nineties (which is when I used Retrospect v3).

Link to comment
Share on other sites

Found this :

This is a known bug that was supposedly fixed in v6.1.126. However, some users still report the problem (see thread Two 6.1.126 Apps Running Simultaneously, running Tiger).

 

Luckily, we have not had this problem since the latest update. Prior to that, though, the only way we could be sure to avoid it was by keeping Retrospect running all the time and not allowing it to autolaunch.

--------------

I'm running 6.1.126 and can confirm it most definitely is not fixed. The solution of keeping retrospect running all the time is not really useful to me. From what I can see the bug has been outstanding for some time and they haven't bothered to fix it.

Presumably all the developers are busy working on a universal 7.5 release (no laughing at the back, I mean it now, stop it).

Link to comment
Share on other sites

Quote:

I did use the command given and only have /Applications/Retrospect 6.1/Retrospect.

 


Ok, I just wanted to check. There are wide ranges of experience for the posters in these forums, and it's common for posters to repeatedly insist that a certain fact is the case, when, after repeated questioning, it turns out that they were mistaken or didn't actually perform the step or command requested.

 

Quote:

From what I can see the bug has been outstanding for some time

 


Yes, but it appears that there may be multiple causes and that only some have been found. It's not as frequent as it once was.

 

Quote:

and they haven't bothered to fix it.

 


No, I think a more accurate statement would be that they haven't been able to. It's hard to reproduce, and I don't know how much effort has been devoted to this problem, either. Dave has posted a few times the information that would be helpful to gather when it occurs, but no one has ever responded.

 

Russ

Link to comment
Share on other sites

Yes I accept all that. We deal with users quite often and they assure us they have tried X, Y, Z only to then tell us that they haven't actually logged in yet!

 

I guess it's fair to say they haven't been able to fix it yet but my emails seem to get ignored so I don't think it's all one sided.

 

Some companies really make an effort and keep the users happy, I really don't believe that EMC are in that category. Maybe if I shelled out on one of the support offerings it would be better but no way am I doing that.

 

I still have to say that a PowerPC version 6.1 when Windows is on 7.5 and the entire Mac range is now Intel shows a serious lack of commitment. (Yes I know it's not that straightforward to move to Universal but lots of other companies have managed it). theres talk of v8 for windows, I wonder what version it will be up to when the Mac Intel version escapes...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...