Jump to content

barcodes not showing up


Recommended Posts

Retrospect Multi Server

Version 7.5.324 - hotfix 7.5.9.102

PowerVault 124T AutoLoader

 

In the storage devices window only one of four loaded tapes is showing the barcode.....

 

I've followed the instructions in the knowledge base article # 7901 that addresses this , but it's still not working.

 

Has anyone else had this problem??

Link to comment
Share on other sites

I had a similar issue with the Retrospect Macintosh version, resolved it with the help of Retrospect Support. My issue was a bit different in that we changed to a different barcoding scheme, which meant that we had to re-associate all of the tapes with new barcodes.

 

Here's the final email of the steps that I did, pointing out some errors in this KB article - they may not apply to the Retrospect Windows product:

 

Quote:

The KB article is almost correct, but was enough for me to figure it out. Some of this may be due to differences in the Exabyte 1x10 1u PacketLoader from other autoloaders. Here are the corrections, at least for the Exabyte 1x10 1u:

 

1. (this step is correct in the KB article)

 

2. missing some steps: Configure > Devices, select "Exabyte Library, SCSI-A:0:0" (not the "Library Slots 1 to 10" entry), Command-I (get info), disable barcode support. You get the same window if you "get info" while selecting "Library Slots 1 to 10", but "Disable Barcode Support" button has no effect on the Barcode Support status.

 

3. It's "Option + Unload All/Eject Magazine" (not "Option + Eject All") while "Just Clear Barcode Info" is checked, at least on the Retrospect 6.1 I have. There is no "Eject All" button. (step 4 has the same error).

 

I note that if I do the above, skip step 4 in the KB article, then re-enable barcode support (step 5), then move each newly-barcoded tape to the tape drive so that Retrospect scans the tape and re-associates the barcode with the correct tape member name. If I then eject the tape back into the library and then try to verify the tape, Retrospect asks where the catalog is (seems to have forgotten this catalog with the changed barcode), allows the catalog to be re-selected, and then it moves the newly-barcoded tape into the drive from the autoloader (knows which one it is) and starts the verify.

 

Doesn't seem necessary to rebuild the catalog.

 


Does this help? It was painful. We had a bunch of tapes. I submitted a product enhancement / feature request for an editable file that would do the barcode to tape association, or else a GUI page to allow the data to be edited.

 

Russ

Link to comment
Share on other sites

Thanks for your reply Russ. I tried that modified way of the procedure, but I seem to be arriving with the same results. Thanks for the info though! What is really wierd is that one of the four tapes in the magazine shows the barcode correctly. But the other three tapes just show "(Erased)" instead of the barcode....

Link to comment
Share on other sites

Hmm. You didn't mention the "erased" issue in your original post. I think you are seeing what I saw in a different context (and still see). This is unrelated to barcodes, if it's the same thing I see.

 

I believe that Retrospect has an odd heuristic for deciding whether a tape is "erased", and may just give up and toss tapes into that category when it gets errors on tape insertion. I had a batch of marginal X-23 tapes from Exabyte this summer; they would work fine initially, but on some subsequent insertions from the autoloader, the header wouldn't read and Retrospect would declare them "erased". If I moved the tapes back into the autoloader and did a cleaning cycle, and then moved the tape from the autoloader back into the drive, Retrospect would then read the tape, its header, and decide that the tape was no longer "erased".

 

It made me nervous because, unrelated to this, Retrospect does not honor the backup set names on pre-named, barcoded, erased tapes when looking for new media; it uses the first erased tape it finds, using an algorithm that seems whimiscal to me - I cannot predict which slot it will pick. I put in an enhancement request to fix this, um, feature, about a year ago. I feared that Retrospect might choose one of these "erased" tapes if it felt it needed new media.

 

Anyway, my problem for this "erased" issue cleared up when I got a new batch of tapes, and I decided it was just a bad batch of tapes.

 

See if a cleaning cycle helps.

 

Russ

Link to comment
Share on other sites

Thanks for your follow up post Russ. I'm beginning to think this may also be a problem with the autoloader itself and not just within Retrospect. We received a brand new box of Dell Ultrium LTO-3 tapes with the auto loader so I don't think it's a problem with the media (maybe the actual barcode labels?)... And we have only backed up to tape four times total since installing the system. Today the autoloader magazine is holding five tapes (barcodes were recognized on one of the five tapes). For the heck of it I tried ejecting and reloading the other four tapes. Two more are now recognized in retrospect (total of three tapes now showing a barcode in retrospect), but the other two tapes are not. I'm leaning toward the autoloader or the labels now... As I loaded the two tapes that are still unrecognized, the front panel of the autoloader displayed "bad/unkown barcode". So if the autoloader isn't recognizing the barcode then Retrospect surely won't either! Man what a pain this has been!

 

EMC definitely needs to improve the functionality of this feature. I like your idea of a gui/editable windows for the barcodes.

 

Thanks for your help and suggestions.

 

-Charles

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...