Jump to content

Problem restoring HD on iBook, need advice


Recommended Posts

G4 iBook HD crashed, AppleCare replaced semi-instantly. No problem, I thought - I have a full disk backup from less than 24 hours before the crash (feels smug, he does). Started iBook in Target mode, connected to the G5 hosting the iBook backup set. Ran Retrospect 6.1.126, restored entire disk to iBook, successful, no squawks in the log. Looked at contents of iBook HD, everything looks good, files are where they should be. System Preferences Startup Disk pane on the G5 even offered the iBook system as a boot option. Dismounted and shut down iBook, disconnected FireWire cable, started iBook - and waited - and waited - no bootup. I've tried a number of tactics, but I'm unable to get the restored iBook to boot off the complete disk backup I did with Retrospect. The iBook boots fine off a Tiger install DVD, or with a Tiger archive & install, but that doesn't restore the disk to its pre-crash state, which is what I thought would be possible.

 

How does one restore to a new HD from a complete disk Retrospect backup so that the drive will boot like its dead predecessor used to? Am I missing something really simple? Or am I expecting something that Retrospect can't do? The help files don't seem to address this issue. Thanks for your help.

 

Systems: G4 iBook, 10.4.8, all updates. G5 DP, 10.4.8, all updates, Retrospect 6.1.126. No execution errors in backup or restore.

Link to comment
Share on other sites

My iBook was stolen last December but Retrospect saved my day. When the replacement iBook arrived, I updated the OS to the save version as the previous one, installed Retrospect and restored while booted from the iBook. No problem.

 

In your case, was there a different version of the OS on the repaired iBook vs the backed up version? That might explain your problem.

Link to comment
Share on other sites

I am having similar problems at the moment. I have tried before without success but recently a Mac G5 (running 10.4) has been showing an increase in seek errors via a SMART disk utility, so I am going to have to get this working soon.

 

I am currently backing up the enire disk, excluding Music, Movies & cache files.

 

The documentation for retrospect says that to restore an entire disk you should install the same version of OS X on the machine that was installed when the backup was done. If you are doing the restore via the network you should also install the client as well. Then run the restore 'entire disk' from retrospect.

 

I have tried restoring via network and firewire ( with the G5 in terminal mode).

 

Recently tried restoring without first installing OS X. Restore seemed to work but would not boot. Tried using the 'bless' command. The machine booted but stopped with a kernel panic. I accept this as I believe that retrospect does not backup everything.

 

Installed 10.4, installed client & did restore entire disk from rerospect. No luck, still wil not boot. Remains at grey screen with rotating disk symbol. Tried 'blessing' disk without success. Disk appear as bootable option when I use the select boot disk option at startup.

 

When I get the time I intend trying to boot in verbose mode & see if this provides some answers.

 

I am not sure what is meant when the documentation says that the same version of OS X must be installed before doing the restore. Does anyone know if this means that an install from the dvd is sufficient or if I also need to install updates as well. Does using a different dvd than the one used for the backup version matter?

Link to comment
Share on other sites

Lennart, thank you. I had erased the iBook drive in FW Target mode before doing the restore. I had not re-installed 10.4.8 prior to the restore, thinking that would happen as part of the restore. I'll erase the iBook drive, re-install 10.4.8, then do the restore. Will report what happens.

Link to comment
Share on other sites

Quote:

Started iBook in Target mode, connected to the G5 hosting the iBook backup set. Ran Retrospect 6.1.126, restored entire disk to iBook, successful, no squawks in the log.

 


 

On the face of it, this looks right. I've done this many times, and it has worked as expected.

 

But your Restore is only as good as the Backup it's based on, and there's no way for us readers to know if there might have been something missing from the past. I do have some suspicions about how Retrospect behaves in regards to Normal (Incremental Plus) Backups across system updates, but it's only a hunch.

 

There are two different other methods you can try, both involve installing from DVD first.

 

- Install valid system on new drive, boot into Target Disk Mode and do the same sort of Restore you did above. The difference will be that Retrospect will match pre-existing system files and not copy them over from the Backup Set.

 

- Install valid system on new drive, boot into the new drive, install Retrospect, gain access to the File Backup Set (possibly use the G5 in Target Disk Mode) and perform a "Live Restore." Again, Retrospect will match existing files and not copy them over, using a hidden temporary directory to manage stuff until you are done and you restart.

 

All three of the methods described here have tested for me in the past; you should be able to get your system up using one of them.

 

Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...