Jump to content

Slow backups, no obvious bottlenecks...

Recommended Posts

Hello. I run Retrospect Multi-Server 7.5, fully patched, on a Windows Server 2003 R2 machine. I back up several dozen client machines (Mac OS 10.4 and Win XP SP2) to a disk backup set.


My experience has been that backups will alternate between running smoothly (15 - 70% usage of bandwidth on a 100 Mbit connection, as reported by Windows Task Manager) and running dog slow (1% network usage).


There is no obvious bottleneck here. The CPUs on both the server and client are near idle, there is no excessive disk activity (as reported by filemon and diskmon from sysinternals) and there is certainly plenty of network bandwidth to go around.


I have tried creating new backup sets with no encryption and disabling software compression, but these changes had no impact.


Things will run properly for a minute or so, then fall down to about 18 MB / min for several minutes, then back to 200+ MB / min for 90 seconds or so then back down... with no apparent rhyme or reason.



Link to comment
Share on other sites

This appears to be with all clients, similar performance with machines on the same subnet and machines on another subnet. Backup is to a hardware-driven RAID 5 array which has no other observed performance issues. (I should mention that these same symptoms were also observed on our initial test pilot machine, a simple Dell Optiplex.)


The only errors in the Retrospect log were the few and far between sharing violation / file in use errors. Nothing of note in the system events logs.


Local backups? You mean backing up data that resides on the server itself? Haven't tried that, and I suppose that would be a good diagnostic. I'll download some Linux ISOs and repositories from the local mirror on our network and see how it goes.



Link to comment
Share on other sites

  • 3 months later...

I have a similar complaint...


My backup server is a 3ghz intel cpu, 1gb ram, gb ethernet WinXP Pro, writing backups to a single 750gb internal harddrive. the os boots from it's own 80gb hd.


After running for the last 3 days straight, it's backed up at an average of about 180mb/minute. The client is a fully patched Mac osx Server 10.4.8 (G5, not intel) with current retro client.


What's unique in my situation is that the cpu is constantly pegged at 100% usage, with retro.exe taking at least 90% of that. Network usage is negligible.


The BIOS lets me turn HyperThreading on or off. I've tried both - little to no difference.


I've got encryption turned OFF and have tried with compression both ON and OFF.


The 750gb drive i'm writing to is formatted NTFS.


Disk-to-Disk, with fast cpu's and gig ethernet... shouldnt this give the highest throughput of any storage medium? I ran retrospect at another company about 7 years ago, and remember getting 700+ mb/min when writing to an AIT tape drive. 7 years is a long damn time! And the backup server at the time sucked! (i think it was a Mac G4 running OS9).


Something serious is wrong here....

Link to comment
Share on other sites

No, that's not it. Company is a design firm - graphics files, some of which are very large. Sure, there's fonts and small files mixed in too, but the server that's been backed up has 800 gigs of data on it. there are not 800 gigs of small files there. Perhaps 10% of the disk space i made up of small files, with 90% made up of large ones (>10MB).


Excactly the same kind of data that i'm used to backing up with Retrospect. It's just now, it's really, really slow.



Completed: 616036 files, 819.5 GB

Performance: 238.8 MB/minute

Duration: 2 10:37:16 (00:03:52 idle/loading/preparing)




Total duration: 5 12:48:23

Link to comment
Share on other sites

I agree, That's slow.


"What's unique in my situation is that the cpu is constantly pegged at 100% usage, with retro.exe taking at least 90% of that. Network usage is negligible."


That puzzles me. We're running disk backup sets and I rarely see such usage. I see it during matching/building snapshot and the like, but never during the file copy.


I'm sorry. I have NO clue.

Well, maybe except one: We've had problems with old NIC drivers. And one poster had the opposite: problem with the latest, so he reverted and problem went away.

Link to comment
Share on other sites

At first i was running it with the build-in 10/100 ethernet, and changed to a pci gigabit card in hopes of improving the speed. that wasn't it, but your suggestion set me on the right path. I discovered that the internal harddrive that the backup was being written to was connected to a Via controller, which was using the standard MS driver dated 2001.


I downloaded the current one from via.com.tw, and bam - triple the speed and minimal cpu usage!


Thanks for your advice. Cheers.



Link to comment
Share on other sites

  • 5 months later...

I have similar situation too.


Retrospect Backup Server:

OS:Win2000 Server with SP4

CPU:Pentium 4 2.0G

RAM: 1G DDR 400

Storage: Raid 0 space on network about 500GB

ethernet: built-in Broadcomm GBE adapter & PCI-X Intel Pro/1000 XT Server Adapter with the latest Driver(2007/3/25)


Backup Client:

OS: 90% WinXP with SP2 ,1 x NAS & 3 x win2000 Server

Client Agent: 7.5.111


A few weeks ago , I install retrospect 7.5 on a whole new win2000 Srv with SP4

at the very start , Retrospect works just fine.

the avg backup speed of Proactive Backup or NAS Backup is about 3xx MB/min , and I am satisfied to that.


But just few days ago. I found the backup speed incredibiily slow!!

no matter which Client and what backup space , even backup to localdisk !!

the avg backup speed drop down to even 3 or 4 MB/min. and It`s connected to Switch with broadcom on board network adapter

so I unplug network cable , and buy 1 new PCI-X network adapter , and reconnect then everything works fine.

But a few days later . The slow backup happened again !!!!!

so I change linking to broadcom again . and seems work just fine now ..

During my testing , I used same Cat5e Cable ,the same NI Driver, the same port on switch , 2 different network adapter.

I have no idea why suddenly the performace just down .

any suggestion ?

Link to comment
Share on other sites

I had this problem. I'm backing up close to 100 clients and need the speed over the network. I concluded that the problem was with the client software. I installed 7.5.116 on everyone and haven't had a slow backup yet. That has been well over a year since I did the install. Any version lower than that had problems. I don't know about later versions (I'm scared to find out)


Hope this sheds some light.


Tim Berry

Scaled Composites, LLC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...