Jump to content

OSX Server 10.1.5 w/ Retrospect Server 5 hangs


Recommended Posts

Hey Folks,

 

 

 

My server used to be happy before I upgraded from 10.1.4 to 10.1.5

 

 

 

Now everynight my server hangs during incremental backup and I have to reboot it to get it going.

 

 

 

The crash occurs when Retrospect is comparing media after it's done backing up. Is anyone else seeing this problem?

 

 

 

If so, is it possible to step the server back to 10.1.4?

 

 

 

Here's the specs:

 

G4/450 512MB Ram running external 68GB Raid 1 on ATTO UL3D SCSI

 

OSX SERVER 10.1.4 with the 10.1.5 update applied and network update 1 applied (essentially all updates available from apple)

 

Retrospect Server Backup 5.0

 

 

 

I'm going to re-install the retrospect server and start a new backup set tonight to see if that works.

Link to comment
Share on other sites

You rock! I can't believe how on top of these questions you are - thanks for that. Back to the questions:

 

 

 

I'm backing up to an AIT2 Tape drive (lacie enclosure with sony mechanism).

 

When I leave my server I log out so retrospect will run but in the background behind the login screen.

 

In the morning when I come back to it the fileserver is no longer serving as clients cannot access it. At the machine itself I'm able to move the mouse and actually type in username and password in order to login but after that the curser just spins endlessly. I can see behind the login window, that retrospect has started to "compare" media but it's not moving either. Funny enough if I start the backup manually it runs.

 

 

 

There is actually another drive set in the machine (raided ATA 100 55GB IDE's on a Sonnet technology card) which makes it through the backup and so does the server's internal drive - the 60GB ultra scsi's are last in the schedule. The log shows the backup and compare for the last set and ends there without showing any errors. It all worked before the update...

 

 

 

Thanks,

 

 

 

Simon

 

 

Link to comment
Share on other sites

Irena,

 

 

 

I ran a scripted backup with the server logged in at 2:22pm E.S.T. and it worked fine. I'm going to leave it logged in and check it tommorow after it's scheduled backup which is still 2:22pm E.S.T. While I prefer logging out for maximum security, if this works I'll be happy until it's sorted by your development team.

 

 

 

Cheers,

 

 

 

Simon

Link to comment
Share on other sites

Things seem to be working fine after today's backup. The scripted backup opened Retrospect ran and then quit after completion. I've checked the log and everything looks good. Our office is closed tommorow and monday for Canada Day, so I'll give you an update on Tuesday. Irena, is this a known issue with 10.1.5 and performing scripted backups with the machine logged off?

 

 

 

Thanks for your help!

 

 

 

Simon

Link to comment
Share on other sites

Havoc/Forum Gurus:

 

 

 

I am having the same problem (almost). I have not been logging out, but the symptom is about the same: usually after the first machine in the first set is done writing, Retrospect 5 just hangs at the "comparing" phase until I come in the next morning.

 

 

 

I say usually because about 40 - 50% of the time the script appears to run fine. About the same (sometimes it runs, sometimes it does not) if I sart the script manually, or let run per the schedule. I always have to force quit, and then reboot after this hang, otherwise Retrospect does not see the firewire tape drive. The odd thing is that some times it works and some times it does not; I have not found anything that seems to change this, including upgrading clients from 4.3 to 5, and downgrading back to 4.3, or rebooting the server before the script runs. The hang apears to be random.

 

 

 

hardware:

 

 

 

Mac G3 server (333) w/ firewire card

 

stock SCSI drive and CDROM

 

10.1.5 (NOT OS X Server)w/all updates running Retrospect 5 Server, w/ driver update

 

VXA external firewire tape

 

(nice and clean; only job is BU!)

 

 

 

Everthing used to run fine 5 nights a week on 4.3 running on OS 9.2. Upgraded to be able to run on and backup OS X, and an OS X Server as a client (have not even attempted this yet), as well as networked machines via FTP.

 

 

 

Have seen some blurbs somewhare about the size of the files or volumes being backed up, but since it runs OK sometimes, that seems unlikely. What about whether or not the first script to run is to recyle the tape? Never a problem before. . .

 

 

 

Have run all available diagnostics (DD, DW, fsck -y,) and the box appears to be fine. . .I never had to do any diagnosis/troubleshooting with Retropect in the past (it always ran fine in 4.3 for me), so this is all new. Help anyone???

Link to comment
Share on other sites

Good morning,

 

 

 

It seems I should join the queue!

 

 

 

I have a client with an iMac (G4, 700MHz) running X.1.5 and Retrospect Server 5.0.205. It has version 2.7 of the driver and uses a VXA FireWire Tape Drive. This machine backs itself up and several clients (OS X server, OS X and 9.2.2 desktops).

 

 

 

The nightly backup is a recycle and it backs up the local desktop container before the clients.

 

 

 

This has worked fine for approx a week and a half but now the backup stalls during the compare phase on the first machine in the script. I have tried changing the script to backup a remote client or the local container first and it makes no difference.

 

 

 

The mouse still works but the script just displays the barber's pole for hours on end.

 

 

 

Any ideas?

Link to comment
Share on other sites

Hello again,

 

 

 

Back from a fabulous Canada Day holiday and I just wanted to give you an update. My server has been successfully making it through it's backups for 4 days since you instructed me not to logout.

 

Currently I'm not backing up any clients over the network with that server but I would like to. I'll let you know how that goes in a new post.

 

 

 

Appreciate the help!

 

 

 

Simon

Link to comment
Share on other sites

Regarding hangs with 10.1.5 and the VXA FireWire drive, go through some hardware troubleshooting. I'm running the VXA FireWire drive under 10.1.5 on a G4 and have yet to see a hang during the compare.

 

 

 

First, some users have reported that typing on a USB keyboard during the compare phase caused problems. I've never seen this, however.

 

 

 

Try a new tape to see if the problem is related to a faulty or damaged tape.

 

 

 

Clean the heads with a cleaning cartridge.

 

 

 

Isolate the device. Another device on the chain may be interfering with the backup device's communication. If your backup device is connected to your computer through a hub or another FireWire device, unplug it and connect it directly to a port on the computer. If it is already connected directly to the computer, try changing ports. If the problem persists, do not reconnect the other devices, and continue down the checklist.

 

 

 

You may have a bad cable. Replace the cable that connects the device to the computer.

 

 

 

Update or reinstall the FireWire adapter drivers and/or firmware. Corrupt drivers can cause issues that may not be otherwise detectable. Check the manufacturer's or vendor's website for updated drivers.

 

 

 

The system board or FireWire/USB adapter in the computer may be having a problem. Install Retrospect on another computer, if available, and try the device there as the only device.

 

 

 

The device itself may be defective. If you have implemented all of the preceding steps and get failures on new media after changing media, cables, software, firmware and computers, then the backup device, being the only factor that has not changed, is the the last variable. Contact your drive vendor for further diagnostics, tests, or to inquire about repair or

 

replacement.

 

 

 

 

Link to comment
Share on other sites

Unfortunately I'm back...

 

 

 

Since I changed my backup script to run at 2:22pm E.S.T. last Friday (leaving the server logged in) everthing has been good until today. It crashed during it's scheduled execution while doing a compare on the final set of drives. The only thing we did earlier today was put another 400mb of data on the server. It was a hard crash too, I was unable to force retrospect to quit, unable to launch the terminal and unable to login to the server from another machine (it would bring up the file sharing login dialog box and freeze the client machine as soon as you clicked ok after entering your name and password). I've changed the time now to 4:30 to see if it will crash again...

 

 

 

I've been looking for more info on the Sonnet ATA-100 card that I'm using, and can't find much here to say if it's good or not. I'm going to take out my 55GB ATA raid and the sonnet card it's sitting on - boo hoo, but I have an alternate set of scsi wide drives that I can just throw onto the ATTO UL3D. I'll let you know how my evening goes...

 

 

 

Irena, If you think it might be something else and I should leave the Sonnet Card and ATA raid in place, please let me know before 5pm E.S.T. - hopefully you'll have seen this before then ;)

 

 

 

Thanks,

 

 

 

Simon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...