Jump to content

Volume Restore Won't Boot- Need Help

Recommended Posts

I am using Retrospect Desktop 5.1.77. My Mac is an eMac with the hard disk partitioned into 2 partitions. The main partition uses MacOS X 10.2.8, and I have a small test partition that has 10.3.3 and nothing else. I've been backing up to CD-RW media religiously, and figured that I wanted to test the restore capability of Retrospect before upgrading my main partition to Panther.


For my test, (while booted into 10.2.8) I backed up my small partition, backing up everything (it fit on 3 CD's). I then erased that partition using the Disk Utility from Jaguar on my main partition. Now I did a full volume restore back onto the small partition and everything went without a hitch... and yes, I deselected the Ignore Ownership checkbox for the small volume.


I now changed my startup disk to point to the restored volume and this is where the problem began. The system appeared to boot correctly up until the small spinning pinwheel that is displayed before you get to the logon screen. The problem is that that's where the system remains forever... with the spinning pinwheel, and it never goes any further.


What am I doing wrong? I really need to prove to myself that I can do a successful volume restore before I begin a major update to my main partition.


Thanks in advance for your assistance.



Link to comment
Share on other sites





Thank you for pointing to your article #27186. I actually did see this, but the problem is that since this is a small test partition I likely would not have the room for two operating systems, so let me tell you what I did since my original posting because this gets a pretty interesting.




After restoring my backup set to the test partition, at this point it just hung at the spinning pinwheel (not the colored ball) during startup. I rebooted from disk 1 of the Panther installation disks. From the Installer menu, I ran the Disk Utility program and told it to repair permissions on my test partition. It seemed like every file on the disk had to be corrected. I noticed that every file corrected had permissions of 99 or 501 and these were corrected to 0 and 80 (I hope I didn't reverse these two, but you get the point).




After that the system successfully booted to Panther 10.3.3. However, all is still not golden. The only programs besides the operating system that I have loaded onto this test partition are Norton Utilities, Norton Antivirus, and Techtool Pro. As the boot process completed, I got multiple dialogs indicating that all the kext and other startup files associated with these programs were not correctly installed and were therefore, inoperative. So far, the only resolution to this that I can find is that I have to reinstall these programs.




Do you know that following the article you referred me to would have prevented these problems?




You see, at this point I'm beginning to wonder exactly what benefit is Retrospect giving me if I have to reinstall the operating system before restoring by backup sets, and afterwards having to reinstall all my applications? My assumption is that the Documents, Music, and Photos folder would have been correctly reinstalled.




I am asking all these questions because I have been using Dantz backup products for close to 20 years and they have always performed flawlessly. This is my first experience with restoring an OS X system and I'm having more problems than I've ever had. Would upgrading to Retrospect 6 help me avoid any of these problems?




Thank you for your previous reply and I look forward to your response.





Link to comment
Share on other sites

I just finished another 3 or 4 hours of time following directions provided by Dantz technical support. The tech support guy's position was that Retrospect 5.1 is not compatible with Panther. I fully described the procedure that I was using and he agreed that I was performing the correct steps.


When I told him that the main compatibility issue noted in their release notes was that scripts would not auto-launch under Panther, and that this is not an issue for me, he restated that version 6 would solve my problems. Since version 6 is available as a time-limited (30 days), fully functional demo, I had an opportunity check it out.


The bottom line is that version 6 did not change any of the symptoms, I'm stuck again with the spinning pinwheel.


Any additional ideas?


Link to comment
Share on other sites

Following the steps in the KB document will not result in 2 copies of the Mac OS on the disk. The Restore Entire Disk will erase/replace the temp system on the disk. In the end you will be left with a single install.


The beachball at startup could be an indication of a problem with the restored system being "blessed".


In this process, you are not restoring back to the original startup disk, correct? Does that original disk still exist on the computer? Has it been lost or reformatted?

Link to comment
Share on other sites

Let me bring you up to date with exactly what I am doing and where I'm at. These steps have now been done exactly the same way with Retrospect versions 5.1.177 and the demo of version 6 that I downloaded yesterday.




1) I have a v5.1 set of backup CDs that were created backing up the entire test partition (Panther 10.3.3, most recent Norton Utilities, Norton Antivirus, and TechTool Pro). The Panther OS was fully updated from Apple.


2) Erased entire test partition.


3) Installed Panther to the test partition from the original disks, then did all the software updates from Apple until it indicated that it was fully up to date. This required two update sessions. I am booting from the test partition with the newly installed Panther OS.


4) Installed Retrospect on the test partition.


5) Did a Retrospect entire volume restore of the test partition while booted from the test partition. (According to Retrospect warnings, at earlier points I ensured that the checkbox to ignore permissions for the test partition was unchecked, but as far as I can tell, this is only possible when booted from a different volume.)


6) Retrospect erased and restored the test partition from the backup CDs with no errors and a successful indication.


7) Attempted to reboot from the test partition, but at the grey screen with the dark grey apple, the spinning pinwheel goes forever.




I will leave the disk in this state now until I hear if you have something you want me to try. Previously, I found that if I boot off the Panther install disks and launch Disk Utility and repaired permissions, zillions of files had to be changed from permissions of 99 and 501 to 0 and 80. After a very long time when this completed, I was able to boot successfully from the test partition, but Norton Utilities, Norton Antivirus, and TechTool Pro all complained that certain of their components were incorrectly installed and that I needed to reinstall the applications.




As stated earlier, the symptoms have not changed whether I use version 5.1 or version 6 of Retrospect Desktop. Further, the original backup disks were made with version 5.1.177, using all the default Retrospect settings.




Please let me know any thoughts you have on this because I count on Retrospect.







Link to comment
Share on other sites

The following is my most recent posting to the Macintouch website where I was also discussing this problem and getting suggestions...


A few days ago I started the topic of restoring Panther volumes with Retrospect Backup. With clues provided by one of your readers (Merle Reinhart) and assistance from Robin Mayoff from Dantz Technical Support, I believe I’m on the verge of enlightenment, and yes, I have successfully restored my Panther volume.


There is a critical point that I believe, for the short term, needs to be covered in a knowledgebase article and a software release notes addendum. For the longer term, I definitely believe that the software needs to operate a bit more intelligently.


The reason for all my restore problems was because I did the backup while booted from a different partition than the one I was backing up. This would not have been a problem except that the partition I was backing up was also capable of being a boot volume.


So here is the bottom line for Retrospect Desktop v5.1 and v6.0 (and likely any other compatible version)-- Install Retrospect on any volume capable of booting, and most importantly, do your backup of a boot volume while booted from that volume.


Regarding Merle’s statement from a previous posting: “After initializing the volume you want to restore, change the ownership to be root and group admin with privileges of rwx for the owner and group and r for the world.”, when I checked the ownership of my volume after erasing and reinstalling everything from scratch, everything he said was true except that my ownership was system and not root. Other than checking this just one time, I have not done any investigating about the discrepancy.


RMayoff, thanks for the help, and any clarifications or corrections to this posting is gratefully accepted.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...