Jump to content

Strange Performance Issue with Retrospect 5.1.175 and SCSI DLT1 (under Mac OS X v10.3)


Recommended Posts

My system is a dual 1.0 GHz "MDD" G4 with 1.5 GB RAM and an ATTO U3LD ExpressPCI Pro Ultra160 SCSI card. I have only one SCSI device attached: a Quantum 40/80 GB DLT1 drive. I am running Mac OS X v10.3, upgraded from v10.2.8. I have experienced no other issues or strange behaviors at all after upgrading (in fact my system has been 100% stable and faster than before).

 

 

 

I was performing a large (43GB uncompressed) backup today. Sometime late in the compare phase, my system started "lurching" (for want of a better term). It would perform normally for a few seconds, then appear to hang (sometime the cursor would freeze, sometimes not). During these freezes, tape drive activity would stop, the clock would stop updating, iTunes would stop playing, and essentially the ENTIRE OS would be hung. Then it would unfreeze for a few seconds (and act normally), then the cycle would repeat.

 

 

 

The volume being backed up was an 80 GB Mac OS Extended (journaled) HFS+ partition on an internal 200GB IDE HDD.

 

 

 

Retrospect shows no errors (though, as expexted, the performance was lower than normal), and my system logs show nothing unusual. I stopped all other applications (iTunes, iCal, DragThing, & Mozilla) with no effect. However, when I paused the Retrospect compare, the problem went away. The system was perfectly responsive again. Until, that is, I resumed the Retrospect compare. Then the strange freezes resumed just as before. I aborted the compare because I didn't like the extra stress being placed on the tape drive (since it wasn't streaming), and because the 43 GB backup had already compared ~36GB with zero errors. CPU, disk activity/usage, and system memory (including VM) usage appeared fairly normal as viewed via Activity Monitor during the freeezing episode. This was a local backup, and so there was no network activity to speak of.

 

 

 

Small Retrospect backups don't appear to initiate these freezes. I have only seen this once, but it was the only large backup I've performed since upgrading to Mac OS X v10.3. I have used this same setup with Mac OS X v10.2.2 through v10.2.8 for over a year, and never saw anything like this...

 

 

 

Any ideas?

 

 

Link to comment
Share on other sites

  • 3 weeks later...

Memory usage appeared to be fairly normal.

 

For the time being, I've moved the tape drive to my PC (I also own Retrospect 6.5 for Windows), installed my one remaining Retrospect client license on my Mac, and am backing the Mac up via the PC. This is not what I want long-term though.

 

Given how little Dantz is saying about this issue, I've decided to look into alternatives (specifically BRU for Mac OS X from The Tolis Group). I hope Dantz gets out a fix soon (or at least sends out an update status message to its "Panther and G5 Support" mailing list), because I'd REALLY rather not spend another $250 for BRU...

Link to comment
Share on other sites

This is exactly the issue I am having with 5.1/10.3.1 Server on Xserve/Atto card/Sony Storstation (AIT3). Performance will grind to almost a holt and eventually crash the machine. Stopping whatever retrospect is doing stops the problem until you start it again. Quiting Retrospect will clear it, until the next time.

 

Activity monitor icon shows one processor maxed out and the other at zero.

 

This is intensely annoying on such a mission critical piece of software. As is the apparent wait until January for an upgrade. Dantz must have had copies of 10.3 early enough to have identified the problems, if not to fix them. We could have been warned!

 

I have had to go back to 10.2.8 server under which 5.1 is perfectly happy.

 

Graham.

Link to comment
Share on other sites

Im encountering a similar problem with a g4 server, 10.3, LaCie AIT (actually Sony SDX-300C) drive, 68-pin SCSI connection to Atto Express PCI PSC card. Unless the machine and retrospect have both been recently restarted, I get basically zero performance (2 mb/min) and/or hanging up the whole machine as described in Darly's original post. If I restart everything I can get it to run normally, although if I try to run a second backup without restarting, I get the slow performance and stalling again.

 

Twice now I've also had retrospect hang up during recycle backups while comparing the same file on one of the client machines. I get a 'miscompare at data offset' error on the file

 

"NAVMac800QSFile"

 

and I have to abort the backup and start over. The first time I was able to run a normal backup and get it to pick up where it left off but I haven't had a chance to see if that will work a second time.

 

I've loaded the SCSI and 5.1 Driver updates from Dantz. The SCSI seemed to help, as initially I could not get it to do anything at all.

 

Has anyone tried updating their PCI card firmware? I was thinking of doing that next if I can figure out which model it is (the system profiler has a different model number than the sticker on the card itself. argh.)

Ted

Link to comment
Share on other sites

My ATTO card was not OEM so maybe I'm lucky...I might be able to update the firmware. But it makes me nervous. i see posts from people who can't get SCSI devices to work at all. I'd hate to end up in their shoes, so I may just leave it alone.

 

My workaround is currently to restart the server that's running Retrospect just before I start the backup. For some reason this flushes out the crud and let's it run normally (as best i can tell). Kind of a pain, but at least it works. i'm hoping some kind of patch will be announced at MacWorld. I just spend a few grand upgrading my office to OSX; I'd hate to have to go buy a Firewire AIT drive, too...

Link to comment
Share on other sites

Strange performance issues? How about lack of performance? I'm having so many hassles with retrospect that I'm looking for alternatives. I'm using a G5 running 10.3.2 with the new firmware update, an ATTO 4D card, and a Quantum DLT8000. I've flashed the card properly, Retrospect sees the drive, and backups commence. However, when the tape gets close to the end, Retrospect pretends to continue, but nothing is happening either on the tape drive or elsewhere. The rest of the machine is happy. The only way out is a force quit.

 

The few times that I have actually gotten to the end of a tape and the program tells me to insert a new tape, the status window tells me that the tape is unloaded even after I switch tapes and put the handle down. Drive whirrs happily, dialog box still says tape is unloaded. I try rescans, nada. Only way around that is to quit and restart. Then I get to wait while it counts up all of my files again.

 

Last time I tried calling tech support, I was on hold for 40 minutes. I don't have time for that, unfortunately. And I can only tell when the backup has failed by waiting the many hours to fill a tape. Any ideas anyone? Please? Help meeeeeeee.

Link to comment
Share on other sites

Hi

 

Just in case you haven't heard -

XServe/Mac OS X Server

Dantz, along with several other software and hardware companies, have been actively investigating Mac OS X Server backup problems reported by customers in the field. The core issue reported is that after a certain period of backup to SCSI-attached tape, the server (most often an Xserve) becomes unresponsive or is restarted by the watchdog utility.

 

Dantz and the other companies involved are working together to find the root cause of--and a solution to--this problem. To be notified when additional information is available, Dantz recommends that affected customers sign up for the Dantz Xserve mailing list.

 

The word on the street is that this may apply to all OSX systems but no official word on that yet.

 

Nate

Link to comment
Share on other sites

I am getting the same problem but with OS X Server 10.2.8. Recently received the Panther upgrade but daren't install it.

 

I am completely unable to back up clients and have only some success with the server after a re-boot.

 

This is a real problem. Is anything likely to be done about this in the near future?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...