Jump to content

Error 109 with tape restore


Recommended Posts

I had a hard drive failure and was attempting to do a restore when about 20 hours in to the restore on tape 10 of 11 Retrospect just stopped and wrote the following in the event log:

error 109 (unexpected filemark or FTP end of file)

 

I was restoring using a Pismo laptop and a 1.2TB firewire drive from a VXA-1 tape drive. I can't restore using the G5 (the computer that had the hard drive failure) because it always "just stops" after about 10 hours or so. No errors or anything, just doesn't talk to the firewire VXA drive anymore. But That is a separate issue. The laptop and firewire tape drive and firewire hard drive are completely isolated, the computer has the newest version of the Retrospect - 6.1.126, RDU 6.1.3.101.

 

I attempted again, and encountered the same error.

 

I then performed a recatalog operation - a very lengthy recatalog operation. After recataloging for 4 days, it found a bunch of bad backup set headers on tape 10, and I attempted a full restore again.

 

Same error, same place..

 

I attempted a restore with a previous snapshot. Same error on tape 10.

 

I attempted restoring various groups of files, and sometimes they work, sometimes I get the error 109.

 

My drive crashed on a Tuesday, only 24 hours after a backup which included data verification, so I can't see how that last 20GB could have verified correctly but can't be accessed now. I also don't understand how/why it dies half way through tape 10, but won't continue past a failed portion of a tape on to tape 11.

 

This has so far been about a 3 week long issue (drive crashed on valentine's day), and I have just tried to grab what I can off the backup set by restoring specific files and completely rebuilding my 200GB+ of data that was "supposed" to be backed up. I would feel better if I could at least find out what I can't recover. I feel like a catastrophic failure has occurred when it really shouldn't have.

Link to comment
Share on other sites

It's pretty clear that tape 10 is damaged. Unfortunately, tape is an inherently fragile medium, so it's best to have data backed up to more than one tape backup set.

 

Retrospect doesn't offer a convenient way to identify files by tape member. However, you can work around this by going to Configure> Backup Sets> [name of backup set]> Members to find out the date and time that the damaged member was first written to and when the following undamaged member was written to. Then, initiate a Restore from a backup snapshot and when the searching has completed, select the files occurring between the dates/times you identified. These will be the files on the damaged tape.

 

If there are only a couple of spots on the tape that are damaged, you may be able to restore some of the files from the damaged tape though a trial-and-error process of selecting files a few at a time. If you watch the restore progress window (expanded to that the name of the file being retored is displayed), you may also be able to catch which files are problematic and exclude them from a subsequent restore.

 

(It would, of course, be nice if Retrospect were able to do some of this automatically--something for a future version, in our dreams.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...