Jump to content

Retrospect 6.1 FTP data segment size limit


Recommended Posts

Greetings,

 

I'm attempting the following procedure on Retrospect 6.1 on OS X v.10.3.9 Server with ResKnife with out sucess. Any suggestions?

 

For FTP backup, Retrospect begins by creating 1 MB segments as the

minimum segment size and then scales up to 16 MB depending on the speed

of the connection. While this is appropriate for dialup or even

broadband based connections, it is not optimal for large scale backup to

a corporate data center.

 

Retrospect 4.3 changes that by providing a way to adjust the minimum and

maximum FTP segment size for large network situations.

 

In order to get the best use of Retrospect FTP backup in your

environment, you will need to set both the minimum and maximum segment

sizes to something more appropriate based on your network setup. You can

set the minimum and/or maximum sizes to anything up to 512 MB. If your

goal is to minimize FTP backup segments stored on the server set both

the maximum and minimum to the same value.

 

NOTE: Changing the minimum segment size does not guarantee Retrospect

4.3 will create the minimum segment size if the individual backup

session in question is less than the minimum segment size. For example,

if you set the minimum FTP segment size to be 128 MB and the incremental

backup of a particular hard drive is only 10 MB, the segment size for

this particular backup will only be 10 MB. This is by design and can't

be changed. However, the minimum size is respected in all cases where

the data backed up is greater than or equal to the minimum segment size.

 

 

Changing the minimum and maximum segment sizes in Retrospect

 

To change FTP segment sizes in Retrospect, you need the following:

 

- Copy of the Retrospect 4.3 application

- ResEdit resource editing tool from Apple

- Optionally a calculator that supports decimal to hexadecimal

conversions.

 

1) First determine your minimum and maximum FTP segment sizes in

megabytes. You will then need to convert this number to KB (MB x 1024 =

KB) and then convert the KB value to hexadecimal to enter into

Retrospect.

 

Some sample values are below:

 

128 MB $00020000

256 MB $00040000

512 MB $00080000

 

2) Make a copy of the Retrospect 4.3 application.

 

2) Launch ResEdit and select the copy from above and click Open.

 

3) Double click "Def#" resource in the resource list.

 

4) When it opens, scroll down until you get to item 42, which says key

is FMIN. It should like identical to the screenshot below:

 

5) Change the FMIN data value to the minimum number determined in step

1.

 

6) Change the FMAX data value to the maximum number determined in step

1. The following screen shot shows what things should look like when you

have set both the maximum and minimum to 512MB ($00080000).

 

7) Quit ResEdit and save the changes to Retrospect. Remove all other

copies of Retrospect on this machine so that only the newly modified one

will be launched for backup. If you need this change on multiple backup

servers, distribute this modified copy of Retrospect to each desired

machine replacing any other version.

 

Summary:

Changing the minimum and maximum segment size for FTP backup in

Retrospect 4.3 and later allows Retrospect to work better in large data

center based environments.

 

Now if I can just get this to work in Retrospect 6.1?

 

Thank you in advance,

 

Mark Engle

Link to comment
Share on other sites

Quote:

Now if I can just get this to work in Retrospect 6.1?

 


 

You've provided the complete directions from Dantz. But what have you tried? What did you do, what did you see, etc.

 

I did this successfully with 5.0 and 5.1, and although I never tried it again with 6.x, I doubt that the program changed in any way that would break this.

 

You need to share your experiences with us.

 

Dave

Link to comment
Share on other sites

But of course, I'll provide more details. Sorry for the delay, I've been out of town.

 

Short and sweet, I'm trying to reduce the # of data segments, by increasing the size of the data segments in a FTP/Internet backup set to 512MB from 16MB. I'm exceeding the 32,000 data segments limit per backup set in Retrospect with a FTP/Internet backup.

 

When I open the Retrospect.app from within the Retrospect package using ResKnife, I believe I'm able to locate the Def# resource, but not "item 42" with the FMIN & FMAX keys. The ResEdit experience described in the instructions, I'm unable to replicate in ResKnife. It may be me, but the result is the same. I can't find where to make these changes in Retrospect 6.1 with ResKnife. Any help?

 

TIA,

 

Mark Engle

Link to comment
Share on other sites

ResKnife seems to work differently then ResEdit did, at least in the default configuration when it's downloaded.

 

Resorcerer works in OS X the same way as ResEdit, although it's commercial.

 

In ResKnife, find the Def# resource, and when you open it simply count 24 of the "*****" lines. Then click the disclosure triangle and you should find "Key FMIN / Data 1024" with "Key FMAX / Data 16384" below. If you don't see the right field, click some more of the triangles until you find the right ones.

 

Since ResKnife displays values in decimal instead of hexadecimal, you should be able to edit the values in the Data field directly.

 

Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...