Jump to content

One Source of 505 Errors Found

Recommended Posts

I am so damned happy I finally found this one.




I've been wrestling for a couple of weeks with one stupid win98 laptop that would not be backed up by Retrospect 5.0 on OSX. This user roams away from the office a lot, so I don't get a lot of chance to fuss with their laptop. As well, it's "their" laptop not the company one so I don't have free reign to maintain the configuration on it, although I do back it up as part of our schedule when it's around. For the last month, on the few occasions the machine has been present, the Retrospect backup server would whine about "505 (client reserved)" errors, 519 errors, 1028 errors. Most times it would stop during the initial scanning files phase with "Net Retry". Sometimes it could scan all the files but never get an actual backup underway without a "505" error. If I went to the client and looked it would say things like "In use by "root" scanning" (I'm trying to remember from memory here, excuse me if I miss some details), even though Retrospect had given up and moved onto another machine or gone idle.




Well I knew this was something wrong with the client machine, and not Retrospect, because it had been working fine just a month ago. Something had happened to the client configuration in that time. I uninstalled the 5.6.112 client, I reinstalled it. I even dug out my old floppy and installed the Retrospect Remote 1.1 client on it. None of that worked. I also tried a different brand network card, different network cable segments, different locations in the building (including one across from my own bloody desk so we were on the same hub). Nothing had any success. I had no current backup so I wasn't comfortable with the "reformat and reinstall" solution.




So I resorted to Retrospect itself. I had several backups from this machine already, so I exported the huge list into excel and started looking for obvious changes. I will note the user pleaded ignorance saying that nothing had changed on their part (feh). I looked down the list and found a very different looking installation of McAfee Virus Scan Online. Yep, sure enough this user at one point had followed some dialog boxes to "upgrade" their pre-existing mcafee stuff. They now had "Virus Scan Online" and "Privacy" but not the "Firewall" product bought and paid for and installed on the machine.




On a hunch, I disabled the auto-startup for the virus-scan, so that I would think it wouldn't be running. That didn't make the situation any better. I disabled all the mcafee startup items I could find in "msconfig", that didn't help either. I was ready to think it wasn't it and it was something else when I read a bugzilla report (#111316, search on http://www.mozilla.org/ ) from mozilla on mcafee. I don't pretend to be an expert on Mozilla, but their problem seemed to be that Mcafee Virus scan was installing a shim against the winsock.dll and intercepting all traffic going through it looking for viruses. That rang a bell in my head, since Retrospect has to talk tcp through winsock as well. The discussion hinges around a dll installed by mcafee called "MCSCAN32.DLL", which sure enough, this machine had now, but didn't have in it's original backup from a month ago.




So I took the gamble and uninstalled the Mcafee Virus Scan and Privacy stuff, and after the required I reboot I am happy to report that Retrospect 5.0 on OSX is happily backing this machine up as if nothing was ever wrong. So it appears that not only was it the cause, but just 'disabling' mcafee in it's own control panels wasn't enough to fix it, it had to be uninstalled completely. I don't know if re-installing it will make the problem re-occur, but I do know I'm getting this damned machine backed up before something else goes wrong. Since I de-installed both the Virus scan and the privacy stuff at the same time before trying it, I don't know which one of those it was specifically.




I hope someone else finds this useful, and spares them my consternation of the past couple of weeks.




Steven Cogswell



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...