Jump to content

Error 2249 in backupset transfer


Recommended Posts

Retrospect, Windows

I have an old archive tape backup set which I am trying to transfer to new media for preservation.  The original set was created in 2010 with a much earlier version of Retrospect.  I'm not certain, but it most likely was version 7.6.  I want to make two copies on new (denser) media so I decided to do a tape to disk transfer first so that I would then be able to make the two copies from disk to tape without having to read all the old tapes a second time (there are 36 members).

All was going fine until part way through member 15, which reported the error:

        Can't access session 9/29/2010 3:18:18 PM, error -2249 (could not find session)

At that point the transfer stopped and it started verification of the destination disk backup set.  When the verification completed, Retrospect triumphantly declared "Execution completed successfully", even though more than half the source backup set was not transferred.

I looked at the session contents of the source set and indeed there is no session listed for this exact time.  There are two which closely bracket it and I know they were laid down consecutively by a single script with multiple source volumes.  Obviously the catalog is corrupt in some way.

A second attempt at the transfer matched all the sessions already transferred with no files to transfer and without requesting a tape to be loaded, and then failed with the same error message.

I tried temporarily marking member 15 as missing in the hope the transfer would continue from 16, but no luck, it still stops at the same point.

I tried a catalog repair, which requested the last member of the set, and while it completed OK it had no effect on the problem. 

I tried the "rebuild from tapes" option, but that asks for the "most recent member", which I assume also means the last.  This time it read the full tape then asked for the next member if there was one.  Since there wasn't I selected Done and it finished.  Still no effect on the problem.  I wouldn't expect there to be really, since how can starting from the last member fix a problem that is clearly associated with a much earlier member?  There does not seem to be an option to explicitly start the rebuild from an earlier Member.

What is the best way to proceed?  If I give the rebuild operation member 15 (or perhaps 14?) instead of the last will it go forward from there to the end of the set?  Or must I start right from 1?  Any guidance from those more experienced would be appreciated.

Link to comment
Share on other sites


I did a catalog rebuild from tape starting at member 15.  I stopped it after the single member, so that gave me a catalog of members 1-15. The Backup Set Transfer then worked without a problem, so I am now running the rebuild from Member 15 to Member 36.  Hopefully problem solved.

Further update:


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...