Jump to content

Disaster Recovery fails with RAID, can't restore from Windows either


russellg
 Share

Recommended Posts

I replaced the motherboard, CPU, and RAM in my Windows 10 PC and I'm having trouble restoring the C drive from a NAS backup using Retrospect 18.1.

The first problem was that with the old motherboard, I was using the legacy BIOS mode with MBR disks, and now with the new motherboard (ASRock Z590 Taichi) I want to use UEFI with GPT disks.

The second problem is that the C drive was actually a RAID-1 mirror with two 500 GB SATA SSD drives (not m.2).

After several attempts before understanding the first problem, I lost the data on the RAID volume. But I created a full backup of it on a NAS drive a couple of days ago, before upgrading the motherboard.

To convert the two SSD drives from MBR to GPT, I found that the easiest way was to install Windows 10 on each of them separately, and it takes care of it as well as creating the reserved and system partitions.

Next, I set the motherboard to disable CSM and Fast Boot, and changed the SATA Mode from AHCI to RAID (actually "Intel RST Premium With Intel Optane System Acceleration (RAID Mode)"). I then created the RAID-1 volume with the two SSD drives. My plan was to then restore the whole C drive back to the RAID volume. That's when the problems with Retrospect started.

I booted from a Retrospect Disaster Recovery USB drive but it didn't see any of the local hard drives (neither the RAID volume nor the 3 other non-RAID SATA drives). It only saw the X drive and the 32 GB USB drive with WinPE. I also tried having Retrospect load the Intel Rapid Storage Technology driver that came with the motherboard, and it loaded ok but it still wasn't able to see the local hard drives. 

(Side note: Retrospect DR isn't able to load drivers from folders that contain spaces in the name. It returns an error for each individual word in the folder name.)

To get it to see the local drives, I had to change the SATA Mode back to AHCI. But of course then I lost the RAID volume again.

After multiple failed attempts at various things, I got the idea to leave CSM disabled but set the SATA Mode to AHCI (for Retrospect DR), install Windows 10 on each of the SSD drives (to setup GPT and the partitions), and then use Retrospect DR to restore the whole C drive back to each of the two SSD drives individually. My thinking was that if that worked, I could then switch the SATA Mode to RAID and create the RAID-1 volume again.

However, when I tried to do the restore using the DR drive, it started by deleting the files that didn't need to be there, and then it just stopped the restore process without copying any of the files that needed to be restored. The history didn't explain why, but it showed 1 error: "The system state could not be restored":

Quote

[*] RestoreESPData: statePath X:\ProgramData\Retrospect\RtrExec.dir\Exec\State\ESP doesn't exist, return kErrGeneric
[*] WinXPMetaLoc::XPMdRestoreESP: RestoreESPData failed, error error -1 (unknown)
The system state could not be restored.
System configuration restored, please reboot the computer.
1 execution errors

So instead of using the Retrospect DR drive, I decided to just boot into Windows 10 from one of the other non-RAID drives, install Retrospect, and do the restore from there. I remembered that you can't restore the C drive while you're booted off of it, but in this case I was booted off of a different drive. I set the SATA Mode back to RAID, created the RAID-1 volume, and then used Retrospect in Windows to do the restore to that volume. It copied all the files, but then ended with the same error above, saying the System State couldn't be restored. When I try to boot the restored volume, it gives a blue screen error 0xc000000e saying, "A required device isn't connected or can't be accessed".

So now I'm stuck.

Question 1: What's the best way to convert an MBR drive to GPT, and get all the partitions setup correctly?

Question 2: When I create the RAID-1 volume in the UEFI settings, how much of the two SSD drives have to be identical first? Can I just have data on one of them, and it'll copy it to the other drive? If so, which one is the parent? Or will it even keep the existing data?

Question 3: Why isn't Retrospect restoring the System State? I have a perfectly good backup of the entire C volume but I can't restore it, either while booted off a different Windows drive, or from the DR drive.

Thanks!
Russell

Link to comment
Share on other sites

If the original backup had the bios configured for legacy boot mode, you need to be using legacy boot mode during the restore.  The Microsoft ASR writer will fail to restore registry/partition info if the boot mode is different when you are doing the restore vs what you had during the original backup. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...