Jump to content

Restore Attempt Throws Error -1,124

Recommended Posts

Attempting to restore an entire disk (4TB / GUID / MacOS Extended (Journaled)).  The disk in question is a non-booting media drive which was dropped by a careless individual and no longer functions, but was completely backed up a couple of years ago.  Running Retrospect 16 on a trashcan MacPro with Catalina, connected to a Tolis 8 slot library (HP drive / LTO6) via HighPoint SAS card in a Sonnet TB2 expansion chassis.  My restore destination is a 4TB RAID 0 in an OWC hardware TB2 enclosure, which is blank and is named the same as the dead drive.  This is the same rig that created the original backup.

Upon running the script, I get the standard warning about ignoring ownership, then Restoring from <media set>, snapshot <volume>

X !Trouble matching <media set> to <volume>, error -1,124 (invalid file system data)

Execution incomplete.

The script runs for just a few seconds before it incompletes.  Could this be a volume type mismatch - single spinner vs. hardware RAID?  They're almost identical in size (RAID is a tiny bit larger).



Link to comment
Share on other sites


Are you sure the new HDD was initialized as MacOS Extended (Journaled), and as HFS+ rather than APFS if it was first created with macOS 10.12 Sierra or earlier?   This 2012 thread says the -1124 error message used to be "( invalid NTFS data)", even though the OP in that thread said "I don't have an NTFS volume anywhere on my system. It's pure Mac."

What software did you use to initialize the new HDD?   The OP in the thread linked-to in the preceding paragraph doesn't say, so presumably he/she used Apple Disk Utility.  However this post in a 2018 thread says Disk Warrior worked when Disk Utility didn't.

Link to comment
Share on other sites

6 hours ago, Doug_M said:

Attempting to restore an entire disk (4TB / GUID / MacOS Extended (Journaled)).  

My restore destination is a 4TB RAID 0 in an OWC hardware TB2 enclosure, which is blank

If it is "blank", then that might be your problem. It has to be formatted and (as David points out) in the correct format.

Link to comment
Share on other sites

Thanks guys...

I format every new drive prior to use, and I only use APFS on my personal SSDs, or internal boot SSD on newer Macs that require it.  The drive in question is a spinner, formatted with Disk Utility as I said earlier - GUID / HFS+ journaled.  APFS is a complete non-starter on spinners as far as I'm concerned.

I've swapped the 4TB RAID0 destination disk with the single near-line storage unit intended to replace the damaged drive.  It's a recent SATA III, unused (but formatted), and named the same as the drive it's replacing.  Same error as before.

DiskWarrior doesn't have the capability to format a drive - I've been using it for years to optimize or repair damaged directories, which it excels at.

Link to comment
Share on other sites

Not much to look at, but here you go:

+  Restore using Restore 0015 at 5/13/21, 4:40:39 PM (Activity Thread 1)

    To volume ANOD0015...

    Warning: volume ANOD0015 has the "Ignore ownership" setting enabled.

    Note: OS X System Integrity Protection may prevent the restoration of protected files and folders to ANOD0015.

    -  5/13/21 4:40:39 PM: Restoring from Video Bkup, Snapshot /Volumes/ANOD0015, 9/18/18 6:30:09 PM

    5/13/21 4:40:41 PM: Selector "All Files" was used to select 12,748 files out of 12,748.

    !Trouble matching Video Bkup to ANOD0015, error -1,124 (invalid file system data)

    5/13/21 4:40:44 PM: Execution incomplete

Link to comment
Share on other sites

I think the key is this:

Note: OS X System Integrity Protection may prevent the restoration of protected files and folders to ANOD0015.

Try turning it off and see if it helps. NOTE: Turn it on again after the restore.



You must also give Retrospect Full Disk Access:



A bit puzzling is the actual error that says invalid file system data as that might indicate there is something wrong with the file system on ANOD0015.

What kind of restore are you performing? Have you tried "Restore selected files and folders"?


Link to comment
Share on other sites

I'll need to extract the machine to disable SIP (it's headless, in the rack, in a closet), but will give it a go.

RetrospectInstantScan and RetrospectEngine both have full disk access, and appear in the Files and Folders tab of Security prefs.

So far, I've only tried restoring the entire volume, but will give files & folders a try next.

EDIT: Same error.  SIP is next, though there aren't any 'protected' files on that volume - it's all video clips and project files, so I'm not optimistic on this front.

Starting to think I'll need to repair / rebuild the catalog for that set.

Link to comment
Share on other sites


First, from a May 2020 Ars Technica Mac forum post in a thread discussing Apple software development in relation to macOS 10.15 Catalina:


These days, we get rewrites of all kinds of subsystems that reduce functionality and add new bugs. For instance, the new Disk Utility is a disaster [my emphasis], there's so much stuff in there that just doesn't work. And do I even have to mention mDNSResponder vs Discoveryd? Note that in both cases, the existing thing was perfectly fine.

Second, in this thread you've several times written "GUID / HFS+ journaled".  Why are you singling-out "GUID"?  I'm not an OS/hardware expert like Lennart_T, but are you trying to do something out-of-the-ordinary with the GUID of that new 4TB RAID 0 HDD?

Link to comment
Share on other sites

I've not had any issues with Disk Utility, aside from the reduced functionality vs. older versions... aside from the disappointing feature reduction, it's been my experience that the disk formatting functions work perfectly well.  Having formatted hundreds of drives over the past few years, I feel fairly confident that my tools and methods are appropriate and effective for the task at hand.

I singled out GUID because that's the partition scheme for the disk, followed by the volume / filesystem format.  In Disk Utility, you have 3 different partition scheme options - 1) Apple Partition Map (for really old Macs, pre-OSX) - 2) Master Boot Record (for PC formatting / FAT16, 32. ExFAT) - and 3) GUID Partition Map (for all modern Macs) which supports HFS, HFS+ (Journaled or not), and APFS in all its variants.

Nothing unusual or out-of-the-ordinary for the partition scheme or file system format for the volume in question.  As noted above, to avoid any potential issue with the RAID, I removed it from the equation several days ago and instead have been attempting restore with a single 4TB drive in the same enclosure that was used for the original backup.

Link to comment
Share on other sites

SOLUTION - rebuilding the catalog file has fixed the problem.

Note: Fast catalog rebuild option was enabled during archiving, so I was able to rebuild from the last tape in my media set.  Be aware that Retrospect will ask for another tape (last number plus 1, which doesn't exist (!!)). This is Retrospect's way of telling you the rebuild is complete and you should hit the Stop button.

Restore of the volume is underway!

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...