Jump to content

Retro Engine is "un-quitable" - help

Recommended Posts

Hello, I've been transferring older Retrospect media sets with v10.5 and from time to time I need to stop the Retro Engine, but it seems that it's not possible to make it quit. I have tried the preferences pane of course, but I've also tried to force quit in the activity monitor. It just starts up again by itself. Another thing I've noticed, is that there's no "un-installer" in the 10.5 installer in the dmg I downloaded. Is there a generic uninstaller script I can download somewhere?

Link to comment
Share on other sites


First, you haven't said what version of macOS you're running on your Mac Pro (5,1), but on macOS 10.12 Sierra I can stop the Retrospect Mac 16.6 Engine by going to System Preferences->Retrospect (not System Preferences->Retrospect Client, if you've got the Client on the same computer—which I temporarily did a few months ago) and clicking the Stop Retrospect Engine button.  However that button remains grayed-out until I first click the "Click the lock to make changes" padlock icon in the lower-left corner of the dialog and enter my machine's password.  You can later do the same thing in reverse and click the Start Retrospect Engine button.

Second, why do you need to stop the Retrospect Engine?   Since Retrospect Mac 8 all operations are run as scripts,  even if you've Added a new Copy Media Set script in the Console's Scripts sidebar category and clicked the Run button.  So all you need to do is to go to the Console's Activities sidebar category, select the running script you want to stop in the dialog, and click the Stop button at the top of the dialog.

Finally,  starting with this Nigel Smith post in another thread is a discussion of how to uninstall the Retrospect "backup server" Engine.  Below it is a post by me explaining how I first used the Console on my battery-rejuvenated Mac Pro to do "Export server installer and uninstaller" to a thumb drive, so I wouldn't have to Start the Stopped Engine on the MacBook Pro "client" machine on which I had temporarily installed it in order to uninstall it on the MBP.

Link to comment
Share on other sites


Yes, some missing info. MacPro 5,1, High Sierra OS, Retrospect 10.5. This is installed on my home machine so I can continue cataloging from home. I just brought the AIT drive home and it connects via firewire cable. Works well. However, after installing Retrospect on this machine, I've noticed  a couple things. One, very long shut down and restart times, around 10 minutes, and two, the retrospect engine won't quit, for anything. I noticed that it wouldn't quit when I had a recatalog process fail because of a bad tape. This left the drive in a strange state where it would no longer communicate with Retrospect. I read somewhere that I might reconnect to the drive without having to restart simply by turning off the drive, stop the retro engine, turn on the drive, and restart the retro engine. I don't know if it works because I can never get the engine to stop. I've never seen this before. Thoughts?

Link to comment
Share on other sites

  • 2 weeks later...
13 hours ago, oslomike said:

It magically restarts itself in seconds. It's alive! 🙂

No magic -- just LaunchDaemon doing its thing. From the Engine's plist:


So if you want to force-quit the RS Engine you'll have to unload the LaunchDaemon plist first. Untried, but

sudo launchctl unload /Library/LaunchDaemons/com.retrospect.retroengine.plist

...in Terminal will probably (I'm looking at v13) do the trick.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...