Jump to content

client not being recognized

Recommended Posts

Just installed the v17.0.1 (141) client on 2 MacBook Pros using the same installer folder (with my public key) on each one.

In Retrospect 17.0.0 (149) on an iMac Pro running Catalina, I was able to add one of the laptops but not the other.

The client that's not being found is awake and showing "ready for Retrospect login" in the pref panel. I've restarted Retrospect and tried rebooting that laptop as well as uninstalling/reinstalling the client. All 3 computers are on my home wifi network. The laptop that's not being seen is running Catalina and the other one isn't but I do have a 3rd client MacBook Air running Catalina that was previously recognized without any problem.


Link to comment
Share on other sites


Does the MBP which you can't Add have multiple network interfaces?  This sounds to me, whose LAN is much less complicated,  like that situation.

First read this "Client Security" section in the Retrospect Mac 17 User's Guide.  Make sure you have done what it says for the MBP you can't Add.

Next, open the Advanced tab of System Preferences -> Retrospect Client for both the MBP your iMac Pro "backup server" can see and the one it can't see.  Look at the Public Backup Server field on the tab for both those MBPs.  Are they the same?  If they're not, Click The Lock to Make Changes, and then click the Edit button and set the Public Backup Server field on the MBP that can't be seen to the same address as the one that can be seen by the "backup server".  However the P.P.S. of this post in that same thread says that field was introduced in Retrospect Mac 15 for Remote Backup—which I gather you aren't using, so it may not be applicable in your situation unless it's been expanded for use in ordinary public/private keypair security.  But read the preceding portions of that post.

If that hasn't solved your problem, read the rest of that thread—concentrating on the posts by Nigel Smith.

BTW you should probably upgrade your "backup server" to Retrospect Mac 17.0.1, which has a lot of bug fixes even if none related to this.

P.S.: In regard to your post directly below, Retrospect.app is the Console—not the Engine which is installed in a "seekrit location".

Edited by DavidHertzberg
P.S.: Retrospect.app is the Console
Link to comment
Share on other sites

Thanks for the info. Interestingly late last night (without any intervention on my part) I got a message from Retrospect that the MBP had been added as a source. The laptop had been asleep ever since I had tried adding it in the afternoon.

Even though Retrospect is in the Applications folder, I get an error when I try to update-. Will try the manual updater.

Quit Retrospect, move it into your Applications folder, relaunch it from there and try again. Retrospect can’t be updated if it’s running from the location it was downloaded to.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...