Jump to content

error -3050 (VSS reported an error)


Recommended Posts



When starting a full backup I get the following error in the log.


"Can't use Open File Backup option for Local Disk (C:), error -3050 (VSS reported an error)"


The backup doesn't halt, but I did stop it rather than let it complete.


Any ideas on how I should I proceed or what this is?



Link to comment
Share on other sites

There is no post to be found for error "-3050" (you have to use quotes to avoid finding posts that simply have the number 3050) via the Forums' Advanced Search facility.  I did a  search for "VSS", using quotes because otherwise Find Words doesn't like three-character arguments, but this post was the closest to being applicable—and it just tells you that changes Microsoft may have made to VSS for Windows "Creators Update" have caused problems for Retrospect Open File Backup.


VSS is now known as Shadow Copy.  In the next post (#4) following the one linked-to in the preceding paragraph, Hofstede says "Please check the event log of your computer for VSS errors at the time of backup. That will likely give you a better indication what's wrong."  There is a 2012 Knowledge Base article called "Open File Backup Tips" whose last paragraph says more or less the same thing.


Soda does not say what version of Retrospect or of Windows he/she is using.  If it is Retrospect Windows 12 and he/she has Annual Support and Maintenance (or is within the first 30 days of purchase), he/she may be able to get telephone help from Retrospect Tech Support.  Otherwise Soda can file a Support Case, using the procedure spelled out in post #6 of the thread containing the post linked-to in the first paragraph of this post.  He/she will definitely have to supply the version of Retrospect and of Windows he/she is using.

  • Like 1
Link to comment
Share on other sites

Run the services.msc program from the search box, or the program from Control Panel | Administrative Tools | Services.  It's the same thing.


Find the Volume Shadow Copy program.  It is normally stopped and marked to start Manual.  Try to start it and see if it will go.  If it does start without error and it's not being asked to perform any jobs it will probably stop by itself, and that's normal behavior.  Your backup job might run OK the next time.


If VSS doesn't start or gives an error you'll need to restart your system.  If your backup job fails again restart your system.

  • Like 1
Link to comment
Share on other sites

Thanks for all the inputs.


Support confirmed to me that it would be ok to go ahead with the backup and as long as I don't have any open files, then 100% of the data will still get backed up.


Incidentally on a side note I managed to fix the vss error and get everything working properly. My problem seemed to point at the Hyper V shadow copy service and removing it as a VSS provider as outlined in the following post fixed it for me.




However there is no guarantee that this maybe the same reason someone else would have a VSS error, so do make sure this solution is applicable to you before following it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...