Jump to content

File/directory not found messages during backup


Recommended Posts

I'm using Retrospect 11.5 Desktop/Professional.  Frequently I get numerous error -1101 (file/directory not found) messages during the initial copy phase of backups.  These are almost always files that are always there, not ones deleted between the scan and the copy phases.  Also, they are not the same files every time.  Generally, rerunning the backup works, but that is a pain.  Retrospect is supposed to be more automatic than that.  It happens on the "server" PC and both of my 2 clients.  It's not a new problem, but rather something that has been happening for a long time.  I'm running Window 10 now, but it was happening long before that.

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

This may not have anything to do with Roger Fajman's problem, since I'm a Retrospect Mac administrator.  


However, in order to test out Retrospect e-mailing (which I don't normally use, because my "backup server" machine is 40 feet away from my client machines in my apartment) in connection with a script hooks problem another Retrospect Mac administrator is having, yesterday I Removed and Added one Mac client after having updated its Retrospect Client software to the latest version.  When I then ran my usual incremental "Sun.-Fri. Backup" script this morning, I got -1101 errors for three volumes other than the boot volume on the one client that is a Source for that script.  It turned out that these other Retrospect-detected volumes are some kind of garbage (cache volumes?) on my one-and-only SSD drive in that laptop client.


When I looked at the Source definition for that client, it turned out that Retrospect Mac—the latest version—had defaulted to selecting All Volumes in the options dropdown for that newly-re-Added client Source.  I have now re-Removed and re-Added that Source, changed the options dropdown to Selected Volumes and selected only the boot volume for that Source, and re-checkmarked that Source for all scripts that back it up (and dragged that Source up to the top in the summary window of all multi-source Scripts that are supposed to back it up first).  We'll see whether that change makes my -1101 errors go away.


P.S.: The change did make my -1101 errors go away.  Again, since all my machines are Macs, this may not have anything to do with Roger Fajman's problem.


P.P.S.: I have now filed a Support Case about these -1101 errors.  We'll see if they're a result of a Retrospect bug or a macOS bug.

Link to comment
Share on other sites

The last paragraph of the "description of your issue" in my Support Case (the rest of it was essentially a duplicate of the second and third paragraphs in post #6 in this thread) read:


"Why are these 3 _other_ Retrospect-detected volumes showing up? They have long hexadecimal-number names.  Are they some artifact of my client's SSD drive, which was installed about 3 months ago to replace a failed HDD? Or are they some artifact of the Retrospect Add Client process?"


To which the Agent Response was: 

"The Retrospect Client runs with full admin permissions (root of the Mac).  Retrospect asked the operating system to display all available volumes.  If extra volumes are displayed on a newly added client, it is because the file system reported the volumes exist, even if you are unable to see them yourself.  I am unable to explain exactly what those volumes are in your case, but the operating system does believe they exist in some way."


To which I have now replied:


"With the greatest respect, I simply don't accept the explanation in the response of July 26, 2017 12:26 [which I have copied as the Agent Response two paragraphs above this].

The only way the Retrospect 'backup server' can get any information about what's on any drive attached to a client computer is through the Retrospect Client for that client computer.  That Retrospect Client is running with the same full admin permissions, under the same OS, when it is being used for a Backup as when it is being used to Add a Source.  How can the 'backup server's' Add Source see extra volumes on a newly added client, but the same 'backup server's' Backup process give 'Scanning incomplete, error -1,101 (file/directory not found)' messages for those same extra volumes?"
I have added to that reply a final paragraph linking to this thread, especially posts #1 through #5—which refer to similar -1101 error problems with a Windows "backup server" and Windows clients. 
Link to comment
Share on other sites

In my Support Case, there followed several exchanges of Additional Notes yesterday, following Retrospect T.S.'s request the day before yesterday that I upload my operations_log.utx file and a copy of any applicable screenshots.  I'll spare you these Additional Notes, since they are Retrospect-Mac-specific and this is a Retrospect Windows forum.


However IMHO my last Additional Note is worth reporting (slightly abbreviated), since it is of more cross-platform applicability.


"Following up on the Agent Response of July 27, 2017 12:27:

As mentioned in the second paragragph of my Description of Problem of July 26, 2017 03:17, I already did what you suggested. The trap for others is that Sources—>Add—>Options defaults to All Volumes, including the 'phantom disks'.

The 'phantom disks' may in fact be the result of a new wrinkle/bug in macOS 10.12.6, since I don't recall having this problem when David's MacBook Pro was booting under OS X 10.10. The machine had a new SSD installed, to replace a failed HDD, about 3 months ago by ...; at my request they installed macOS 10.12 on the SSD. I then ran Setup Assistant [a facility of macOS] to put back all other files from a portable HDD onto which I had done a Retrospect Restore of the latest Backup of the HDD. I haven't done anything since except a couple of upgrades, including to macOS 10.12.6.

I'm sorry if Apple has made life difficult again for Retrospect Inc.. But IMHO you'll have to change Retrospect Mac to compensate for that.
Link to comment
Share on other sites

I thought I posted this before, but it's not here. I decided to upgrade to 11.1 and find it to be much more reliable. It doesn't get those file/directory not found errors all the time. It's a problem that existed for years, over many versions. It looks like they finally fixed it. It shouldn't take an upgrade to get a fix for something like that...

Link to comment
Share on other sites

On 7/30/2017 at 9:55 PM, Roger Fajman said:

I thought I posted this before, but it's not here. I decided to upgrade to 11.1 and find it to be much more reliable. It doesn't get those file/directory not found errors all the time. It's a problem that existed for years, over many versions. It looks like they finally fixed it. It shouldn't take an upgrade to get a fix for something like that...



OK, let's all cross-post 🤣.


Roger Fajman didn't need to post this, because he's been beaten to the punch by Johnny Mac in this post.  However post #1 in this thread says Roger Fajman was already using Retrospect Windows 11.5, so I think he has actually upgraded to Retrospect Windows 12.1—whose Release Notes says it contains a couple of fixes for the -1101 error (insert appropriate smiley here).  Anyway it's nice to know that both administrators' -1101 errors have been fixed. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...