Jump to content

Retrospect v12.5 Server Suddenly Stuck/Dead?

Recommended Posts

Hey all. Wondering if anyone has any thoughts about this...

Within the last month or so,  Retrospect (v12.5.0 (111)) on my iMac (OS 10.11.3) has suddenly stopped working. It's as if the server side just can't start up. I'll launch the application, I'll get a "Connecting," all the various things will populate in the interface, then wham, it's back to "Connecting" again. Even worse, when I went to write this I checked and now I can't connect at all to the server. To note: the server and the Desktop client tools are running on the same iMac.

I've run the Retrospect Engine Installer.pkg but that hasn't seemed to help.

Activity monitor says that the following are running...



  Retrospect Client


Yet, I can't get the application to connect with the Server.

I've added and removed the server within the application a couple of times. Sometimes as the local iMac's IP, sometime as the local loopback ( Still nada.


Any suggestions would be greatly appreciated!

Thanks in advance.



Link to comment
Share on other sites

Can we assume that you've tried rebooting your iMac?


If that hasn't helped, try this: Quit the Retrospect console app and stop Retrospect engine in System Preferences. Then, drag the files Config80.dat and Config80.bak from /Library/Application Support/Retrospect to the desktop. Restart Retrospect engine and launch the Retrospect console app (you'll need to reenter your license code). If things are fixed, that would mean that your old Config80 is corrupt. Unless you have a good backup copy of Config80.dat, you'll need to recreate all your scripts and lists from scratch.


If the problem still exists, run the Retrospect uninstaller and then reinstall Retrospect. If all goes well, you may then be able to move your old Config80 files back to /Library/Application Support/Retrospect. 


By the way, unless you are backing up this iMac from another machine, there is no need to run Retrospect Client. Although it's unlikely to be causing problems, you may just want to uninstall it.

Link to comment
Share on other sites

So, FWIW, I had a similar (but not quite) problem after updating from 10.11.2 to 10.11.3.


Normally, I stop the engine in the Sys Pref, but leave it checked to start at system startup.  I did this as usual prior to updating to 10.11.3.   I thought Retrospect was fine -- but it wasn't until a couple of days later that I noticed that none of my proactive backup scripts were working?


Things only started working when a scheduled *groom* script ran -- then as soon as that finished, all the proactive scripts started working again.    I've reported this, but I don't know how easy it is to reproduce...


Bottom line -- it probably makes sense to reboot twice after any 10.11 OS upgrade these days...

Link to comment
Share on other sites

Thanks folks! Appreciate the input!


tickland... Thank you SO much for this... I could NOT figure out where the Engine (server) tools were other than via the Console (also a word I wasn't getting out).

Alas, stopping the Engine, removing "Config80.bak" & " Config80.dat," and then restarting didn't change the issue. Console tries to connect, gets the Engine (server) for a second or two and then it drops.

I'll give the uninstall/reinstall a try when I have a little more time.

I DO have some scripts built. Is the Config80 the only files I need worry about to keep?



Link to comment
Share on other sites

You will definitely want to save your media set catalogs. The catalogs should not be affected when you run the uninstaller, but to be absolutely safe, you could also drag the catalog folder to the desktop. (The default location for this folder is also in /Library/Application Support/Retrospect.)


One thing I hadn't thought of: there is also a user preference file for the Retrospect console, which is located in your user library at ~/Library/Preferences/com.retrospect.Retrospect.plist. I'm not aware of this file causing problems, but it couldn't hurt to trash this file (when the console isn't running) and see if that makes any difference.

Link to comment
Share on other sites

  • 2 weeks later...

Well, to conclude... I tried removing a variety of things from the /Library/Application Support/Retrospect in a variety of ways and nothing seemed to make a difference. I tried uninstalling and re-installing but that helped but only until I tried putting back my preferences and files. Then it went back to having the Console continually drop the connection to the Engine. I finally just removed everything and re-installed from scratch. I rebuild all my settings and am currently doing a backup. It seems to work fine but something got pretty well messed up.

So, it appears that if you have this issue, the only way to solve is to do a full delete and re-install from scratch and rebuild your settings/scripts.


As an aside... when I re-installed there is no longer an 'uninstall' script. Did I miss something? Where did the uninstall go?


Thanks everyone!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...