Jump to content

Rebuild Retrospect 10.5.0 - Not enough application memory


Recommended Posts

Currently running Retrospect 10.5.0 on Snow Leopard Machine:

 

 

 Processor Speed: 2.66 GHz

  Number Of Processors: 2

  Total Number Of Cores: 4

  L2 Cache (per processor): 4 MB

  Memory: 13 GB

HDD Capacity: 496 GB

Available: 396.91 GB

 

 

Have been using Retrospect 10 to rebuild catalogues that were previously being used within version 6.

The rebuilds have been going fine but lately I have been getting an error of:

 

'!Not enough application memory'.

 

Nothing in my opinion has changed from when we started rebuilding catalogs and in my opinion I would think that the machine being used has plenty of system memory.

 

Has anyone else come across this error on rebuild/repair?  

Surely there should be an easy solution to this that I'm just missing, or isit simply a bug?

 

Any info would be great.

 

Thanks

Link to comment
Share on other sites

Just ran system monitor whilst Rerstrospect was trying to rebuild and the activity monitor said that it never dropped below 13GB of free memory at any time.  Should I therefore rule out a system memory problem?  The issue still says not enough application memory so that is maybe leading me in the direction of it being a bug/software problem.

If anyone could get back to me on this with maybe the same problem that would be great!

Link to comment
Share on other sites

I am indeed running 10.5.0 and I did a reboot yes. The rebuild files shouldn't be corrupt as I've previously rebuilt this set on the system but it got lost. So in theory if I update the machine to Yosemite and install the latest version that could very well fix the issue?

Is the last digits (145) in the version number?

 

Yosemite is a lemon. 

If you don't want El Capitan, go for Mavericks. That is, if you really want to leave Snow Leopard.

Link to comment
Share on other sites

  • 2 weeks later...

Ok think I've solved the problem.  Seems to be running smoothly now but we shall see.

If anyone else gets this problem here's how to fix it.

 

It had nothing to do with system memory but seems that there were too many activities within Retrospect running at once which was giving the '!not enough application memory' error message on rebuild.

 

Luckily there is an option within general preferences that allows you to choose how many activities can run at any one time.  The number in the activity threads box had defaulted to 16 so I simply changed this to 1 and now it seems to be running without any problem at all.

 

I have also attached an image so everyone can see where this is.

 

Thanks

post-87720-0-72016800-1454684675_thumb.png

Link to comment
Share on other sites

  • 3 weeks later...

16 is a lot. 8 could be a lot. Being able to run more than 1 - like 2 - is wonderful.

 

However, it's not often that more than 2 or 3 are of real advantage. If you get several threads either reading or riting to the same device/disk, you end up spending all your time seeking the head. Other scenarios also limit the actual amount of "parallelism" you actually get.

 

Each thread can burn a lot of memory and/or other resources. I'd be inclined to limit the threads to 2 or 3, unless you have a good plan, and a good reason.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...