Jump to content

USB Drives on Server machine forcibly disconnected in Retro 12

Recommended Posts

Retrospect forcibly dismounts (forcibly ejects) external USB drives when completing a backup. This happens at the conclusion of a backup caused by my script. I see no options to do this. Other externals (connected by FW) are NOT dismounted, only USB drives.  The maker of the product says the fault pins to Retro, since it doesn't happen in other Backup or normal Finder uses (tried on CCC without error). Naturally they never heard of this before.


To recover from this, I need to manually reconnect the drives- remove and reconnect the USB cable. The device is a 4 port USB drive interface for bare SATA drives from Startech.com (SATDOCK 4 U3E). Happens with Retro running on Yosemite, and other OS's. Is there some setting or other preference controlling this. It has been happening regularly and seems to have followed the last version update (V12). 


Please note: the Eject tapes and discs option in the script is NOT CHECKED. 

  • Like 2
Link to comment
Share on other sites




Ever since I installed Retrospect 12.0.2(116) in July on my Mac Pro, I've been getting intermittent messages from Mac OS X 10.10 warning me that I shouldn't dismount drives without doing it through the Finder. These messages come when I boot up the machine, and thus seem to refer to something I must have done previously. I just boot the machine once a day after having left on whatever client machines are going to be backed up that day, let Retrospect run the one scheduled backup script after it starts via System Preferences->Users & Groups->Login Items, then eyeball the Log and shutdown the Mac Pro. I don't bother to see if the USB drive-of-the-week is still really mounted.



I'm still getting this occasionally, I think, under OS X 10.10.5 running Retrospect 12.5. My USB3 G-Tech G-Drive Slim drive-of-the-week is attached to a NewerTech USB/eSata host adapter with 6Gb/s ports. Tomorrow after the backup script runs, I'll quit Retrospect and attempt to do a GetInfo of the USB3 drive.

Link to comment
Share on other sites

I spoke with support on this one, and their advice to me was:

  1. Retro uses Finder to deal with drives via commands issues to access, open and close drives. We didn't go into detail about it but suffice it to say that there is no un-mounting or mounting of drives in Retro. That action could only occur in Finder, according to tech support. 
  2. Advice on this product since the rep had a similar one and has had issues like mine in the past... Look at USB interface either on the device or on the machine causing issues. Replace the Dock if it proves to be a USB related issue. 
  3. Try un-mounting (in Finder), physically disconnecting the Dock, rebooting the computer, reconnecting the dock to a different USB port of the the server machine. 
  4. Then, try a repeat of the Retro backup that causes unmount to see if the drives disconnect by themselves. 

Well, I tried that with the added step of checking out each drive to see if it would reliably mount and un-mount on it own. Found one drive that was sticky in the regard and repaired it, removed it, and made sure it worked to mount and un-mount from the Finder (and in Disk Utility). Once that was done, tried running the same script again. Seems OK, for now. 

Link to comment
Share on other sites

Yesterday I unintentionally left Retrospect 12.5 idle on my Mac Pro under OS X 10.10.5, after running my usual 8-hour "Sat. Backup" of 6 drives onto the Recycled Media Set White. This morning around 9:30 a.m. I noticed that the Mac Pro was on, and that the normal "Sun.-Fri. Backup" No Media Action scripted backup of my MacBook Pro—which should have run at 3 a.m. if the MBP was running—failed around 4:15 a.m. during the scan with error -559 (network connection timeout). (This possibly happened because I had been working on the MBP intermittently during the night, and put it to sleep at some point.) There were 8 warnings from OS X about G-Drive White having been removed, all of which disappeared when I clicked on the top one in the right-of-screen column of warnings.


I then manually started the "Sun.-Fri. Backup" script, which incrementally backed up the MBP unevenfully in 10 minutes as usual.


What occurs to me is that, since I have regular-to-micro cables attached to two different 6Gb/sec ports on my NewerTech USB3/eSata host adapter and usually alternate between them as I swap G-Drives on Friday afternoon, maybe the cable I used to attach G-Drive White wasn't solidly plugged in. But then why did the "Sat. Backup" script run in the normal amount of time without unusual Log errors?


Oops, while I was writing this on my MBP, I got an unexpected but welcome long phone call. I had rebooted the Mac Pro just to check the Retrospect Log for this post, but then pushed the cable attached to G-Drive White and felt it move in a millimeter or two. When I just now went to shut down the Mac Pro, there was a removed-without-dismount warning for G-Drive White sitting at the top right corner of the monitor. Maybe there's a cable/port problem that's causing these warnings.


P.S.: I later remembered that, when I first saw removed-without-dismount warnings back in July, I had just installed Retrospect 12 and attached the newly-purchased G-Drive White. I named it G-Drive White, and created Media Set White on it, because I had recently used the Storage Set Red to make backups onto DAT tape under Retrospect 6.1 on my G4 Digital Audio tower running OS X 10.3.9 (and I—as a patriotic American—give three cheers for the Red, White, and Blue in that sequence ;) ). I think the adapter port and cable were the same as on Saturday.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...