Jump to content

Surface Pro 3 Windows 10 failure


bignordique
 Share

Recommended Posts

I have a Surface Pro 3 originally running Windows 8.1.   Retrospect client 8.1.0 (266) has run pretty much flawlessly now for some months.

 

The server is Windows 7 also running Retrospect 8.1.0 (266).

 

I "upgraded" to Windows 10 and Retrospect no longer works.  When I launch a backup it seems to find all the files to be copied and then when it starts copying the files over the Ethernet, Retrospect hangs and eventually errors out.  

 

Strangely, the wired Ethernet on the Surface Pro 3 becomes unusable until I unplug and replug the cable.

 

I disconnected the wired Ethernet and switched over to the WiFi.  Retrospect backups appear to work over the WiFi.

 

I should be able to get by with the WiFi, but prefer wired since its faster and more secure.

 

This probably not a Retrospect problem. 

 

Anyway I thought I would post it here to see if anyone else has had a problem like this.

 

Thanks in advance for any clues.

 

Bignordique

 

 

 

 

Link to comment
Share on other sites

It's probably the drivers for the NIC in the Surface Pro 3 that isn't up to date.

As a second option, the firmware on the NIC needs updating.

 

Now, since Windows 10 is new, updated software may not have been released yet.

 

But check the manufacturer's website for more info.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...