Jump to content

Retrospect 10.0.0.213 prevents sleeping


carternp
 Share

Recommended Posts

Since installing 10.0.0.213 the workstation on which this software runs never sleeps. If I attempt to make it sleep then after around five seconds it will wake up again. I note that in the release notes there is this entry:

 

[Fixed] Prevent Retrospect server from entering sleep mode during backup (#4080)

 

I'm unclear whether this means that its intended to never allow sleeping but the way I read this is that the fix is intended to prevent sleeping *during a backup* but I am seeing this behaviour when Retrospect is idle.

 

Are there any work rounds for this problem or can this be raised as a bug?

 

I'm happy to supply any further diagnostic information if needed.

 

Thanks.

  • Like 1
Link to comment
Share on other sites

Full hibernation still works.

 

What I have discovered from my limited testing is that after a restart or cold boot the Retrospect server will enter and exit sleep normally (I use a third party application for scheduled sleep/hibernate and wake) until Retrospect is launched. After Retrospect is launched, and even after it is exited, sleep no longer works.

Link to comment
Share on other sites

Will disable Instant Scan ans report back.

 

Made no difference.

 

I disabled Instant Scan in Retrospect and also stopped and disable the Retrospect Instant Scan service (Control Panel > Administrative Tools > Services). I then exited Retrospect, set the target power state to Suspend (which translates to hybrid sleep in Windows 7) in SmartPower and restarted the machine. After the restart I launched Retrospect and left the machine to carry out its schedule.

 

By the schedule the machine should have gone to sleep just after 23:00 but at 08:00 the next morning it was still running. I connected (RDP) to the machine and changed the target power state to Hibernate and once the inactivity period expired the machine hibernated.

 

Before Retrospect 10 both Suspend and Hibernate SmartPower target States would work but now only Suspend will work if Retrospect 10 has been run on the machine. If Retrospect 10 is never launched after a cold start or restart then Suspend will work but once Retrospect is launched it will fail. Even if Retrospect is closed Suspend will still fail until a restart resets whatever parameter Retrospect 10 has set/changed. 

Link to comment
Share on other sites

I have instant scan disabled so I concur that I don't think that is the cause.

Are you using any Proactive Backup scripts?

 

I was doing some more troubleshooting with the Windows 'powercfg.exe' utility and found that if Proactive Backup has not been activated (in this case because it is outside scheduled backup period) after Retrospect is launched then Windows sleeps. I will see what happens later after the scheduled backup period.

Link to comment
Share on other sites

Yes, I have some Proactive Backup scripts setup, and I agree that this is worth investigating as a cause of the issue. I will do some testing over the weekend and report back. If this is the cause though I think there should be some way of disabling the behaviour through a setting/registry fix etc.

 

Thanks for your help.

Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...