Jump to content

Cannot Add SMB Share (credentials not valid)


Recommended Posts

I have had a root-level folder on another computer that was shared via SMB, to act as a place to keep some media sets. It began to report as offline, so I started to investigate. I finally got to the point of just removing the share, intending to add it back in again... except that I cannot.


When I click on "Add Share..." and then put in Server "SMB://xxx.yyy.zzz.abc/VolumeName", together with the correct Username and Password, I get "These credentials are not valid". All of this information is entered exactly as I recorded it from when I first set up the share; this share has been being used for a while now. The only significant recent change I can think of is that the machine was upgraded to Mac OS 10.10, and apparently during this process, the SMB sharing was turned off. I detected that right away, and tried just to turn SMB sharing back on, but that didn't work. That's when I began trying to roll things further back, by removing the share with intent to re-add.


I know that the credentials are valid, because I reset the password on the host machine, turned file sharing off, rebooted, and restarted the RS8 engine to be safe. I can enter those credentials and access the shared volume via Finder. They are the same credentials that are used for a few other shared volumes, so I don't particularly want to change them.


The host machine is running Mac OS 10.10, but the RS8 engine is installed and running on a machine with Mac OS 10.5.8.


What can I do to get my shared volume back?

  • Like 3
Link to comment
Share on other sites

  • 2 weeks later...

Here is a rundown of the various methods I have attempted, thus far without success:


1. Force Mac OS 10.10.2 to utilize SMB-1 protocol (in lieu of SMB-3)

2. Try to add the Share in Retrospect as "cifs://servername/volume" instead of "smb://..."

3. Tried multiple variations of capitalization, just in case of case-sensitivity

4. Disabled then re-enabled SMB sharing as well as Guest account (both of the "sharing-only" accounts on the host machine)

5. Updated host machine to Mac OS 10.10.3


Nothing seems to work.


I suppose I haven't yet tried changing the credentials (password), which I have wanted to avoid since the same credentials are used to connect to several other similarly-shared volumes, but I guess I can check that next.


Anybody have any other ideas?

Link to comment
Share on other sites

  • 4 weeks later...

Just out of curiosity - are you really using Retro 8 for Mac server to back up Mac OS X 10.10? Even if you get it to work, there is new metadata in the newer Mac OS that Retro 8 does not know about. I'm surprised that it even runs.


I gather the engine is running on Mac OS  10.5.8? Is that the limiting factor on an upgrade to newer Retro?

Link to comment
Share on other sites

  • 3 weeks later...

The main limiting factor of upgrading Retrospect is our uncertainty whether we wish to persevere with the product. We have been evaluating other options  (including our whole backup paradigm), but as long as I can get Retrospect to behave properly then we can continue using it. I'm not likely to just purchase a more current version in the hopes that it resolves the very particular failure mode that I am seeing.


So for the time being, we've been using a work-around, by relying on Carbon Copy Cloner to handle the one particular server volume that isn't getting backed up since its media set cannot be seen by RS8. The work-around is effective enough that it calls further into question our need for Retrospect.


We have not had other issues regarding backing up data on machines running Mac OS 10.10; we have Client 6.3.029 running on them, and only certain folders are backed up, not the entire boot drive and operating system. The volume that isn't getting backed up by RS8 right now is actually on an external drive hosted by Mac OS 10.8 Server; the problem isn't in talking to that client, though, but in the fact that the "destination" where its media set has been kept is now on a 10.10 system.


In other words, I can talk to clients on 10.10 systems, and read their data for backup purposes, but I cannot "see" an SMB-shared volume from a 10.10 (non-server) computer. Apparently I need to have that media set on such a shared volume, unless perhaps there is a way to define media sets such that they utilize the RS8 Client in lieu of volume-sharing.

Link to comment
Share on other sites

  • 2 weeks later...

Depending on how many machines you are backing up, how important it is to do backups frequently, and other factors, the cost varies, and the importance of upgrading to get *correct* backups varies.


I don't know how much upgrading to v12 will cost you (see above), but I can tell you that the list of improvements/fixes between Retro v8 and Retro v12 is very long. If you are backing up Mac OS X newer than 10.8, you are not even getting correct backups.


In my opinion, a few hundred dollars for an upgrade is dirt cheap if you value your data and your time. You may have already burned more time keeping v8 running than it's worth. Even if you are evaluating other solutions, just getting today's backups to be correct would be well worth the cost. Buy yourself some time.


Just my opinion.


No, I don't work for Retrospect. ;->

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...