Jump to content

Disk media set with 2 members does not work

Don Lee

Recommended Posts

I ran into a problem backing up to a disk data set ("Users" on a FW drive) and needed to make the member "bigger". This was in the middle of a backup operation, and I didn't want to kill it, so I wanted to just edit the size of the existing member. Retro would not let me edit the single member in the set, but it would let me add another member, so I added a second member. I ended up with 2 members. One was limited to 186 GB, the other to 44 GB.


I ran into a problem the next day with the backups, with multiple attempts to back up to this set, and each try I got:


- 11/29/14 9:35:24 PM: Copying Databases

!Catalog File out of sync with Media Set "Users".

11/29/14 9:35:59 PM: Execution incomplete


I tried to "repair" the dataset, and it still did not work - same error. I tried the repair several times. The repair behaved badly, too. I could not get the "add member" dialog to show me the "1-users" and "2-users" members. It would only show me one "member" called "Users". Despite succesful "repairs", the subsequent attempts at backup all failed the same way.


I ended up doing a media set copy to a temp media set, with the intention of copying the data back to "Users". When I did a recycle on "Users", I noted that the two members had the same size - 44 Gb. I enclose a screenshot, FWIW.


I am now copying the data back to "Users". I'm confident that the recycled media set with one member will behave.


Looks like a bug (or two) to me, but I don't know if I could reproduce it, tho.


(sorry about the formatting - the forum doesn't seem to let me format the post)


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...