Jump to content

Missing Disk Backup Set .rdb Files


Recommended Posts

Hi, All,

 

One of my clients has been using Retrospect 8 to backup their Server 2008 R2 box and seven Win 7 Pro 32 clients for a couple years now. Everything has been going well and previous file/folder recoveries (very few of them) were successful.

 

Since I hadn't performed a Backup Set Verification in about a year, I initiated one and waited the estimated 4.5 hours for it to complete. Came back to have a look and noticed the Verification status showed as "Resynchronizing (this may take a while)." Indeed it is taking a while…now over 9 hours.

 

A peek at the Verification session log shows 533,248 (and counting) entries as follows:

 

Trouble reading: "1-Backup Set A" (74742972), error -102 ( trouble communicating)
Additional error information for Disk Backup Set member "1-Backup Set A",
Can't read to file F:\RetrospectDailyA\Retrospect\Backup Set A\1-Backup Set A\AA000417.rdb, error -1101 ( file/directory not found)
 
I should note the above error repeats thousands of times for the same .rdb file (AA000417). There is also an error for AA000525 repeated thousands of times. Up to now, no other .rdb files are referenced in the Resynchronizing errors.
 
Retrospect writes .rdb files sequentially, each being 614,408 KB in size. That said, the latest .rdb file is AA002527.rdb. So counting the rdb_del file also in this directory, there should be 2528 total files.
 
There are 1576 .rdb files. Some 950 .rdb files are gone.
 
Looking at the directory where these Backup Set files are stored indeed shows AA000417.rdb is missing. A further look shows  various time periods within the disk Backup Set.
 
This Backup Set is configured to auto-groom to 10 copies. I do see the effects of grooming on some of the .rdb files as their size varies from a few KBs to something close to the 614,408 KB max size of the other .rdb files. But the missing .rdb files??? I've never seen Retrospect completely groom-out/remove/delete .rdb files from a disk Backup Set. Not on Retrospect for Windows or for Mac. Never.
 
So is it a media problem? Someone deleting .rdb files manually? There are a couple people tasked with rotating the backup media every week. And one of the Backup Sets is offsite when not in rotation. Both disk backup destinations are LaCie 2TB RAID Mirrors connected via USB 2.0 to an HP server, all new as of October 2012. The 'B' set is next to Verify. I'll update this entry after determining how the 'B' set looks.
 
Thanks for your time.
 
Steve
  • Like 2
Link to comment
Share on other sites

Addendum:

 

The last comment from Swish in this thread suggests the catalog rebuild fixes this verification problem. He/She also suggests Retrospect should handle this, apparently, grooming-related issue more gracefully. To which I must agree:

 

http://forums.retrospect.com/index.php?/topic/147354-cant-verify-browse-or-restore-from-backup/

Link to comment
Share on other sites

Upon initiating the catalog rebuild and pointing Retrospect to the corresponding Disk Backup Set, the system indicated there was only one 'missing' .rdb file and asked if I wanted to proceed, knowing no files from this missing .rdb file would be referenced in the backup. I proceeded and the catalog rebuild is progressing at about 1,800MBs/minute. Once complete I'll run the Verification and see how it goes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...