Jump to content

Had a hard time doing a bare-metal restore...


Recommended Posts

Hello All !

 

Here's the story... that kept me awake for around 2 days...

 

I have an XP SP 3 VM running under VMWare Fusion 6.0.2 on my Mac OS 10.9.2 Mac Pro (2008), and backed up by a Retrospect 7.7 SBS server. I've been using my VM daily for years, but it was giving signs of malfunctionning (freezes with a black screen after login in). I decided to rebuild it from scratch, by creating a new one with the same characteristics under VMWare Fusion, and then doing a bare metal restoration with the Retrospect 7.7 Rescue CD and my latest backup.

 

It didn't work as intended. I was able to boot the VM from the Rescue CD iso, and got the first dialogs for the restoration. The problem was that the Emergency Recovery Wizard was unable to configure correctly the (virtual) network card: it kept assigning a localhost address (127.0.0.1) which is pretty much useless when you want to connect the Retro Client to the Server in order to restore everything. In fact, the option "Adjust drivers to support new hardware" shown on the documentation page http://www.retrospect.com/en/documentation/user_guide/win/disaster_recovery and that I linked here was missing:

 

http://download.retrospect.com/docs/win/v8.0/user_guide/img/en/addendum_rug-17.jpg

 

I remember doing a bare-metal recovery on a physical PC some years ago using the backup from my server over the network, and it had worked fine. Why isn't this working today anymore ? Is it because I was trying to do it on a VM ? Why is that "Adjust drivers..." option missing from the wizard ?

 

I ended up recreating my VM anyway by first installing Win XP from the CD, then the Retrospect 7.7 client and then doing a full restore on it. After some tweaking around (notably because for some unknown reason the MBR of my VM was messed up, and I had to restore it with the CD console), I finally was able to use it normally.

 

Thanks for your ideas,

Paul-Henri

 

 

 

 

Link to comment
Share on other sites

I don't know if this also applies to VMware Fusion but in VMware Workstation the default virtual NIC configuration can emulate three different hardware types depending on what OS is installed and if the VMware Tools virtual network driver is installed. This split personality of the NIC can confuse some utilities that don't understand virtual hardware. (The NIC can be locked to a specific type by manually editing the .VMX file but this can result in no network access if the OS does not have a driver for the selected type.)

 

When I've restored Windows XP VMs from Clonezilla images the MBR often ends up corrupted but Windows 7 VMs have restored without issue. (Linux VMs mostly restore without issue too.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...