Jump to content

mysterious behavior - Console evaporates, config80 balloons

Don Lee

Recommended Posts

Reporting the news. All retro 10.5.1 (145). Console running on mini, 10.6.8. Engine on 10.8.5 on newer mini. 16 GB mem.


I had the console up for a while. I clicked on "refresh" for one of my clients, and it seemed to take a while. I put the console in the background and forgot about it.


A good hour later, I brought the console to the front, and it was *still* spinning, waiting for access to the client. I clicked onthe little "x" to tell it to quit, and then clicked on the client, and the "refresh" again. I don't remember exactly what I did at that point, but the console stayed up, and the engine appeared to crash. The display collapsed to the icon for the engine/server, and it said "connecting".


I tried to restart the console, and it did not help. It also refused to connect the the enfine.


I moved over to the server, and being aware of the problems with retro crashing and messing up its prefs, I decided I would see if there was a crash log, and maybe do something about the prefs *before* i restarted.


On the server, the engine was still running, but refusing all console connections.


As I recall, after I restarted the engine, the console still would not connect. Once the engine was up, restarting the console worked.


I went to the control panel on the server, and noticed that "instant scan" was enabled (I KNOW I disabled it and left it disabled) I unlocked it and pressed the stop button. The engine stopped.


I then went to /Library/Applications Supprt/Retrospect, and noticed that config80.dat was 14.7 MB, and config80.bak was 1.7 MB. This looked sub-optimal. I don't want one of those huge config80.dat files.


I moved config80.dat to config80.dat.bad, and then I copied config80.bak -> config80.dat.

I also copied config80.bak to config80.bak.bak (just in case - not certain retro is actually backing up its pref files)


I restarted the engine, and all is well EXCEPT that the "activities" prior to today are all gone. I can see the activity in the log, and I can see the passt backups, but the stuff in the "activity window is gone.


Small price to pay.


Why did it crash?

Why did it crash without actually crashing?

Did the "non-crash" cause the "large" config file?

Why did the crash "re-enable" the insta-scan?

What state in the console would prevent it from connecting to the engine?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...