Jump to content

Question about un-mounting AFP shares

Don Lee

Recommended Posts

(env: retro 10.2.0 (201) on Mac OS X 10.8.x)


I have re-configured my volumes and have eliminated the need for one of my remotely mounted "sources" on the retro sever.  finished the reconfig, and removed the AFP volume "backup" from the source list in the console.


Since I had removed the volume from the export list on the server, I wanted to make sure that it was truly no longer accessible to the retro engine, so I tried to re-mount it.


It worked (!)


I found that when you remove an AFP volume from the source list, it does not necessarily unmount the volume.


This may be right, and might be wrong, but it was unexpected.



Link to comment
Share on other sites

  • 6 months later...

My experience is that if I have an AFP share listed in "sources", the volume is mounted by Retro.


There are cases where I need to un-mount that volume, but there is no explicit way to do it.


Stopping the engine does not do it.


Removing the "source" from the sources list does not do it.


The only way - short of command line - to unmount these volumes is to reboot the machine.


Is there any plan to address this? Retro should have a way to cleanly un-mount the volumes that it has mounted.The

 obvious thing would be to enable the "Eject" button that is already present in the GUI.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...