Jump to content

Console gets confused between two engines

Don Lee

Recommended Posts

I have seen this now several times, but I don't know how to reproduce it. It is with retro v 9.0.2 (107),

both engine and console. Setup is the console running on Macbook Pro laptop running 10.5.8, and engine running on Mini with 10.6.


The problem is that if I connect to more than one engine, if I leave the console open a while, the console will end up showing the wrong info in the various windows.


For instance, if I look at the scripts, it will show scripts for both engines in the same window, as though it has merged the lists. Clicking on one of the scripts will show the wrong source and destination media sets/sources - again, with names that are consistent with being from the "other" (wrong) engine.


I have been unwilling to "play with" the console in this state, being unsure what it might actually

do to my backup data while obviously confused.


I have not run v10 enough to see if this happens there, too.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

I have another instance of this and enclose a screen shot of the console. The engine is on a remote machine that I access through an ssh tunnel, so the latency is high (about 200 ms) and BW is under 500 KBits/sec, but it's usable.


The log in the lower pane is clearly for the wrong script. I even hit refresh a couple of times, and changed to another pane and back, yet this log "stuck".



Link to comment
Share on other sites

  • 2 weeks later...

I saw this again this evening. One of my remote engines was complaining of being unable to back up its client. The remote network there is 192.168.0.xx. (I use an ssh tunnel to get there.)


I connected to the engine machine, and the engine was unable to connect to the client to browse files, in addition to the

backups failing with:



+ Normal backup using bu_DBase at 1/10/13

To Backup Set DBase...

Can't access volume Databases on Skinnie, error -556 ( backup client: network interface unavailable)

1/10/13 9:00:03 PM: Execution incomplete

+ Normal backup using bu_DuoUsers at 1/10/13

To Backup Set Users...

- 1/10/13 10:00:00 PM: Copying Users

1/10/13 10:00:53 PM: Snapshot stored, 16.7 MB

1/10/13 10:00:56 PM: Comparing Users

1/10/13 10:01:11 PM: Execution completed successfully

Completed: 843 files, 210.4 MB

Performance: 814.2 MB/minute (788.6 copy, 901.6 compare)

Duration: 00:01:11 (00:00:40 idle/loading/preparing)




I logged into the client, and

noticed that the IP of the machine ( was OK, but the "protected by Retrospect" IP was

This is really odd, because that's in my DHCP range. I tried turning the client off, and restarting it. I'm not sure what

ended up ding the trick, but the client finally changed its "protected by" IP to 192.168.0.(whatever). It's working now.


Clearly something about connecting to that machine through my tunnel has caused it to think that the retro console

(which also connects through a tunnel) picked up a DHCP address from the host of the console.




I also noted that the bi-weekly backup operations were failing. When looking at the scripts, there were

clearly some missing.


Throughout this, I had the 10.0 console open, and connected to both engines. (one engine is v9, the

other is v10)


I've seen this "confusion" before.

Unfortunately, I have been unable to come up with a procedure to reproduce it.

Link to comment
Share on other sites

  • 1 month later...

Very sorry for the delay. I know this data confusion has been an issue since Mac 8.0. However, we thought we fixed it in 9.0 and have been unable to reproduce the problem in-house with 10.0. I tried quite a bit last month and never saw it.


Still, I know you use SSH tunnels to reach the remote servers. Are there situations where the two remote servers have the same private IP (192.168.0.*)? Or when the remote server restarts while the console is open?


Regardless, if you see the issue again, please contact our support team with your configuration (referencing this forum topic), and I'll make sure we address it. Until then, you should definitely relaunch the console whenever you see data issues like this.

Link to comment
Share on other sites

Thank you for following up.


Because the console does not support the specification of port numbers, I use a single server for the tunnels, and re-use the port with a different engine on the other end. I'll set up the tunnel, use the console on that engine, then kill that tunnel and set up a different tunnel on the same port from the point of view of the console.


I learned early on that that got the console all confused, so now I make sure I kill the console between remote-tunnel sessions.


I can't say for sure what triggered the prior problems. All I have is what I remember, and what I documented, like the screen shots.


Yes, it is possible that the remote servers had the same private IP, but I never had more than one remote server connected to the console at once. (I shared a single port/server for my end of the tunnel)


What I could *not* prevent is that I have a local server on the local ethernet that is always present whenever I fire up the console. The confusion was always between the remote/tunnel'd server and the local server.


I have been using the recently posted 10.1 "test version" exclusively of late, and have not seen any of these anomalies. That said, I have also kept my old habits of not doing anything that might trigger it (like killing the console every time I re-connect to a new tunnel). I also try to avoid manipulating both the local engine, and a remote engine in the same "console session". My recollection is that what triggered the confusion in the console was trying to manipulate both the remote and local servers in the same session.


BTW - The local network is not on local IPs. The local engine is never on the same IP as either the remote "private" ip, or the near-side of the tunnel.


I hope this is helpful.

Link to comment
Share on other sites

  • 1 month later...

I hit this problem again this evening.


I was running a console on Mac OS X 10.6.8, connected to a local network engine, and another engine over a tunnel (and a slow connection...) I killed the tunnel, and noticed that some of the media sets from the "tunnel" engine appeared in the list of media sets for the local network machine. I include 3 screen shots. The "AngMac" and "BarMini" sets are from the "remote" engine. I clicked the tabs and tried looking at the details of these sets, and even clicked on "Retrieve" to see that the "hidden" snaps were accessible (I didn't try to actually retrieve them)


The "local" engine is 10.1.0 (221). The "remote" engine (that I disconncted) is retro 9.0.2(107)




Link to comment
Share on other sites

I am still seeing this behavior in V10. Two different engines at two different remote locations. The source and scripts list often get scrambled and I see a mixure of both engine's sources in the windows. I immediatly quit when this happens and it happens often.

Link to comment
Share on other sites

I can also reproduce this problem easily. It is most noticeable with sources - with the screen for a particular engine in the console showing a mix of sources from the two connected engines.


Relaunching the console seems to clear it up reliably, but after a while, it happens again.

Link to comment
Share on other sites

  • 6 months later...

New case today. I had the console up dealing with my "local" engine, and fired up the ssh tunnel to talk to one of my customers (running 10.5 (145)) Note this is a "fresh" console, in that it had not been used since launch to talk to "other "engines, aside from the "local" one (which I can't turn off, except by stopping the engine)


I imediately saw the screen snap that I enclose: (forum uploader hangs.... I posted it.




The scripts displayed are a mix of scripts from my local server and the remote one.The ones with "Skinnie", and "MiniDuo" are correct. The ones that start with "Monthly" and "Weekly" are wrong - from the "local" engine.


I started up the console again, and it displayed the correct data. Note that there were the same number of entries.



Link to comment
Share on other sites

  • 1 month later...
  • 9 months later...
  • 1 year later...

Sorry to say, it's BAAACCCCKKKKK!


Screen shot enclosed.


This screen shot is my console running on my laptop (with external screen) running X 10.8. Retro 12.5

I have two clients attached and active. Both are v 12.5 engines.


I'm looking at the scripts panel, and looking at the sources tab. If you look in the list of Sources, you will see 4 sources that are correct for the engine called "BarryMini". The last one, "Witsend", is my laptop (?). Witsend also shows up in the list of sources of the "virtue" engine.


Note in the second screen shot what SHOULD be displayed for the list of sources for "BarryMini"



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...