Jump to content

Exchange 2007 Mailboxes and Databases not seen by Retrospect after trying 8.0


Recommended Posts

I can not say 100% it is fault of Retrospect 8.0 but it does look like that to me 99%.


After testing Retrospect 8.0 now the Exchange 2007 mailboxes and databases can not be seen as volumes by both Retrospect 8.0 and 7.7.620 any more.


The 8.0 never did manage to add them correctly to Volumes (yes, I had the additional patch needed installed). But after that now even 7.7.620 can not add them to Volumes even though it worked fine before trying 8.0.


Did it leave some files on the Exchange server that need to be removed? I tried with both 8.0 and 7.7 clients removing the C:\ProgramData\Retspect Client folder after deinstalling the client from Add/Remove Programs. If it matters, the Exchange is running on Server 2003 R2 x64.


Now I can not even back up my server with any version of Retrospect or client.


What the hell did it do???


I would really appreciate some advice.

Link to comment
Share on other sites

I have the following in the retroclient.log, if it means anything to anyone:



1353409450: ConnStartListen: starting thread ConnStartListen for

1353409540: Connection established by

1353409560: connTcpConnection: invalid code found: 164

1353409560: connTcpConnection: invalid code found: 153

1353409560: ConnReadData: Connection with closed

1353409565: Connection established by

1353409571: ConnReadData: Connection with closed

1353409582: Connection established by

1353409584: ConnReadData: Connection with closed

1353409588: Connection established by

1353409863: ConnReadData: Connection with was reset

1353409899: PipeRead: ReadFile failed with error 109



So far my search on google and in the Retrospect KB hasn't produced anything.

Link to comment
Share on other sites

OK, I got this sorted out. It seems 8.0 has bugs with Exchange but to go back to 7.7 client you will have to completely remove the Retrospect Client, including deleting the folders C:\ProgramData\Retrospect Client and C:\Program Files (x86)\Retrospect, and then restart the Exchange server.

After that install the 7.7 client as normal and the databases and mailboxes should be visible in Volumes.

Link to comment
Share on other sites

We had the same problem when upgrading from 7.7 to 8.0. I saw this forum post and installed the .Net 4 on the 2003 64-bit server that has Exchange 2007 on it. After that I restarted the Retrospect client and re-added the Exchange license in the Retrospect server and voila! It can see Exchange. This really should be documented somewhere in the Exchange installation instructions for Retrospect 8. A forum post is not where we should find install instructions.


Mayoff, can you recommend a new KB article for this or update the existing Exchange KB article? Can it also be put in the User guide?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...