Jump to content

version 10 comments (background app is expensive; docs)

Recommended Posts

A couple of quick comments.


First: -really-??? We're still getting Retro version >8< documentation? You can't take the time to roll it all into one -current- doc?




Second: how long is RetroISA going to continue eating up 10% of my 8 cores (90% of one) as it parses my files? It's been running for nearly 90 minutes now.


My boot hard drive has over 500 GB of files; some 3.1 million of them.


If it's going to run continuously like that, I'm going to have to uninstall it.

  • Like 1
Link to comment
Share on other sites

RetroISA takes a long time to first generate the "scan" file(s) for the InstantScan feature to work. On my "OS only" test partitions, it was taking about 30 minutes to fully run. If you have more than one partition, it needs to make one for each new partition.


After that, I believe (at least from the last time I looked), it updates that file for changes every 5 minutes or so.


You can watch the construction of the file in /Library/Application Support/Retrospect/RetroISAScans to see the timestamps on the file(s) as to how they are progressing. The more actual *files* you have, the longer it takes to create this initially.

  • Like 1
Link to comment
Share on other sites

FWIW, I installed Retro 10 yesterday afternoon. Last night, Retrospect performed a scheduled backup operation and a copy operation on local HD volumes, employing instant scan according to the log entries. Neither operation took an appreciably shorter time than the previous several nights' operations under Retro 9. For example, the backup operation under both versions took a bit over 25 minutes to back up a couple of thousand files totaling around 20 GB, with around 14 minutes of that time in each case being spent "idle/loading/preparing." I'm curious how great the benefit of the instant scan process is supposed to be.

Link to comment
Share on other sites

How does Instant Scan work?




A: Instant Scan runs as a background process on Retrospect servers and clients to maintain a list of all the files and folders present on HFS+ (Mac) and NTFS (Windows) volumes. It uses FSEvents on OS X and the USN change journal on Windows to keep track of new, changed, moved, and deleted files. When it’s time for a backup or a restore, Retrospect gets the file listing from Instant Scan, instead of needing to scan each volume, as it did in previous versions. For a volume with a million files, this can easily save 10 minutes per backup.



Exactly how much faster are backups with Instant Scan?


A: Run a backup with Retrospect 9 or with Instant Scan deactivated and watch how long it takes Retrospect to scan a volume at the beginning of the backup. When it changes from Scanning to Matching, the scan is complete. That’s how much time Instant Scan will save for every backup and for restores to the original destination.



Only the scanning time will be faster. The copy time should be about the same from the prior version.

Link to comment
Share on other sites

From the RetroISA FAQ:


: If I change a file on my disk and immediately run a backup or trigger a Backup on Demand, will that file be included in my backup?



: It is possible that a newly saved file will not be included in a backup that runs within 30 minutes of a file change. If you were to copy a large number of files to a volume, that will result in a longer amount of time to scan and update the RetroISA scan files. The RetroISA process must have time to scan and update the Scan File before a backup for those file changes to be seen when the backup starts. A scan file may be updated in as little as 5 minutes after a file has changed, but on larger volumes it could take longer to update the scan files.


You may also see error -1101 (File/Folder not found) if a file was deleted from your disk between the last time a scan file was updated and when you have attempted a backup of a disk.

This seems like a potentially major problem. In the vast majority of cases, I perform a backup shortly after I've finished several hours of work, certainly less than 30 minutes later. According to this Q&A, there's no guarantee that the last 30 minutes of work will be backed up. For me, that includes the last 30 minutes of medical records that absolutely must always be backed up. Also, this doesn't seem like a good solution for backing up the active boot volume, where files are frequently changing. I can imagine dozens if not hundreds of files not being backed up if the backup window is 30 minutes.


Despite these limitations, I said to myself, "no sweat--I can still upgrade to Retrospect 10 if I disable the RetroISA function." The extra time to scan a volume is worth the guarantee of backing up every file.


Reading more about RetroISA, in order to disable the process, the user has to edit the retro_isa.ini file. What? You mean there's no preference in Retrospect 10's user interface to turn off RetroISA or exclude certain volumes? And if you're not comfortable mucking about in the retro_isa.ini file, you risk not backing up 30 minutes of work? This can't be good...


So far, Retrospect 10's landmark feature, RetroISA, seems more of a liability than an asset.

Link to comment
Share on other sites

not sure whether this is normal. i installed the new v10 client on my macbook pro. it is running steadily at 200% cpu utilization. it's been a bit over 4hrs since i installed. it has used 8hrs 37mins of cpu time. still going.


this is a "normal" (to me, at least) laptop system with about 285GB of "normal" stuff on it. photos, music, apps, documents, etc.


is it normal/expected for it to take this long (both wall-clock time and cumulative cpu time)?


the two files in /Library/Application Support/Retrospect/RetroISAScans are both very small. the process memory footprint is also small. so i don't understand what it's doing.



$ ls -lh /Library/Application\ Support/Retrospect/RetroISAScans

total 16

-rwxr-xr-x 1 root admin 3.6K Nov 7 17:29 RetroISAScan-C49787A2-75B7-394B-A388-D4C5C9C96083.dat

-rwxr-xr-x 1 root admin 256B Nov 7 17:29 RetroISAScan-C49787A2-75B7-394B-A388-D4C5C9C96083.inf

Link to comment
Share on other sites

Sounds like the scan is taking too long for you. I would stop the RetroISA process and delete the scan files as described in the Advanced RetroISA document linked above and then start the RetroISA process again. New scan files will get created. That will hopefully fix whatever is getting the process "stuck" for such a long time.

Link to comment
Share on other sites

the process ran another 4+ hours and was still going at 200% cpu utilization. i killed it. looked in /Library/Application Support/Retrospect/ and RetroISAScans dir was no longer there, so i guess it went away when i killed the process.


now the process is running again, but is using almost no CPU. the RetroISAScans dir has come back. files in it are small.


so i'm not sure what this means... the scanner is no longer using a lot of CPU. otoh, it doesn't seem to have scanned my machine, either. for the record, this machine is running 10.7.5.


i just looked at another machine on my local network (the machine running retrospect server) and i see that the RetroISA process is still running there also. it is competing for CPU with other processes (including RetroEngine). it has 5:20:00 of cumulative cpu time. this machine is running mac os x 10.6.8 server. it has some other drives attached - does RetroISA scan those drives as well? looking in /Library/.../RetroISAScans on that machine, i see a set of pairs of files (.dat, .inf) with different names, so i'm going to assume that those correspond to the various drives attached to my server and that the large runtime is warranted in this case.

Link to comment
Share on other sites

another followup regarding the 10.7 machine.


searching logs for "retroisa", i was seeing pairs of log lines like the following:


11/8/12 4:05:18.414 AM com.retrospect.retroisa: #3> ~TMonitor::Enter: couldn't lock pthread_mutex: 60, result 22

11/8/12 4:05:18.414 AM com.retrospect.retroisa: Assertion failure at "tmonitor_unix.cpp-95", on threadID 0x106607000


i restarted this machine and things seem possibly more healthy now. no more of the above log lines have appeared. RetroISA process is using some CPU, but it's only been a few minutes... so far, there is one (small) pair of files in /Library/.../RetroISAScans. so i'm hoping things are back to normal.


another followup on the 10.6.8 (server) machine that i mentioned that also has a RetroISA process eating a lot of cpu... it appears from the logs that the initial scans of the attached volumes within about 15 minutes after installation of the new version of retrospect. however, there seems to be a lot of work being done on periodic updates for all the attached volumes.

Link to comment
Share on other sites



Installed Retrospect 10, Yesterday too... same issue here my CPU usage is above 250%, over heating my MacPro 3,1 under 10.8.2 (16 Go, RAM) while I'm not using Retrospect at all! Is it possible to deactivate this RetroISA process ?






OK sorry, i've just check the message from Mayoff above. I will try to disable ISA to see if CPU usage return to normal:


Edited by sbgraphic
Link to comment
Share on other sites

An FAQ on the new process is found at:



Advanced RetroISA options are at:



in the above article, it does not mention how volume names with spaces should be handled. in fact, the article side-steps the issue by using an example volume name of "MacintoshHD", whereas a standard default root volume on macs is "Macintosh HD".


so in this case, would you say:


ExcludedVolumeName0=/Volumes/Macintosh HD/


ExcludedVolumeName0=/Volumes/Macintosh\ HD/


or something else?



UPDATE: sorry - i could have just tested this before posting - the correct answer is: spaces in the volume name seem to work fine w/o any form of special quoting or escaping needed.

Link to comment
Share on other sites



Sorry but "Disable Volume Scanning" as mentioned in the FAQ above does not work well.

As soon as the file was edited and replaced, Retrospect change it back to it's default value (=1) after relaunch.... Any idea ? (OSX 10.8.2)


about specific volumes from being scanned is it the same .ini file to edit ?





I've tried to edit the "com.retrospect.retroisa.plist" and set the "RunAtLoad" and "KeepAlive" values to "NO" (instead of YES") and Disabled value to "YES".


Is it secure to do so?

Anyway after testing to edit the .plist file it does not change anything...

Link to comment
Share on other sites

Before you try to edit the .ini file, you probably will need to change the file permissions. The file will not correctly "save" otherwise.



1) Locate the retro_ISA.ini file

2) Get Info on the retro_ISA.ini file.

3) Unlock the file using the lock button

4) Change the file permissions to "Read & Write" for Admin, Everyone and your logged in user account.

5) Double click the file and make any needed edits

6) Save your changes

Without making that change, the default action under 10.8 (as an example) is to make a copy of the file with a new name because the original file is locked.

Link to comment
Share on other sites

Okay I previously used a "root" permission on that file before/after editing (chown).


However I did what you mentioned above, but it does not work either.


As soon as I launch the command again (after saving the changes) the value reset itself instantaneously from "=0" to "=1".

Any idea why ? Would be great to be able to disable it through the UI...

Link to comment
Share on other sites

I had the same problem as "sbgraphic". I'd follow Retropect's article on how to disable the RetroISA process but everytime something would reset the the "0" back to "1" in the RetroISA.ini file. I think Retrospect support forgot to include the "-w" option/switch in their article. Here's the command with the -w option/switch:


sudo launchctl unload -w /Library/LaunchDaemons/com.retrospect.retroisa.plist


Note: The key is ithe "-w" option/switch in the launchctl command.


Here's how I finally got the Retrospect RetroISA process (daemon) to stop running on my iMac:


Changed the permissions on the RetroISA.ini file to allow "admin" read & write.


Modified that RetroISA.ini file:

Changed StartRetroISA=1 to StartRetroISA=0

[Note: Disabled all volume scanning]


Started Terminal.app to enter these UNIX commands as follows:

sudo launchctl unload -w /Library/LaunchDaemons/com.retrospect.retroisa.plist

[Note: According to my Google search, the "-w" option permanently keeps daemon from running (so RetroISA should no longer start-up again on re-boots of iMac)]

[Note: The -w option used to actually change the *.plist file but now (under MAC OS X 10.?) it does NOT change the DISABLED key in the plist file but rather stores the DISABLED=TRUE status elsewhere on disk]

  • Like 2
Link to comment
Share on other sites

how long is RetroISA going to continue eating up 10% of my 8 cores


OSX 10.8.2, multiple boot volumes, 500 GB + of stuff.


i normally run from a standard account. i installed from an admin account, watied over an hour for the initial scan to complete. then i logged into the standard account and the whole scan seemed to repeat again.


the scan repeated when i restarted. it also seemed to scan my time machine backup disk and the backup disk.


i was seeing repeated slowdowns while in normal use.


i disabled the scan process by doing the unload mentioned in the "advanced options" and removing the plist from the LaunchDaemons folder.

Link to comment
Share on other sites


Note: The key is ithe "-w" option/switch in the launchctl command.



:) Thanks to "SmokeAndMirrors"


Apparently it is :-). Now the process has stopped running, i'll try and reboot later.

As I've seen now the content of the "Instant Scan Advanced Options" page indicated above has changed.


But one more question should I restart the "com.retrospect.retroisa.plist" file again? But in that case as the process is disable, nothing will run... correct? Because I tried to restart it (without option -w) and Terminal indicated "nothing found to load", which seems logic to me. Correct?




Link to comment
Share on other sites

I second that: Thanks to SmokeAndMirrors. :)


The procedure to edit the retro_isa.ini file and use launchctl command to unload the process (with the -w modifier) worked. After a restart, the "=0" stuck. Without using launchctl, the "=0" switched back to "=1" after a restart.


Now my CPU history in Activity Monitor is nice, low, and even (when I'm not doing something).

Link to comment
Share on other sites

Retrospect 10 seems remarkably slower than 9

My "performance" statistics dropped from 500 to 1,000 MB/min with R9 to 20 to 100 MB/min

Nothing else changed in my configuration: same scripts, same rules, same sources, same server, same NAS for media sets, same network

Is anyone else seeing this?

The first few pages of my activities log is attached 11/6 is when I installed 10


Thanks in advance for any advice


Link to comment
Share on other sites

Folks..great thread! I'd be grateful anyone could read the following thread - http://forums.retrospect.com/index.php?/topic/150002-disable-scanning-in-retro-isaini-retrospect-10/ - bottom up as I have found that despite a proper edit the .ini file (after a reboot) reverts to the default (and the subsequent high CPU% and temps).


Much advised for any advice.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...