Jump to content

Media Set password corrupted


rtech
 Share

Recommended Posts

I checked Retrospect yesterday and a script had been running that has crashed about a week or so ago and was still trying to complete. ( I had been away hence the delay in discovery!)

I was unable to stop the script from running, so restarted the server but this didn't help matters. I was also unable to stop the Retrospect Engine. I managed to force quit the Engine and restarted it, then found that the backup script had now stopped.

All well and good - except that the Media Set won't unlock with the password that has always unlocked them - so I am unable to backup or retrieve anything!!

The scheduled script ran as per usual but was unable to backup (Error -1101 (file/directory cannot be found)) - am summing this is because the Media Set is locked?

Any solutions. I know 100% that the password I am entering is correct, so something has corrupted somewhere...

Link to comment
Share on other sites

I was unable to stop the script from running, so restarted the server but this didn't help matters. I was also unable to stop the Retrospect Engine. I managed to force quit the Engine and restarted it, then found that the backup script had now stopped.

I don't understand this. Rebooting the server would definitely stop the engine and therefore the backup script. Do you mean that, upon restarting, the engine also restarted and resumed the backup script?

 

When you issue any command from the console, it always takes a bit of time before the engine responds and communicates the new status back to the console. In the case of stopping a script, that can take a few minutes. In the case of stopping the engine, it can take many minutes for the engine to complete its tasks and shut down. It's best to be patient whenever possible.

 

I know 100% that the password I am entering is correct, so something has corrupted somewhere...

Absolutely sure on that? I think a lot of us have been pretty convinced sometimes we were correct when we were really entering the previous password.

 

All well and good - except that the Media Set won't unlock with the password that has always unlocked them - so I am unable to backup or retrieve anything!!

If that's really the case, either the media set catalog or the configuration file has likely gotten corrupted.

 

First thing I'd try is forgetting and re-adding the problematic media set. In the media set window, highlight the media set and click "Remove;" then click "Locate" and attempt to re-add the set.

 

If that doesn't work, the next easiest thing is to test the configuration file. Quit the Retrospect console, stop the engine, and drag the files Config80.dat and Config80.bak from /Library/Application_Support/Retrospect to the desktop or somewhere else safe (so you can drag them back in the event they are OK). Restart the engine and relaunch the console. You'll need to re-enter your license code, after which you'll have a bare, clean configuration. Try locating the media set again.

 

If that also fails, you'll need to rebuild the catalog from the media.

 

If you still can't get in, it means that you really did forget the correct password.

Link to comment
Share on other sites

Many thanks Tim, you have saved me a LOT of time and effort

 

I tried your first suggestion of removing and re-locating the media sets. I did this, then re-entered my password: lo-and-behold both media sets reappeared!! (I KNEW my password was right!). One media set took a LOT longer to reappear- this was the one being used when the backup crashed.

 

I have run test backups with both media sets and all is operating correctly

 

Thanks again!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...