Jump to content

Upgrade and drive handling


tchannon
 Share

Recommended Posts

I'm a long time user on MS machines including in the past on servers. Personally I use Professional on a local workgroup, have done for many years, currently on 6.5

 

Back then Dantz tended to be a "difficult" company with no reasonable support, followed by in essence failure and a long saga as you know. My reading was interest kind of moved to Apple, dead product but what I had was workable. Alternatives still don't exist, at least at a sane price. (moment you mention network, the $$$ jump)

 

Very recently the last workable backup drive here failed, not a surprise. It is not possible to just go and buy a new drive because only some work with R,, I have a new SATA drive, no dice.

 

I was already aware some kind of vendor movement was taking place with Retrospect, if appearing highly unstable.

 

The ongoing problem is NT passthrough as access to optical drives, a known unreliable facility generally but many products manage this without trouble, nor is there any actual problem here for other software. Retrospect is extremely sniffy about APSI so I have been through hell many times, having to resort to things like the Frog driver, currently the Nero driver.

 

It's a black mark against Retrospect that it uses special disk formats instead of a standard filing system. This gets into the ridiculous such as drive testing to see if it works. Even if this passes it is no guarantee it actually works. (current situation here, complains it doesn't recognise a disk as valid, says unknown but after passing tests)

 

Version 7.x now exists. The drive compatibility list is still a joke. Nothing is said about what might work or has changed, no change from the old days.

 

I am using XP and DVD for backup.

 

Any suggestions on whether 7.x might be fixed?

 

Coda: I've had quite a few hard disks go down over the years and also server hardware failures. Recovery has worked fine. As a system I know it works for real. Lots of things could be better.

 

Tim

Link to comment
Share on other sites

  • 2 weeks later...

You could try installing the trial version of the current release (7.7). That was helpful to somebody else in a similar situation a while back:

http://forums.retrospect.com/index.php?/topic/147262-qualified-dvd-drive-not-recognised/

 

You may wish to write down your v6.5 licence code and backup your preferences/catalogs, in case you need to re-install it later.

 

I have had no problems in v7.7 with three different optical drives (one qualified, the other two 'configured' using the drive testing), but I primarily use hard drives, so my experience with DVD-based backups is somewhat limited.

Link to comment
Share on other sites

That was painful. Good news is it probably works.

 

For the record.

 

Two XP Pro boxes on a wired LAN workgroup.

Initially Retrospect Professional 6.5

Backup to DVD +RW via NT Passthrough. Couple of drives died over time, last one was external on USB2

New SATA drive where 6.5 autoconfigures the drive but it doesn't actually work. Drive reports as TSSTcorp CDDVDW SH-S223L firmware S03

 

Filled in the form and downloaded R7.7 (100M +). Email arrived giving trial software key.

 

Dealing here with the master XP box which will carry the full Restrospect, the other box is a network client.

Uninstalled R6.5, seemed to work but I looked anyway, service still running. Reboot. Service still running, no uninstall item. Check old program directory, empty except for preserved user content (good behaviour). Exe and dll are missing so service isn't actually usable. Run registry cleaner, finds nothing.

Start regedit and search on dantz

Delete dozens of keys. Double check, none left. Reboot, service has gone. Run registry cleaner, finds nothing.

I know there are some configuration directories deep in the file system, decide to leave them, assuming 7.7 won't find them.

 

Install 7.7, no problem but says it is upgrading, ouch, has found something, give it the emailed key, is happy.

 

Reboot, paranoid is'us

 

Bad stuff omitted. (I was scratching trying to figure things out)

 

Go into devices, select the DVD and delete the autoconfig... however this is where R, is dreadfully done, nothing tells you whether a configre exists or properly what it is doing, including messages vanishing off the end of text boxes.

Drive is not recognised but doesn't tell you. Therefore run autoconfigure. Changed behaviour from R5 or R6, read the prompts. Odd.

 

That is what ought to happen. I went through waiting for ages, nothing doing. Some were not crashes, but I've has exceptions from CPP and as far as needing to forcibly close R. This was all about the DVD and getting configure to work. It suddenly behaved. (several reboots for sanity sake, wise after crashes)

Is this computer stable, yes. Fully patched etc.

 

Since then it has behaved.

 

Tried a small test backup with full DVD verify. (note, to do the master no client is installed)

Restored the backup to a different location.

All okay.

 

Boot the other (client) XP box (via wakeup).

Wait.

Add client, it finds the client, select, it asks for a password (Restrospect 6.5 client password), give it. And we have details, all fine.

Hit upgrade client (this was you-must-be-kidding), few seconds reports okay. Didn't reboot the client. (I'm not usually into lots of reboots)

 

Create a new client DVD dataset. Create a backup script as normal for that client. Advanced turn on backup security settings etc.

 

Trip an immediate backup on the schedule client script. Asks for disks, formats, and does it in three. Speed is fairly normal (and much worse than with a USB drive), how it is.

It goes into verify and asks for the disks again.

Zero errors. Reports mentions rather poor compression 19% but much the same as 6.5, just how it is.

 

That's it.

I've now created additional backup sets and added these to the client script, scheduled as a rotation.

And also for the master XP box, which has yet to be run... which will take many more disks.

 

Did 7.7 read 6.5 DVD? Not sure. It did read disk labels but said the disks are unknown. This is worrying for anyone needing to restore an old system. It is possible I had some bad disks, so that this as uncertain.

 

Might help someone. Any questions?

Link to comment
Share on other sites

Thanks for sharing your experience in detail. Glad to hear you have it working.

 

It's a shame you can't read your v6.5 discs, though. :( There are some v6.5 tape sets at my workplace... if I get a chance to try them with v7.7, I will post the outcome here. (I know that the catalogs open fine in v7.7, but I haven't yet needed to restore any files from them.)

Link to comment
Share on other sites

  • 1 month later...

News.

After a lot of pain 7.7 has settled down, completing several successful backups on the complete network here and showing a restore is feasible via a trial. (my existing experience tells me there is no need to actually do the whole exercise)

 

This was done on a trial licence, which didn't complain about expire soon (good).

 

I've now paid. three emails were received (instant), invoice/receipt and new licence code the critical ones. Licence updated without problem. (unlike the old days when it could take months to get a take)

 

The UI is still poor and illogical/indirect speaking. How it is.

 

Defects? Found several which I ought to have recorded but there is so much needs a rewrite seems pointless.

One I recall is discovering it doesn't handle it's own configuration correctly, so on changes to drive config, exit and rerun, then it picks it up.

 

Get it setup and it works.

 

DVD handling is okay but I did need to force in a non-Microsoft ASPI driver, a known problem, nothing to do with Restrospect. Bit of a story. If anyone with XP suspects this is an issue the simplest current recommendation is install **only from the official site** the now free usage read only InCD package from Nero who bought the rights from Adaptec ages ago. The critical point is this installs a good commercial ASPI driver. (Frog driver works but few will trust an unknown third party)

If this embarrasses the new owners of Retrospect, simple answer.

 

Critical file in system32 is wnaspi32.dll, Nero version 2.01 dated 2006

 

I notice eject media after backup (config item) now seems to work reliably, used to very erratic.

 

New media verify function is a great improvement (checks against checksums after end of writing)

 

Update client over the network works fine. (always did for me anyway)

Client works fine. I use separate workstation wake on lan and shutdown to hibernate as needed here. (best software for this is the wonderful tools from sysinternals, so good MS bought the company ... note: this will NOT work with Home versions of the OS)

http://technet.micro...ernals/bb897553 (microsoft site)

 

There seems to be a speed problem, backs up somewhat slower than V6.5 but doesn't seem to be caused by bloat. Can't keep the DVD write satisfied. Suspect this is about drive handling/buffering. (existing observation, an external drive tends to run faster)

 

Been able to trip exceptions, if under fault conditions.

 

It works which is what matters.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...