Jump to content

"recycle" button grey'd out on disk sets? Why?

Recommended Posts

OK, I give up.


When I select a media set, the "recycle" button is made available to me in the "media sets" panel.


I have 3 "disk" sets, and when I select them, the "recycle" is greyed out.




I have checked permissions, and that does not seem to be the problem.


There is nothing unusual about these sets, except that both the catalog and the member data is on Firewire disk. The single "disk" set I had where the catalog file was on the "main" hard disk

(in /Library/Application support/Retrospect) THAT one, I could recycle.


Why is this button unavailable?

Link to comment
Share on other sites

Yes, they are on the same volume. Is that bad?

In earlier versions of Retrospect, a disk backup set's data member needed to take over the entire disk volume (so no room for the catalog). Although this arrangement is no longer required, I suspect that Retrospect still wants the catalog to reside on a different volume from the data. This would be easy to check: just copy the catalog to a different volume, delete from the data volume, and point Retrospect to the new location of the catalog.

Link to comment
Share on other sites

Even though a Recycle of a Disk Media Set's Member erases only the Retrospect folder, it's likely the option isn't available to negate the chance of erasing the Catalog file during that process. Perhaps the logic could have been tighter, but better safe then sorry.

If you _need_ to have a Media Set with the Catalog and the Data residing on the same logical volume, use a File Media Set; that's what it's designed for.




Link to comment
Share on other sites

If there is a requirement or preference for the catalog and the disk "member" to be on different volumes, that should be documented.


Unfortunately, I ran an experiment that says the "same volume" theory is wrong.


I created a disk backup set "atrash", with the catalog on one disk, and the data member(s) on another. I then backed up something small to it.


Backup worked fine. "recycle" button available.


I copied the catalog to the same disk as the data member(s). I then did a "locate" and "verify" to ensure that Retro had accepted the change.


The "verify" failed. (?!)


+  Executing Verify at 5/11/12 (Activity Thread 2)
   To Backup Set atrash...
   !Can't save Backup Set atrash, error -1103 ( write protected)
   5/11/12 7:36:36 PM: 1 execution errors
   Completed: 263 files, 39.8 MB
   Performance: 2,388.7 MB/minute
   Duration: 00:00:02


I checked on the catalog file, and it was read-only. I changed it to read/write, and did the "verify" again. Works now.


(side question: why does retro insist on having write access to the catalog for a *verify* operation??? It looks like it actually did finish, but the red X says it didn't.)


When done, checked the "recycle" button. Available. I pressed it. No more files in "atrash".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...