Jump to content

No way to move "disk" media sets

Don Lee

Recommended Posts

I have noticed that the "disk" media sets have the full path of the members embedded somewhere, and if the data is moved, it is no longer accessible to retro 9.0.1.


I did some experiments this morning with a small disk media set, backing up some data to it, then

moving it, removing it from the media set list, and doing a "locate".


Retro can find the catalog, and seems happy, until I try to restore from the media set. When I do, Retro wants its "member".


I have tried all the combinations I can think of to sweet talk Retro into finding the slightly moved

members, and I have been unable to get it to work. It appears that once any portion of the path to the data member has changed, Retro is unable to access it.


Either some way should be provided to "find" these members, or Retro should warn you not to move them.

Link to comment
Share on other sites

This is also the case with the individual files on each disk member. If you perform a groom operation on a disk media set that frees up space on member #1, you cannot move files from member #2 to this new free space on member #1; Retrospect will simply ignore the moved files.


This restriction is most certainly one of the ways that Retrospect ensures integrity of its backup data. Aside from the fact it's not clearly spelled out in the user documents, they would probably not consider this a bug.


If you need to be able to move a media set, you should use a file media set. Unfortunately, contrary to what the User's Guide says, these are limited to 1TB in size for the data portion.

Link to comment
Share on other sites

I'm less interested in manipulating the internals of the set than I am in dealing with the case where the full path to the media set member(s) moves for reasons not related to my direct action - like renaming a directory containing the disk set. This is more likely to happen by accident, and it effectiively completely erases your backup data, unless you can change the name back.

  • Like 1
Link to comment
Share on other sites

I want to emphasize that this inability to use a backup set if it has moved is sometimes both unexpected and ugly. Consider this case:


I have my backup storage on external firewire disks. I want to move that storage to a replacement machine, or to a different machine. It is not obvious that the "disk" sets will be completely useless in the new environment unless I can ensure that the full path to the disk is identical to what it was on the old machine.


For me, this is the case - I want to move storage from one machine to another. The current machine is running Retro 6. The new machine is running Retro 9. I have mounted the disk via AFP to do some conversions of retro 6 sets to retro 9, but I have to ensure that I do not set up any disk sets, because if I do, when I move the disk to the new machine, the sets may be useless.

Link to comment
Share on other sites

  • 4 weeks later...

Can you clarify exactly what has this 1TB limit?

A file media set has two parts: a data file and a catalog file. For this type of media set, both the catalog and the data file need to reside in the same directory/folder.


In Retrospect 6.1 and earlier, the data portion was limited to 1 TB; in other words, the total amount of data stored in the backup set (earlier terminology) could not exceed 1 TB after any software compression was applied.


According to the User's Guide, Retro 8/9 file media sets should be able to expand to use whatever capacity is available on the hard drive volume. However, people who have tried this find that Retrospect throws up an error message, "Can't add that much data to the backup set. The limit is 1 TB." That message is clearly a holdover from Retro 6.1, as it uses the old terminology ("backup set") instead of the newer "media set." It may be that this message is spurious, rather than that the capacity is really limited. Either way, there's a bug (in either the software or the documentation), and the net result is the same: Retrospect 8/9 won't let you exceed 1 TB of data in a file media set.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...