Jump to content

RetroEngine using 100% CPU while idling


otolithe
 Share

Recommended Posts

Once in a while, the RetroEngine process will start using a *lot* of CPU, up to 100% of the two cores, while the console shows absolutely no activity from the server. If I try to stop/restart the engine through the Retrospect Preference Pane, it does nothing and the engine keeps running. Looking at the OS X console, I can see the following error message:

08/02/12 18:02:08,547 sudo: root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/launchctl unload /Library/LaunchDaemons/com.retrospect.retroengine.plist

08/02/12 18:02:08,598 [0x0-0x144144].com.apple.systempreferences: launchctl: Error unloading: com.retrospect.retroengine

The only way to stop the RetroEngine process is to effectively force quit it through Terminal or the Activity Monitor. If I then relaunch the RetroEngine using the Preference Pane, it starts immediately using all the available CPU again.

The only way to go back to normal is to reboot the machine.

 

My configuration:

MacBook 2,1 Core2Duo 2GHz, 3Gb RAM

Mac OSX 10.7.3

Retrospect 9.00 (319)

Backups of the two clients are done over gigabit ethernet using Proactive Backups

 

This is a real problem since it requires me to manually reboot the backup server more or less every 2-3 days.

  • Like 1
Link to comment
Share on other sites

Backups of the two clients are done over gigabit ethernet using Proactive Backups

 

I experienced and still experience a similar problem (as described here: http://forums.retros...n-idle-on-lion/). I had an issue, where idle CPU load was constantly high, which I was able to fix as described in my post. What I still see, is that every time that Retrospect waits for a Proactive Backup Client to be backed up, the CPU load of RetroEngine explodes, and stays high, until I either stop the engine (which usually doesn't work) or until I force-quit it. I guess it must be an issue with Prospective Backup (Clients), as you have the same problem... But I haven't figured out a work around yet.

 

The only thing I figured out was, that the problem appears, when a Proactive Backup Script starts / expects a client to be backed up. Retrospect tells me that the client or the "source is in use". Even when the client is connected to the network, the CPU load stays high, and backup does not start. The only way to correct this situation is to force quit RetroEngine (as quitting through the SystemPref usually does not work). After force-quitting RetroEngine and starting RetroEngine again, backups usually start, and CPU load is normal --- until the next Proactive Backup.

Link to comment
Share on other sites

I've experienced a similar issue, that I think I've tracked down to a single bad client. I have a support incident open on this. The problem was this one client (with nothing to distinguish it from all my other client machines) was causing complete failure of a proactive script with the engine at 100% and the client "busy", but no backups occurring. Client has had RS reinstalled to no avail. Removing this single client from Sources and everything went back to normal. The odd thing was this client could be backed up manually and also in a regular script. I'm currently checking whether returning it to a proactive script works or fails.

Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...

This Retro ist driving me insane! I recently updated to 10.7.4 and now I have the same issue. With R8, but as I read, this has not changed in R9 :-( And no, I don’t have FileVault in use, I have one old client and three local proactive sctipts. The shares have all been killed, it’s not possible to use them with RS and Lion. But still … CPU load until kill, afterwards everything works fine, on- and off-switchable. An NOWHERE, no-one can tell one nothing. What to do? Who will save us RS-victims?!

Link to comment
Share on other sites

I still have the same issue occasionally with Proactive Backups - it seems to happen less often with the latest version on Retro. Still, I was not able to find a solution or a workaround.

I first thought, that Parallels / VirtualPC running on a client caused the issue - since I noticed, that the RetroClient was listening not only on the the main network interface (Wifi or Ethernet) but also on the virtual network interfaces offered by VirtualPC / Parallels.

The problem also appeared, what I connected with a client to the home network via a VPN connection (the machine running RetroEngine is also running a VPN server) when the proactive backup was due.

Hope it gets fixed for good soon...

Link to comment
Share on other sites

  • 9 months later...

Howdy.  I add that our Retrospect program, the latest version of 10 (10.1.0 (221)) on a Mac mini, also frequently goes to Retro Engine at 100% CPU when everything appears to be idle.  When that occurs, the program fails to perform proactive backups on schedule, listing clients as busy.  Interestingly, it still appears to perform Copy from and to its attached external hard drive.  Quitting Retrospect, shutting down the engine using preferences or restarting the machine usually is a good temporary fix.  Occasionally a force quit is required.  Other bugs include delayed proactive backup until the program is opened.  Since the client backup is fine once Retrospect is reset, I think the problem lies in the program not the client.

Link to comment
Share on other sites

  • 4 months later...

Howdy again.  Currently using version 10.5.0 (145).  Server is a Mac mini Late 2012, client is a MacBook Pro Mid 2010, both running MacOS X 10.5.8 (12F45). Instant Scan is disabled on both the server and the client.  

RetroEngine high CPU usage problem persists, first reported June 2013.  CPU usage goes up to 100% within one day.  Will not perform backup when stuck at 100%.  RetroEngine shutdown and restart using Preference panel works fine and RetroEngine will behave (1-5% CPU) for several hours.  Client is successfully, automatically  backed up during this grace period.  Can anyone help on how to get RetroEngine to behave without daily restarts?

Link to comment
Share on other sites

Same problem here.  2010 Mac Pro w/10.8.5 running Retrospect 10.5.0 (145).  Proactive client is a Mac Book Pro also running 10.8.5 with the 10.5 Retrospect client.  The RetroEngine process stays stuck at 100% even with no activity.  Trying to stop the server through the system preferences fails (simply does nothing).  The only way to stop the RetroEngine is to do a force quit in Activity Monitor.  After restarting the engine will behave normally for a while and even perform proactive backups.  In less than a day the RetroEngine will get stuck at 100% again.  Note that even when it's in this mode, normal (non-proactive) backups continue to run.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...