Jump to content

Backup client reserved: Error -505

Recommended Posts

I had this problem for the past week and figured out what the problem was so thought I'd put it out there. The problem (kind of) wasn't Retrospect in this case.


The Retrospect server (Mac, Retrospect 8.2) kept dying backing up a particular script on one of our file servers (CentOS 5.6). A reboot fixed this for a day but then the problem reoccurred and frequent reboots of the file server are impractical.


The symptom:

I narrowed the problem down to one script which backed up the root partition. Whenever this ran, Retrospect hung on the script and after stopping it, all other jobs on the server failed.


The cause:

I logged into the server to try to figure out the problem and ran "ls /" which worked as usual. I then ran "ls -l /" which hung indefinitely. I ran "strace ls -l /" which told me that the hang was happening when accessing a directory mounted off the root which is a hard nfs mount to an external drive. This is the problem with hard nfs mounts - they can hang indefinitely when they fail. Once I fixed the mounting issue, everything was gravy.


So this wasn't entirely Retrospect's fault. However, once I stopped the hanging script, the server should have released the client connection (I ran "rcl status" and the connection was not being released).


Hopefully this helps someone else keep their hair! :D

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...