Jump to content

Retrospect 9 abruptly ends copy without error message


Recommended Posts

I downloaded and evaluation copy of Retrospect 9(9.00 319) to see if it is as stable as 6.1retrospect for Mac was. I am running 10.72 (Lion) on a Mac Pro server with 16 gig of ram. I keep having a weird problem when trying to copy data from one hard drive to another. Retrospect copies the files but then quits suddenly somewhere in the middle of copying with a flash on the screen and nothing else. When I look at the log it as if the job never happened. No record of the copy.

 

The second symptom is that when I try to reset up the job, the source is no longer visible and I have to stop the engine or quit retrospect to get the list of sources to rebuild.

 

I have done this several different times, and with large and small amounts of data but the results are the same. Retrospect quits copying unexpectantly and erases any record of the process.

 

Has anyone else experience this and is there a solution? Also does this type of behavior also happen when backing up to tape? I need my backup software to be dependable and I have my doubts about Retrospect 9.

 

 

From the console log:

1/18/12 2:46:37.642 PM com.retrospect.retroengine: Assertion failure at "elem.cpp-2591", on threadID 0x108101000

1/18/12 2:46:37.672 PM com.apple.launchd: (com.retrospect.retroengine[50180]) Exited with code: 255

1/18/12 2:46:37.703 PM Retrospect: Server::expirationDate exception: MacRequestor::Request: connection closed by remote endpoint

1/18/12 2:46:37.779 PM Retrospect: Server::expirationDate exception: MacRequestor::Request: connection already closed

 

 

Mike

Link to comment
Share on other sites

I am running 10.72 (Lion) on a Mac Pro server with 16 gig of ram.

 

 

More specific information about your software configuration and hardware setup would probably be helpful, and certainly couldn't hurt to provide.

 

"one hard drive to another" would be what, exactly?

 

What does "list of sources to rebuild" mean? Rebuild what? Rebuild how? What types of Sources?

Link to comment
Share on other sites

  • 1 month later...

This may not be your problem but... I have had similar problems several times over the last few years with both RS 8 and 9 due to bad disk or disk controller. My latest instance was due to a bad disk controller card in the external HD case. Retrospect logs are useless to troubleshoot as there is no or unhelpful information.

 

In the latest instance, I was able to confirm I had a bad disk controller in the external HD case by using SuperDuper to clone from one large disk to the suspect disk. SuperDuper copy would also fail after 10 to 40 minutes of copying. Replacing the disk in the case did not fix. But the nice thing about SuperDuper is the logs indicated what was happening. Don't remember the exact error, but the gist of it is file system reference ID for the mount stopped working and the MacOS created a new reference ID. From the finder, nothing appears to change and the failed disk continues to work under normal usage.

 

IMHO, Retrospect handles this type of failure poorly in general, failing to recognize the mount has disappeared or changed ID and gracefully exit with log entry that would tell us what happened. I would be happy to give the faulty disk case/controller to Retrospect if they were interested in improving the robustness of failure handling for this type of problem.

 

-> Kent

Link to comment
Share on other sites

Well, what is happening is that Retrospect is unexpectedly quitting for some reason and, because of that, isn't saving your changes to the configuration file, so it reads from the backup configuration file -- which probably didn't have your source added to it.

 

My suggestion would be to try to figure out what file the copy process is barfing on to see what the underlying issue is. Maybe break down the source hard disk into a series of Favorite Folders until you can figure out what file/folder causes the Retrospect Engine to "exit" and then work from there? (It might be something you need to open a support case for if -- for example -- you can do a Finder copy of the same files without issue). *Or* it might be an actual problem with a folder/file on the disk that Retrospect can't handle.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...