Jump to content

Update Error Using R9 And Lion


Guest Cavett

Recommended Posts

I have installed Retrospect 9 on my Macbook Pro running Lion. I have licenses and I have Registered. I am able to backup and restore.

 

When I try to "Check for Retrospect Updates", I get an error message: "Update Error! An error occurred in retrieving update information. Please try again later" My only choice is "Cancel Update".

 

Any help will be appreciated.

Edited by Cavett
Link to comment
Share on other sites

Thanks, Steve. The problem occurs many days in a row.

 

I have registered my Retrospect 9 many times, but on this Web Site, it does not show that it is registered (my other Roxio products are listed as registered.)

 

Could that be the problem. Do others show their Retrospect products registered on this (Roxio) Web Site?

 

Thank you.

Link to comment
Share on other sites

Problem solved! Miraculously, I tried it for the 37th time, and it worked: No updated available rather than previous error message.

 

PS I still m not listed a registering Retrospect 9, on this Web Site, but all my other Roxio software is listed?

 

Thanks for the help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...