Jump to content

Are You Getting Vss Error 8194 On W2K8?


Antti
 Share

Recommended Posts

Hi,

 

Are you getting VSS error 8194 on Windows Server 2008 (ours are R2)? We are (on all of them), and I know many others are, too. I have an open support case, but I'm having difficulties in getting my message through. The error (see below) is probably caused by MS or Retrospect. According to MS Technet article (link below) this is caused by the application. So, help me and yourself by answering to this thread. Thank you!

 

-----

Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005, Access is denied.

. This is often caused by incorrect security settings in either the writer or requestor process.

-----

 

Some information on MS Technet.

Link to comment
Share on other sites

link from social technet may help:

 

http://social.technet.microsoft.com/Forums/en/windowsserver2008r2general/thread/0f0d8f90-2108-4fa0-b60c-6487baf90445

 

Can you please run "vssadmin list writers" in command line to dump the output here?

 

Are there any error message shows as followed?

 

Writer name: 'Cluster Service Writer'

Writer Id: {41e12264-35d8-479b-8e5c-9b23d1dad37e}

Writer Instance Id: {0c1bc452-1296-430b-9fe7-de9c9fdac19c}

State: [1] Stable

Last error: Non-retryable error

 

 

If yes, it could be the 3rd party application is responsible for properly handling the security context of COM callbacks from VSS.

 

You may be able to workaround the problem by doing the following:

 

- Start | Run and type dcomcnfg and hit Enter key

- Expand Component Services

- Expand Computers | My Computer

- Right Click on My Computer and choose Properties

- Select COM Security

- Select Edit Default on Access Permission

- Add the Cluster Service Domain account with Local Access and Remote Access allowed

 

If this does not work then add in the following also:

 

- Start | Run and type dcomcnfg and hit Enter key

- Expand Component Services

- Expand Computers | My Computer | DCOM Config

- Select your Ultrabac client exe

- Right click and select Properties

- Click on Security tab

- Select Customize option for Access Permission and click Edit button

- Add the Cluster Service Domain Account to grant access

 

Could also be that the 32 bit requestors won't work with 64 bit VSS services.

Edited by MarkUK
Link to comment
Share on other sites

link from social technet may help:

 

I wasn't asking for tech help and you actually posted the same link I did. About the advice on the other link then: I would not change any permissions on servers unless the OS/software vendor says so. Roxio should mention these errors in the documentation. If workarounds are needed, they have to be documented. If nothing needs to be done, then Roxio tech support should tell me that these messages can be ignored. Whatever the case, if the product has been tested with the OS in question, these error messages should have been spotted and the problem fixed.

Link to comment
Share on other sites

just trying to help plus your technet link doesnt work for me

 

Thanks, sincerely, for trying. I don't think this can be solved by users, though. I was after getting some pressure from the community on Roxio, so they would fix this. I'm certain that most if not all are getting these errors on 2k8R2. On the old forum there were at least this and this on the subject.

 

I'm not too satisfied with the tech support, but I got an answer after two weeks of trying. They "are confident that there is no cause for concern". Ok, there is not much else I can do about it, but at least I have an answer and the support case to back this up.

Link to comment
Share on other sites

Yes, we get this on our servers as well. Not just 2k8, on 2k3 servers as well.

 

we still see these errors on windows 2008 and newer systems. It is only when using retrospect we get these, using MS build in backup tool do not log these entries, so hallo! Come retrospect - it is a issue with your software.

 

Robert

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...