Jump to content

Network drive error (-1017) when using valid network login info


awnews

Recommended Posts

I'm having a problem getting Retrospect (MS) to access a network drive (on a Linux box) as a save-to destination. This setup is on a XP laptop that is connected to a network domain but the laptop is *not* joined to the domain. The laptop is able to access (r/w) all the needed network drives (had to fill in a "corp/mydomname" and "password" the first time) from the Windows Explorer using both UNC path and a mapped network drive (P:\folder\file.txt) but Retro won't take the latter.

 

If I run Retro with "run as specified user" (using local login info), Retro fails (error -1017) when attempting to access the network drive even after I type in the valid corp\mydomname (or corp\mylocname or My_Laptop1\mylocname or ...) at the network login screen. If, on the otherhand, I set Retro to run as as the "logged-in user" -- which, btw, is *exactly* the same as the "run as specified user" info -- and restart, it has no trouble accessing the network drive (doesn't even put up a popup asking for for the network login info). The downside to the "logged-in user" it that it makes running unattended backups difficult/impossible.

 

So how do I get Retro to accesss the network drives even with "run as specified user" is choosen? As I pointed out, the specified user (name & password) is *exactly* the same as the name & password the machine is logged as now. Since I'm able to access the network drive manually, after filling in the corp\mydomname & <corp password>, it doesn't make sense that Retro isn't able to use this same & correct info to access the same drive. I'd try the mapped network drive path/method but Retro doesn't "see" that.

 

 

===================================================

Inital setup, using "run as specified user" option

 

Using Retrospect

+ Retrospect version 7.0.326

Launched at 8/24/2006 11:35 AM in user account My_Laptop1\mylocname

+ Retrospect Update, version 7.0.12.105

 

 

local Login to My_Laptop1:

mylocname

<password>

 

 

Retro Prefs Security

(*) Always run Retrospect as the specified user <== note, same as local login user name & pw

User: mylocname

Password: <password>

LogOnTo: My_Laptop1

 

-------

When trying to access the network drive as a \\UNC destination (\\ls1\hwsync\projects\MTV_Designs\PMM4F_backup), fails:

Server: ls1

Volume: hwsync

Connect as: corp\mydomname

Password: <corp password>

=> can't access server given username and password, error -1017 ****************

 

 

===================================================

Setup after changing Retro to run "as the logged-in user" option

 

+ Retrospect version 7.0.326

Launched at 8/24/2006 12:09 PM

+ Retrospect Update, version 7.0.12.105

(note no specified user account for login)

 

-------

local login to My_Laptop1: <=== same as before

mylocname

<password>

 

-------

Retro Prefs Security

(*) Run Retrospect as the logged-in user (quit & restart Retro after this)

 

-------

When trying to access the network drive as a \\UNC destination, works fine.

Doesn't ask for server/volume/Connect as/Password info. ****************

Link to comment
Share on other sites

Today I happened to connect to another network drive:

 

\\filer\hwsync\projects\MTV_Designs\PMM4F_backup

 

This worked OK from the Windows Explorer, although it did display a popup and ask for my login name & password (corp\username & password) since, as I noted before, I'm running from a workgroup PC while connecting to stuff with domain permissions. Retrospect, even when supplied with the corp\username & password, still failed with this (-1017) if I set up the Security user to be the specified login user (same as logged in).

 

However, it occurred to me to try the following:

 

\\filer.mv.company.com\hwsync\projects\MTV_Designs\PMM4F_backup

 

Note the "mv.company.com" FQDN added to the end of the machine name. This behaved the same for the logged user (was still able to connect from Windows Explorer) *but* Retrospect was now able to work OK (given the same corp\username & password that failed before). So it *appears* that Retrospect is not tacking on the FQDN suffix to machine names the same way Windows Explorer does and must be told explicitly the full name (or IP?) of the target machine. I wonder if Retro could provide a better error message (can't find machine != login password failed. Can it tell the diff?) or could include the FQDN (from DHCP?) the same way Windows does?

Link to comment
Share on other sites

So it "works" in the sense that with the \\filer....\path set up and after I enter the domain login (corp\userID & password) Retrospect is able to backup (Data Dup) to the specified destination. Note that this is a different ID (localPC\loginname & password) that is set for the RunAsSpecifiedUser security option.

 

However what *doesn't* work is that Retrospect doesn't seem to *remember* this ID between sessions (don't have have to reboot, just have the machine in standby for a while. Quit out of Retro and start again). At the next scheduled launch, Retro reports that it can't access (error -1017) the destination, and it has this same behavior if I launch it manually. After I *again* open up the backup dest. dialog and *again* manually enter the login (corp\userID & password), Retro runs the next backup without errors. So this doesn't allow *unattended* backups to run.

Link to comment
Share on other sites

Hi,

 

Under "Configure" > "Volumes" > "My Network Places", are you seeing the network drive?

If so, can you right-click and choose "login as" on the network volume.

You can then put in the username and password and Retrospect will save the network disk authentication.

 

Thanks.

Link to comment
Share on other sites

Yes, I can see the network drive under the "Configure" > "Volumes" > "My Network Places" tab. And if I try to access it it works fine, after popping up a dialog where I enter by corp\userID & password. The problem is that it doesn't "stick." That is, it works OK as long as Retrospect is running, but if I quit Retrospect and restart it (no machine reboot), it *again* asks for login info the next time I try to open that "Configure" > "Volumes" > "My Network Places" network drive (or fails if it tries to auto-launch and run the backup).

 

So the root problem is that Retrospect is *not* saving the corp\userID & password login info. On the otherhand, the Widows Explorer does (pops up a login dialog but has a "[] Remember password" checkoff box). I would access the network drive using a mapped drive (i.e. Windows Explorer would remember the permissions and Retrospect would use the R:\path) but Retrospect doesn't see mapped drives.

 

Also, under the Backup Sets > Properties, the "Automatic Login" tab is greyed out.

 

And I'm running under an admin-level account (e.g. LocalUserID, which is the same account that Retrospect it set to use under its Properties > Security tab).

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...