Jump to content

Retro 5 & VXA Firewaire


Recommended Posts

Have been reading thru the thread, since I just joined. Haven't found this one -- yet.

 

I have NEVER had a successful backup to my (almost new) Ecrix VXA Firewire drive. (No SCSI adapters involved!)

 

 

 

Using a G4 - 500 w/ 2 gb memory, under OSX 10.1.4 retro 5.0

 

I'm trying to back up my startup partition, which contains just over 3 gigs of data.

 

 

 

Everything proceeds normally, up to the point when it actually has to write data. After scanning the folders, reading the icons, and choosing a tape for the backup, Retro does a "rewind" (I'm guessing to make sure it's at the start of the tape) then gives the following abort message:

 

"Trouble in Retrospect" (an understatement, I'm guessing...)

 

Internal consistency check failed

 

Assertion check at "dev.c-1047"

 

 

 

The "Knowledge Base" has no reference to that particular message.

 

I've tried several different tapes (all new) with the same result.

 

It works fine in OS9, but has NEVER worked in OSX.

 

 

Link to comment
Share on other sites

The knowledgebase does have a number of entries on general assert troubleshooting that may be helpful.

 

 

 

What version of Retrospect is this exactly?

 

 

 

Have you tried reinstalling, or replacing your preferences file?

 

 

 

What happens if you try backing up to a file backup set stored on the local drive?

Link to comment
Share on other sites

Since it was a rainy day yesterday, I completely reformatted the partition and reloaded everything.. from the OS (10.1.4) through Retro 5.0, then did the 5.0.205 update. All reloading was done from original program CDs, so I'm pretty sure the software is pristine.

 

 

 

The results are the same : Assertion check at "dev.c-1047"

 

 

 

I've found several "Knowledge Base" entries in this general area (none for that particular error) and they all seem to end the same way.. suggesting you get the latest version of Retro.

 

 

 

At the moment, I don't have a spare local volume to back up to..

 

 

 

I've been an Ultrix/Irix/Linux system admin for more than 20 years. Can someone tell me what "dev.c-1047" is? The code must refer to a particular area, even if it's not referring to a unix "device."

 

 

 

Any suggestions?

Link to comment
Share on other sites

> Can someone tell me what "dev.c-1047" is?

 

 

 

The message probably refers to the source code for Retrospect itself (e.g. a file called dev.c, line 1047), not to a unix device. The source code contains an "assertion" that some condition is true, and you saw the message because you have something unusual going on. You typically only see messages like this when something very unexpected happens (like in the Princess Bride, inconceivable!), assertions are not usually seen by the customer since all of the likely errors are covered with more informative messages and/or recovery code.

 

 

 

> Any suggestions?

 

 

 

Try backing up just one folder, both to a file backup set, and to the VXA drive. There might be something wacky about your files, or something wacky about your VXA drive, you want to try some variations to narrow down the problem.

Link to comment
Share on other sites

Here's an update. The ECRIX DRIVE plug-in released today (30 May) seems to have solved the problem. I don't know what Dantz did, but I'm actually in the middle of a backup now on my other machine.

 

I've never gotten this far into a backup before. Its done about 6 gigs of an 18 gig partition.

 

 

 

I'm crossing my fingers until it completes.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...